summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorPaco Pascal2022-05-14 14:51:52 -0400
committerPaco Pascal2022-05-14 14:51:52 -0400
commit406dab4d4f3ecc4e84226db781a5cba75e0103b1 (patch)
tree896028f319e9e69f4ed246628fa66bf03f6ca939 /PKGBUILD
downloadaur-406dab4d4f3ecc4e84226db781a5cba75e0103b1.tar.gz
Initial release
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD31
1 files changed, 31 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..a5b7fe949456
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,31 @@
+# Maintainer: Paco Pascal <me@pacopascal.com>
+_pkgname=chicken-marks
+pkgname="$_pkgname-git"
+pkgver=latest
+pkgrel=1
+pkgdesc=""
+arch=($CARCH)
+url='https://github.com/FragmentedCurve/chicken-marks'
+license=('BSD')
+depends=(openssl)
+makedepends=(chicken openssl)
+conflicts=("${pkgname%-git}")
+provides=("${pkgname%-git}")
+source=('git+https://github.com/FragmentedCurve/chicken-marks.git')
+md5sums=('SKIP')
+
+build() {
+ cd "$_pkgname"
+ make eggs
+ make CHICKEN_CSC=chicken-csc
+}
+
+check() {
+ cd "$_pkgname"
+}
+
+package() {
+ cd "$_pkgname"
+ mkdir -p "$pkgdir/usr/bin/"
+ install marks "$pkgdir/usr/bin/"
+}