summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorChocobo12020-10-03 14:02:54 +0800
committerChocobo12020-10-03 14:02:54 +0800
commit7eda578f9b45744046e40122b8a661f59542bddb (patch)
treef846e463e48f8f3651021ea3c57b2e6ac73eed7d /PKGBUILD
parente5213627d8535ca48a492fd9068a40fa09b013e8 (diff)
downloadaur-chihaya.tar.gz
upgpkg: chihaya 1.0.2-4
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD16
1 files changed, 10 insertions, 6 deletions
diff --git a/PKGBUILD b/PKGBUILD
index b5b3695bb2dd..911e6b97a65e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname=chihaya
pkgver=1.0.2
-pkgrel=3
+pkgrel=4
pkgdesc="A customizable, multi-protocol BitTorrent tracker"
arch=('i686' 'x86_64')
url="https://github.com/chihaya/chihaya"
@@ -18,6 +18,12 @@ sha256sums=('17207aeaf1887befba4a100df4e860000fe2e4747ab0c518aad98005606b05fd'
'SKIP')
+export CGO_CPPFLAGS="${CPPFLAGS}"
+export CGO_CFLAGS="${CFLAGS}"
+export CGO_CXXFLAGS="${CXXFLAGS}"
+export CGO_LDFLAGS="${LDFLAGS}"
+export GOFLAGS="-buildmode=pie -ldflags=-linkmode=external -trimpath -modcacherw" # -mod=readonly
+
build() {
cd "$pkgname-$pkgver"
@@ -25,17 +31,15 @@ build() {
GO111MODULE=on \
go build \
- -buildmode=pie \
- -ldflags "-extldflags $LDFLAGS" \
- -trimpath \
- -modcacherw \
./cmd/...
}
check() {
cd "$pkgname-$pkgver"
- go test -bench $(go list ./...)
+ go test \
+ -bench \
+ $(go list ./...)
}
package() {