summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorSigmund2015-07-09 00:19:01 +0100
committerSigmund2015-07-09 00:19:01 +0100
commitf9ae74a7465a0a00634bd8e1eceec8f51e2fdb37 (patch)
tree048c6a6d83f8a21131a75e6de747e35f74729281 /PKGBUILD
downloadaur-f9ae74a7465a0a00634bd8e1eceec8f51e2fdb37.tar.gz
Initial import
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD35
1 files changed, 35 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..114c2fe6bda2
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,35 @@
+# Maintainer: Sigmund Vestergaard <sigmundv at gmail dot com>
+# Contributor: Jakob Nixdorf <jakob.nixdorf@online.de>
+# Contributor: Evangelos Foutras <foutrelis@gmail.com>
+
+pkgname=childsplay
+pkgver=2.6.5
+pkgrel=2
+pkgdesc="A suite of educational games for young children"
+arch=('i686' 'x86_64')
+url="http://www.childsplay.mobi"
+license=('GPL')
+depends=('python2-pygame' 'pygtk' 'python2-sqlalchemy' 'python2-numpy')
+optdepends=('childsplay-alphabet-sounds')
+install=childsplay.install
+source=(http://download.savannah.gnu.org/releases/childsplay/$pkgname-$pkgver.tgz
+ childsplay.desktop childsplay)
+sha256sums=('16b232db3e1806e37748ecf563523cfd7da78fe6b86a625c63e58993b73ca88a'
+ '84414248cb8b55d73569414884ef2cbd8c10f3ddf7803d10f912a2f3fcf42e5f'
+ '487b8649729b3d8fae8c7d8fb2f76450abf516354e6b4c0d7bf280332ff8f1b1')
+
+package() {
+ cd $srcdir
+
+ mkdir -p "$pkgdir/usr/local/games/"
+ mkdir -p "$pkgdir/usr/bin/"
+ cp -R "$pkgname-$pkgver" "$pkgdir/usr/local/games/$pkgname"
+
+ install -D -m755 "$srcdir/childsplay" "$pkgdir/usr/local/games/$pkgname/childsplay"
+ install -D -m644 "$srcdir/childsplay.desktop" \
+ "$pkgdir/usr/share/applications/childsplay.desktop"
+ install -D -m644 "$pkgname-$pkgver/lib/SPData/themes/childsplay/logo_cp_32x32.xpm" \
+ "$pkgdir/usr/share/pixmaps/childsplay.xpm"
+}
+
+# vim:set ts=2 sw=2 et: