summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorTomasz Zok2024-03-22 11:26:40 +0100
committerTomasz Zok2024-03-22 11:27:02 +0100
commit1825315910d62323420f450c9edf3f6ba16a87a6 (patch)
treec7026513c871ef7c2d60b272743431f45a14d965 /PKGBUILD
parent1fa364854643a4e36e5d0aa1e9329fa381708b7f (diff)
downloadaur-chimerax.tar.gz
Add .desktop file
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD9
1 files changed, 6 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index dbc3617d956d..555d18be8c36 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,15 +2,16 @@
# Inspired by PKGBUILD of ucsf-chimera
pkgname=chimerax
pkgver=1.7
-pkgrel=1
+pkgrel=2
pkgdesc="UCSF ChimeraX (or simply ChimeraX) is the next-generation molecular visualization program from the Resource for Biocomputing, Visualization, and Informatics (RBVI), following UCSF Chimera."
arch=(x86_64)
url="https://www.cgl.ucsf.edu/chimerax/"
license=(custom)
depends=(libffi6 libxcrypt-compat)
options=(!strip)
-source=(LICENSE)
-sha256sums=('4361604379b11e73ad942144ef84aaf479815f80265f98fed9879f3c82e3aa8d')
+source=(LICENSE chimerax.desktop)
+sha256sums=('4361604379b11e73ad942144ef84aaf479815f80265f98fed9879f3c82e3aa8d'
+ 'caa99276e5afccf36af41892d223fd1698cdf87a190f1abf1a751b2cf114c4fb')
_major=$(echo ${pkgver} | awk -F. '{ if (NF >= 2) { print $1 "." $2 } else print $1 }')
_source=https://www.rbvi.ucsf.edu/chimerax/cgi-bin/secure/chimerax-get.py
@@ -42,7 +43,9 @@ prepare() {
package() {
cd "${srcdir}"
install -d "${pkgdir}/opt/chimerax" "${pkgdir}/usr/bin"
+ install -Dm644 "${srcdir}/${pkgname}-${pkgver}/share/ChimeraX-icon.svg" "${pkgdir}/usr/share/pixmaps/ChimeraX-icon.svg"
install -Dm644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+ install -Dm644 chimerax.desktop "${pkgdir}/usr/share/applications/chimerax.desktop"
cp -R "${pkgname}-${pkgver}"/{bin,include,lib,share} "${pkgdir}/opt/chimerax/"
ln -s "/opt/chimerax/bin/ChimeraX" "${pkgdir}/usr/bin"
}