summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorpikakolendo022024-11-28 11:58:26 +0800
committerpikakolendo022024-11-28 11:58:26 +0800
commit4bb60d0aef4d01c8f6f80799cdb4dafcc59cd154 (patch)
treeb27f5bee178c7407ae20388662cea091888ad849 /PKGBUILD
parent1825315910d62323420f450c9edf3f6ba16a87a6 (diff)
downloadaur-4bb60d0aef4d01c8f6f80799cdb4dafcc59cd154.tar.gz
1.8
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD23
1 files changed, 15 insertions, 8 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 555d18be8c36..eb902300ef9f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,13 +1,15 @@
-# Maintainer: Tomasz Zok <tomasz dot zok at gmail dot com>
+# Maintainer: pika02 <pikakolendo02 at gmail dot com>
+# Contributer: Tomasz Zok <tomasz dot zok at gmail dot com>
# Inspired by PKGBUILD of ucsf-chimera
pkgname=chimerax
-pkgver=1.7
-pkgrel=2
+pkgver=1.8
+pkgrel=1
pkgdesc="UCSF ChimeraX (or simply ChimeraX) is the next-generation molecular visualization program from the Resource for Biocomputing, Visualization, and Informatics (RBVI), following UCSF Chimera."
arch=(x86_64)
url="https://www.cgl.ucsf.edu/chimerax/"
license=(custom)
depends=(libffi6 libxcrypt-compat)
+makedepends=(ostree)
options=(!strip)
source=(LICENSE chimerax.desktop)
sha256sums=('4361604379b11e73ad942144ef84aaf479815f80265f98fed9879f3c82e3aa8d'
@@ -15,8 +17,8 @@ sha256sums=('4361604379b11e73ad942144ef84aaf479815f80265f98fed9879f3c82e3aa8d'
_major=$(echo ${pkgver} | awk -F. '{ if (NF >= 2) { print $1 "." $2 } else print $1 }')
_source=https://www.rbvi.ucsf.edu/chimerax/cgi-bin/secure/chimerax-get.py
-_file=ChimeraX-${pkgver}.tar.gz
-_filepath=${_major}/linux/${_file}
+_file=ChimeraX-${pkgver}.flatpak
+_filepath=${_major}/flatpak/${_file}
prepare() {
cd "${srcdir}"
@@ -29,15 +31,20 @@ prepare() {
echo 'IMPORTANT: By downloading you accept the UCSF ChimeraX Non-Commercial Software License Agreement!'
echo 'IMPORTANT: You can find the license agreement here: https://aur.archlinux.org/cgit/aur.git/plain/LICENSE?h=chimerax'
echo 'IMPORTANT: If you do not agree, please press Ctrl-C now.'
- echo 'IMPORTANT: Downloading in 10 seconds...'
+ echo 'IMPORTANT: Downloading in 5 seconds...'
- sleep 10
+ sleep 5
_ident="$(curl -s -F file="${_filepath}" -F choice=Accept "${_source}")"
_ident="$(echo "$_ident" | grep 'a href' | awk -F'[?=&]' '{print $4}')"
_ident="$(echo "$_ident" | sed 's@+@ @g;s@%@\\x@g' | xargs -0 printf "%b")"
curl -L -F file="${_filepath}" -F ident="${_ident}" -F choice=Notified "${_source}" -o "${_file}"
- tar xf "${_file}"
+
+ # extract flatpak bundle, ref: https://github.com/flatpak/flatpak/issues/126#issuecomment-227068860
+ ostree init --repo=repo --mode=bare-user
+ ostree static-delta apply-offline --repo=repo ${_file}
+ ostree checkout --repo=repo -U $(basename $(echo repo/objects/*/*.commit | cut -d/ -f3- --output-delimiter= ) .commit) outdir
+ mv "outdir/files" "${srcdir}/${pkgname}-${pkgver}"
}
package() {