summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorTomasz Zok2023-06-13 12:18:55 +0200
committerTomasz Zok2023-06-13 12:18:55 +0200
commit70822acf9dfa4eb5bfaf68696a842ccb18746cfe (patch)
tree720ccdc1304140a7a0f61322f92a4340cf2a0bc6 /PKGBUILD
parentd16b2a23fceeba0154f7d496f88b6ff334656372 (diff)
downloadaur-70822acf9dfa4eb5bfaf68696a842ccb18746cfe.tar.gz
Update to 1.6.1
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD9
1 files changed, 5 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 8051727a617f..37a7aeb0b994 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,8 +1,8 @@
# Maintainer: Tomasz Zok <tomasz dot zok at gmail dot com>
# Inspired by PKGBUILD of ucsf-chimera
pkgname=chimerax
-pkgver=1.5
-pkgrel=3
+pkgver=1.6.1
+pkgrel=1
pkgdesc="UCSF ChimeraX (or simply ChimeraX) is the next-generation molecular visualization program from the Resource for Biocomputing, Visualization, and Informatics (RBVI), following UCSF Chimera."
arch=(x86_64)
url="https://www.cgl.ucsf.edu/chimerax/"
@@ -12,9 +12,10 @@ options=(!strip)
source=(LICENSE)
sha256sums=('4361604379b11e73ad942144ef84aaf479815f80265f98fed9879f3c82e3aa8d')
-_source=https://www.cgl.ucsf.edu/chimerax/cgi-bin/secure/chimerax-get.py
+_major=$(echo ${pkgver} | awk -F. '{ if (NF >= 2) { print $1 "." $2 } else print $1 }')
+_source=https://www.rbvi.ucsf.edu/chimerax/cgi-bin/secure/chimerax-get.py
_file=ChimeraX-${pkgver}.tar.gz
-_filepath=${pkgver}/linux/ChimeraX-${pkgver}.tar.gz
+_filepath=${_major}/linux/${_file}
prepare() {
cd "${srcdir}"