summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorMichael Straube2020-05-12 22:45:34 +0200
committerMichael Straube2020-05-12 22:45:34 +0200
commit6d8b2678f0826aac38264a0b9e5f98beb2c32ec7 (patch)
treecd7b597da8c6002d82f3eb20fed74356fec34ede /PKGBUILD
parentf9d50677b55d2a692786ce124269743b80b51e2a (diff)
downloadaur-6d8b2678f0826aac38264a0b9e5f98beb2c32ec7.tar.gz
Fix build (gcc10)
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD26
1 files changed, 19 insertions, 7 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 2e703f8317eb..0820fa8e6002 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -14,26 +14,38 @@ provides=('chipmachine')
conflicts=('chipmachine')
source=("git+https://github.com/sasq64/chipmachine.git"
"git+https://github.com/sasq64/apone.git"
- "git+https://github.com/sasq64/musicplayer.git")
+ "git+https://github.com/sasq64/musicplayer.git"
+ "0001-chipmachine-rpath.patch"
+ "0002-musicplayer-cmake314.patch"
+ "0003-chipmachine-gcc10.patch")
sha512sums=('SKIP'
'SKIP'
- 'SKIP')
+ 'SKIP'
+ '59f5d6f5e34a5fa9fb668f7272415d02c8ebca00d37271f534af81df1698bc415c8ace2a8fe6260972006ec144409dbd3143531816169e6692c1ba1173ec6ad2'
+ '0ea7b7d1cd46c7adafebcffefe1a92c5bfbdc4e9aa8849a617aff78cdceb216d9007649c1e80a616c650196dba4dd564215aa48b89c3b907fd8cd6561a1840bf'
+ '1cf5640b76f7ca3a03b61d70cfccc9e7600e9f2ed15193e55feed6b07c8501fff32999963e5fa751556b72e1ff85f6efdc8d0623a33883f9ddde640018e78c4f')
pkgver() {
cd chipmachine
- git describe --long --tags | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
+ git describe --long --tags | sed 's/^v//;s/-/.r/;s/-/./g'
}
prepare() {
mkdir -p build
- # remove insecure rpath
- sed -i '/link_directories(\/usr\/local\/lib.*/d' chipmachine/CMakeLists.txt
- # fix linking errors with cmake >= 3.14.0
- sed -i '/target_link_libraries(uade PRIVATE ws2_32)/d' musicplayer/plugins/uadeplugin/CMakeLists.txt
+ # Remove insecure rpath
+ patch -d chipmachine -Np1 < 0001-chipmachine-rpath.patch
+ # Fix linking errors with cmake >= 3.14.0
+ patch -d musicplayer -Np1 < 0002-musicplayer-cmake314.patch
+ # Fix build errors with gcc10
+ patch -d chipmachine -Np1 < 0003-chipmachine-gcc10.patch
}
build() {
cd build
+
+ # Workaround for gcc10 linking errors
+ export CFLAGS+=" -fcommon"
+
cmake ../chipmachine
make
}