summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorAndrew Sun2020-10-01 22:45:35 -0400
committerAndrew Sun2020-10-01 22:45:35 -0400
commit322f8f1fcdf7eb9aad0b50d9b5bcea12d6a692b5 (patch)
tree0321dfcd89560039d12215959297ddaf308d9833 /PKGBUILD
parent7d17a7f166afc81ae6989189927b90cbdcad3a5d (diff)
downloadaur-chipmunk.tar.gz
fix build without <sys/sysctl.h>
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD18
1 files changed, 13 insertions, 5 deletions
diff --git a/PKGBUILD b/PKGBUILD
index ec547b6efddd..0f4bc1a43c20 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,18 +1,26 @@
-# Maintainer: Massimiliano Torromeo <massimiliano.torromeo@gmail.com>
+# Maintainer: Andrew Sun <adsun701 at gmail dot com>
+# Contributor: Massimiliano Torromeo <massimiliano dot torromeo at gmail dot com>
# Contributor: Astor Castelo <amcastelo[at]gatech[dot]edu>
-# Contributor: Fabio Volpe <volpefabio@gmail.com>
+# Contributor: Fabio Volpe <volpefabio at gmail dot com>
pkgname=chipmunk
pkgver=7.0.3
-pkgrel=1
+pkgrel=2
pkgdesc="A high-performance 2D rigid body physics library"
arch=('i686' 'x86_64')
url="https://chipmunk-physics.net/"
license=('MIT')
depends=('glibc')
makedepends=('cmake')
-source=("${pkgname}-${pkgver}.tar.gz"::"https://github.com/slembcke/Chipmunk2D/archive/Chipmunk-${pkgver}.tar.gz")
-sha256sums=('1e6f093812d6130e45bdf4cb80280cb3c93d1e1833d8cf989d554d7963b7899a')
+source=("${pkgname}-${pkgver}.tar.gz"::"https://github.com/slembcke/Chipmunk2D/archive/Chipmunk-${pkgver}.tar.gz"
+ "no-sys-sysctl-header.patch")
+sha256sums=('1e6f093812d6130e45bdf4cb80280cb3c93d1e1833d8cf989d554d7963b7899a'
+ 'adf74765488c932464c33609775b3d9d8043a79162efc2d0f49b42a38d447e8a')
+
+prepare() {
+ cd "${srcdir}/Chipmunk2D-Chipmunk-${pkgver}"
+ patch -Np1 -i "${srcdir}/no-sys-sysctl-header.patch"
+}
build() {
mkdir -p "${srcdir}/build" && cd "${srcdir}/build"