summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorCédric Connes2019-10-06 15:52:11 +0200
committerCédric Connes2019-10-06 15:52:11 +0200
commit6f3bab0d3803b4208cdcae2e3ebda881db52f866 (patch)
tree667870dc51c363b1c6589928b951e27cf02c2619 /PKGBUILD
parenta9a952cc6220a0d6143f6c1fd9a2f62cee188bde (diff)
downloadaur-6f3bab0d3803b4208cdcae2e3ebda881db52f866.tar.gz
Temporary workaround for gzip extraction
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD7
1 files changed, 6 insertions, 1 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 8b72a1adfaed..94f3d125257c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname=chisel-tunnel
pkgver=1.3.1
-pkgrel=1
+pkgrel=2
pkgdesc="A fast TCP tunnel over HTTP"
arch=('i686' 'x86_64' 'arm' 'armv6h' 'armv7h' 'aarch64')
url="https://github.com/jpillora/chisel"
@@ -24,6 +24,11 @@ md5sums_armv6h=('8f5a59b2b3d84ff8ed075695a912e0c7')
md5sums_armv7h=('8f5a59b2b3d84ff8ed075695a912e0c7')
md5sums_aarch64=('8f5a59b2b3d84ff8ed075695a912e0c7')
+prepare() {
+ # Temporary, until this bug gets fixed: https://bugs.astron.com/view.php?id=112
+ zcat "chisel_${pkgver}_$CARCH.gz" > "chisel_${pkgver}_$CARCH"
+}
+
package() {
install -D -m755 "chisel_${pkgver}_$CARCH" "$pkgdir/usr/bin/chisel"
install -D -m644 "README_${pkgver}.md" "$pkgdir/usr/share/doc/$pkgname/README.md"