summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorCédric Connes2017-04-17 16:15:24 +0200
committerCédric Connes2017-04-17 16:15:24 +0200
commit8187f704b112e1f5274d729226b0d8001e0e7dca (patch)
tree79f169a69cf17628850f4bc702d74959ddcf7885 /PKGBUILD
downloadaur-8187f704b112e1f5274d729226b0d8001e0e7dca.tar.gz
Initial commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD24
1 files changed, 24 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..87c0ef9fc0ab
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,24 @@
+# Maintainer: Cédric Connes <cedric.connes@gmail.com>
+
+pkgname=chisel-tunnel
+pkgver=1.2.2
+pkgrel=1
+pkgdesc="A fast TCP tunnel over HTTP"
+arch=('i686' 'x86_64')
+url="https://github.com/jpillora/chisel"
+license=('MIT')
+source=("https://raw.githubusercontent.com/jpillora/chisel/$pkgver/README.md"
+ "https://raw.githubusercontent.com/jpillora/chisel/$pkgver/example/users.json")
+source_i686=("chisel_i686.gz::https://github.com/jpillora/chisel/releases/download/$pkgver/chisel_linux_386.gz")
+source_x86_64=("chisel_x86_64.gz::https://github.com/jpillora/chisel/releases/download/$pkgver/chisel_linux_amd64.gz")
+md5sums=('a4b9322a6a38e3cdcd11f091241295d4'
+ '94a1b56e4b075e50eca71637dca2ba27')
+md5sums_i686=('588094f95dd8a4022280bbb38c6a5d1a')
+md5sums_x86_64=('69e4a6c7322038beea821749568cc2f3')
+
+package() {
+ install -D -m755 "chisel_$CARCH" "$pkgdir/usr/bin/chisel"
+ sed -n '/^#### MIT License$/,$ {s/^#### //; p}' README.md > LICENSE
+ install -D -m644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+ install -D -m644 -t "$pkgdir/usr/share/doc/$pkgname" README.md users.json
+}