summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorchaca2019-10-28 21:19:50 +0400
committerchaca2019-10-28 21:19:50 +0400
commit736918d3253f3634587f6158bd052c8084c19451 (patch)
tree106979295ea3b81de6ea02db6cdc451bfaef620d /PKGBUILD
downloadaur-736918d3253f3634587f6158bd052c8084c19451.tar.gz
Initiaal commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD26
1 files changed, 26 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..0742b91d47ee
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,26 @@
+# Maintainer: ChacaS0 <incoming+chacas0-chksum-13830438-issue-@incoming.gitlab.com>
+pkgname=chksum-git
+pkgver=0.1
+pkgrel=1
+pkgdesc='Check and compare easily the checksum of a file.'
+arch=('x86_64')
+url="https://gitlab.com/ChacaS0/chksum"
+license=('Apache')
+conflicts=("chksum")
+makedepends=('git' 'go-pie')
+source=("git+https://gitlab.com/chacas0/chksum#branch=master")
+sha256sums=('SKIP')
+
+build() {
+ cd "$srcdir/chksum"
+ go build \
+ -trimpath \
+ -ldflags "-extldflags ${LDFLAGS}" \
+ .
+}
+
+package() {
+ cd "$srcdir/$pkgname"
+ install -Dm755 "$pkgname" "$pkgdir/usr/bin/chksum"
+ install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+} \ No newline at end of file