summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorAlan Witkowski2019-04-17 19:08:56 -0600
committerAlan Witkowski2019-04-17 19:08:56 -0600
commit2cd83bb0fb8dfe506d3d653708ddbd42608eeb9d (patch)
tree5c5b593d62d650d7054dbe29179608d0649a421e /PKGBUILD
parentb4276d4d6f3720dcca793b5c5f0e8591de1d0422 (diff)
downloadaur-2cd83bb0fb8dfe506d3d653708ddbd42608eeb9d.tar.gz
updated PKGBUILD to master branch
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD29
1 files changed, 15 insertions, 14 deletions
diff --git a/PKGBUILD b/PKGBUILD
index f5637bd3d68d..d1362d002c26 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,35 +1,36 @@
-# Maintainer: Taran Lynn <taranlynn0@gmail.com>
+# Maintainer: Alan Witkowski <alan.witkowski+aur@gmail.com>
+# Co-Maintainer: Taran Lynn <taranlynn0@gmail.com>
pkgname=choria-git
-pkgver=v0.4.2.r1305.g87ee046d
-pkgrel=2
+pkgver=r1578
+pkgrel=1
pkgdesc="A 2D MMORPG that's all about grinding and doing chores (development version)."
arch=('i686' 'x86_64')
url="https://github.com/jazztickets/choria"
license=('GPL3')
-depends=('gcc-libs' 'irrlicht' 'sqlite' 'glm' 'sdl2_image')
+depends=('gcc-libs' 'sdl2' 'sdl2_image' 'openal' 'libvorbis' 'libogg' 'freetype2' 'lua' 'glm' 'sqlite' 'jsoncpp' 'tinyxml2' 'zlib')
conflicts=('choria')
makedepends=('cmake')
source=("${pkgname}::git+https://github.com/jazztickets/choria")
sha256sums=('SKIP')
pkgver() {
- cd "$pkgname"
- git describe --long | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+ cd "$pkgname"
+ git log --oneline | wc -l | sed 's/^/r/'
}
prepare() {
- cd "$srcdir/$pkgname"
- git submodule init
- git submodule update
+ cd "$srcdir/$pkgname"
+ git submodule init
+ git submodule update
}
build() {
- cd "$srcdir/$pkgname"
- cmake -DCMAKE_INSTALL_PREFIX=/usr .
- make
+ cd "$srcdir/$pkgname"
+ cmake -DCMAKE_INSTALL_PREFIX=/usr .
+ make
}
package() {
- cd "$srcdir/$pkgname"
- make DESTDIR="$pkgdir/" install
+ cd "$srcdir/$pkgname"
+ make DESTDIR="$pkgdir/" install
}