summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorJames An2014-10-22 02:56:37 -0400
committerJames An2014-10-22 02:56:37 -0400
commit6b74d169b4e066c23353a11c0c63905f79938905 (patch)
treea4a6720dc4f43d164279bfcac3c5f26e018f9972 /PKGBUILD
downloadaur-6b74d169b4e066c23353a11c0c63905f79938905.tar.gz
Added chrome-remote-desktop as new maintainer before changes.
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD48
1 files changed, 48 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..6757d23494ad
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,48 @@
+# Maintainer: Mateus Rodrigues Costa <charles [dot] costar [at] gmail [dot] com>
+
+pkgname=chrome-remote-desktop
+pkgver=37.0.2062.28
+pkgrel=2
+pkgdesc="Allows you to securely access your computer over the Internet through Chrome."
+url="https://chrome.google.com/webstore/detail/gbchcmhmhahfdphkhkmpfmihenigjmpp"
+arch=('i686' 'x86_64')
+license=('BSD')
+install=$pkgname.install
+depends=('python2' 'python2-psutil' 'gconf' 'gtk2' 'nss'
+ 'xorg-xdpyinfo' 'xorg-setxkbmap' 'xorg-server-xvfb' 'xorg-xauth')
+source=("chrome-remote-desktop.service")
+md5sums=('cde1758e875ff114cc8153edb7087d2a')
+_arch=i386
+if [ "$CARCH" == i686 ]; then
+ md5sums+=('31ea1a11c1f76d9764694b18ee5b15ea')
+elif [ "$CARCH" == x86_64 ]; then
+ _arch=amd64
+ md5sums+=('e0ebe47f87f7af1b4b819b3cf742a69f')
+fi
+source+=(${pkgname}_${pkgver}_$_arch.deb::https://dl.google.com/linux/direct/${pkgname}_current_$_arch.deb)
+
+package() {
+ msg2 "Extracting data.tar.gz"
+ bsdtar -xf data.tar.gz -C "$pkgdir/"
+
+ msg2 "Patching Python script"
+ sed -e '1 s/python/python2/' \
+ -e '/^.*sudo_command =/ s/"gksudo .*"/"pkexec"/' \
+ -e '/^.*command =/ s/s -- sh -c/s sh -c/' \
+ -i "$pkgdir"/opt/google/chrome-remote-desktop/chrome-remote-desktop
+
+ msg2 "Removing things that won't work"
+ rm -R "$pkgdir"/etc/cron.daily/
+ rm -R "$pkgdir"/etc/init.d/
+ rm -R "$pkgdir"/etc/pam.d/
+
+ msg2 "They forgot the LICENSE file, using the copyright file instead"
+ install -Dm644 "$pkgdir"/usr/share/doc/$pkgname/copyright "$pkgdir"/usr/share/licenses/$pkgname/copyright
+
+ msg2 "Adding a systemd user service"
+ install -Dm644 "$srcdir"/$pkgname.service "$pkgdir"/usr/lib/systemd/user/$pkgname.service
+
+ msg2 "Creating symlinks for chromium compatibility"
+ mkdir -p "$pkgdir"/etc/chromium/native-messaging-hosts
+ ln -sr "$pkgdir"/etc/opt/chrome/native-messaging-hosts/* "$pkgdir"/etc/chromium/native-messaging-hosts
+}