summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorFredy García2023-08-14 19:22:43 -0500
committerFredy García2023-08-14 19:22:43 -0500
commitd7b5a633c832b757589be3a733c097dae5746f8b (patch)
treef133b80574a5973cde96458aa013428b115029eb /PKGBUILD
parent94e14118549a6afabedd75ed50a29008e926ffa2 (diff)
downloadaur-d7b5a633c832b757589be3a733c097dae5746f8b.tar.gz
Upgrading to version 116.0.5845.10, fixing xdg issues.
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD13
1 files changed, 9 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index de6cb79c3cae..3c1832a7e77f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,30 +5,32 @@
# Contributor: Mateus Rodrigues Costa <charles [dot] costar [at] gmail [dot] com>
pkgname=chrome-remote-desktop
-pkgver=115.0.5790.10
+pkgver=116.0.5845.10
pkgrel=1
pkgdesc="Access other computers or allow another user to access your computer securely over the Internet"
arch=("x86_64")
url="https://remotedesktop.google.com"
license=("BSD")
-depends=("gtk3" "libutempter" "libxss" "nss" "python-psutil" "xorg-server-xvfb" "xorg-setxkbmap" "xorg-xauth" "xorg-xdpyinfo" "xorg-xrandr")
+depends=("gtk3" "libutempter" "libxss" "nss" "python-packaging" "python-psutil" "python-pyxdg" "xf86-video-dummy" "xorg-server-xvfb" "xorg-setxkbmap" "xorg-xauth" "xorg-xdpyinfo" "xorg-xrandr")
install="${pkgname}.install"
source=(
"${pkgname}-${pkgver}.deb::https://dl.google.com/linux/${pkgname}/deb/pool/main/${pkgname:0:1}/${pkgname}/${pkgname}_${pkgver}_amd64.deb"
"${pkgname}.service"
"pamrule"
"crd"
+ "xdg-base-directory.patch"
)
sha256sums=(
- "a49ac21281a220c17afcfdcdf4a274d1e094927aea135f53ee7eb39a2c1b07a4"
+ "84396947d787cbe90073e944c272856871086c2671d82ac59f6ee9f460476459"
"e5da5ae89b5bc599f72f415d1523341b25357931b0de46159fce50ab83615a4b"
"fcc38269eb1cc902abff9688eda9377a22367e39b9f111f87c0dd8e77adb82e2"
"021110f49d465294517eec92eeb24ebca41e264ef33cbdda78732add1f269d02"
+ "993cff7024be6c4e3b2c0f84287adb51711a30c7dd965bb5b8687980f496e1a5"
)
# curl -qs https://dl.google.com/linux/chrome-remote-desktop/deb/dists/stable/main/binary-amd64/Packages | grep "^Version\|^SHA256" | awk '{print $2}'
-build() {
+prepare() {
cd "${srcdir}"
bsdtar -xf data.tar.xz -C .
@@ -37,6 +39,9 @@ build() {
rm -R "${srcdir}/etc/cron.daily"
rm -R "${srcdir}/etc/init.d"
rm -R "${srcdir}/etc/pam.d"
+
+ # Fix problem with missing import xdg.BaseDirectory, fixing xorg_binary location
+ patch -Np1 -i "${srcdir}/xdg-base-directory.patch"
}
package() {