summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorThomas Hebb2013-09-14 20:54:14 -0400
committerThomas Hebb2013-09-14 20:54:14 -0400
commitd5d347d160167416c94a9ff2b2b51939ff4417e6 (patch)
tree555f1c631e5937e8b41a019f965491a9606a1837 /PKGBUILD
downloadaur-d5d347d160167416c94a9ff2b2b51939ff4417e6.tar.gz
Initial commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD32
1 files changed, 32 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..28af3b3c4229
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,32 @@
+# Maintainer: Thomas Hebb <tommyhebb@gmail.com>
+pkgname=chromecast-tools-git
+pkgver=4.23c235e
+pkgrel=1
+pkgdesc="A set of simple utilities for working with Chromecast USB boot image files"
+arch=('i686' 'x86_64')
+url="https://github.com/tchebb/chromecast-tools"
+license=('GPL')
+depends=()
+makedepends=('git')
+source=('git+https://github.com/tchebb/chromecast-tools.git')
+sha256sums=('SKIP')
+
+pkgver() {
+ cd "$srcdir/chromecast-tools"
+ printf "%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+build() {
+ cd "$srcdir/chromecast-tools"
+
+ for SRC in *.c ; do
+ make ${SRC%.c}
+ done
+}
+
+package() {
+ cd "$srcdir/chromecast-tools"
+
+ install -d "$pkgdir/usr/bin/"
+ install -t "$pkgdir/usr/bin/" $(ls | grep -ve '.c^')
+}