summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorRaphael Freudiger2015-08-17 20:10:18 +0200
committerRaphael Freudiger2015-08-17 20:10:18 +0200
commit06fef1f9e9a12e4e17290d5070b55bff0cdc1b1b (patch)
treeee6809abfdf99fa57bd20fa49f80d509dc7aa2e1 /PKGBUILD
downloadaur-06fef1f9e9a12e4e17290d5070b55bff0cdc1b1b.tar.gz
Initial commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD32
1 files changed, 32 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..dd8b73d80f36
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,32 @@
+# Maintainer: Raphael Freudiger <laser_b at gmx dot ch>
+pkgname=chromecastize-git
+pkgver=43.ef7305a
+pkgrel=1
+pkgdesc="Bash script to convert video files into Google Chromecast supported format."
+arch=('any')
+url="https://github.com/bc-petrkotek/chromecastize"
+license=('GPL')
+depends=('ffmpeg' 'mediainfo')
+makedepends=('git')
+source=('git+https://github.com/bc-petrkotek/chromecastize.git'
+ 'https://patch-diff.githubusercontent.com/raw/bc-petrkotek/chromecastize/pull/25.patch')
+md5sums=('SKIP'
+ '1b3bc12dbeabf8dbaa5b148d9c77296e')
+
+pkgver() {
+ cd "chromecastize"
+ printf "%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+build() {
+ cd "$srcdir/chromecastize"
+
+ git apply ../25.patch
+}
+
+package() {
+ cd "$srcdir/chromecastize"
+
+ install -d "$pkgdir/usr/bin/"
+ install -t "$pkgdir/usr/bin/" chromecastize.sh
+}