summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorbrent s2019-12-22 12:05:50 -0500
committerbrent s2021-02-18 14:52:15 -0500
commitff5f3e82b806143e2b1a796f3489f5d2de372c01 (patch)
tree95172622eb880741246d8d1dc03d1eb2d4fe2606 /PKGBUILD
parent8c5539f8abd3fd9a6f9e88ce175f00e317bfcf9e (diff)
downloadaur-ff5f3e82b806143e2b1a796f3489f5d2de372c01.tar.gz
adding chromedriver
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD36
1 files changed, 25 insertions, 11 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 4775539c36ed..705ae9943434 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,26 +1,40 @@
# Maintainer: brent s. <bts[at]square-r00t[dot]net>
-validpgpkeys=('748231EBCBD808A14F5E85D28C004C2F93481F6B')
+#validpgpkeys=('748231EBCBD808A14F5E85D28C004C2F93481F6B')
# Bug reports can be filed at https://bugs.square-r00t.net/index.php?project=3
# News updates for packages can be followed at https://devblog.square-r00t.net
pkgname=chromedriver-dev
-pkgver=77.0.3865.10
+pkgver=90.0.4412.3_855346
pkgrel=1
-pkgdesc="Standalone server which implements WebDriver's wire protocol (for google-chrome-dev)"
+pkgdesc="Standalone server which implements WebDriver's wire protocol (for google-chrome-dev, a.k.a. Canary)"
arch=( 'x86_64' )
url="https://sites.google.com/a/chromium.org/chromedriver/"
-license=( 'Apache' )
-depends=( 'google-chrome-dev' )
+license=('Apache')
+depends=('google-chrome-dev')
_pkgname=chromedriver
-conflicts=( 'chromium-dev' )
+conflicts=('chromium-dev')
install=
changelog=
noextract=()
-source=("https://chromedriver.storage.googleapis.com/${pkgver}/${_pkgname}_linux64.zip"
- "${_pkgname}_linux64.zip.sig")
-sha512sums=('8ae2156e708fd8754982b6124d5072bc3e746d332ea48bf1d9159c407e602b523e74c87b3f67d4bf4ab3c24fc0e2b1c1f292985f845d501c20ff68dd5c62bbd3'
- 'SKIP')
+# TODO: switch this with a bash variable expansion
+_pkgver=$(echo ${pkgver} | cut -f2 -d"_")
+#source=("${_pkgname}-${pkgver}_linux64.zip::https://chromedriver.storage.googleapis.com/${pkgver}/${_pkgname}_linux64.zip"
+#source=("https://commondatastorage.googleapis.com/chromium-browser-snapshots/index.html?prefix=Linux_x64/${_pkgver}/${_pkgname}_linux64.zip")
+source=("chromedriver_linux64.zip::https://www.googleapis.com/download/storage/v1/b/chromium-browser-snapshots/o/Linux_x64%2F${_pkgver}%2F${_pkgname}_linux64.zip?generation=1613675414795893&alt=media")
+# "${_pkgname}-${pkgver}_linux64.zip.sig")
+# "${_pkgname}_linux64.zip.sig")
+sha512sums=('SKIP')
+
+pkgver() {
+ cur_ver=$(echo ${pkgver} | cut -f1 -d"_")
+ # This is just... the dumbest thing.
+ # But it's what Google wants. Aparently.
+ # https://sites.google.com/a/chromium.org/chromedriver/chromedriver-canary
+ _pkgver=$(curl -sL "https://www.googleapis.com/download/storage/v1/b/chromium-browser-snapshots/o/Linux_x64%2FLAST_CHANGE?generation=1613675422448818&alt=media")
+ echo "${cur_ver}_${_pkgver}"
+}
+
package() {
mkdir -p "${pkgdir}/usr/bin/"
- install -D -m 755 "${srcdir}/${_pkgname}" "${pkgdir}/usr/bin/${pkgname}"
+ install -D -m 755 "${srcdir}/${_pkgname}_linux64/${_pkgname}" "${pkgdir}/usr/bin/${pkgname}"
}