summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorDaniel Playfair Cal2020-04-18 15:20:52 +1000
committerDaniel Playfair Cal2020-04-18 15:20:52 +1000
commit3c679f036143146ee23ce19a6fba7b3da1c406dc (patch)
tree801c6af7a3ccc13ffb22015e4a21b38637088830 /PKGBUILD
parentd60157861037f70068f0b8c8a7427b8040230160 (diff)
parent6e1ddc6cbfee92bbe7eb99f0a60456e6137976a8 (diff)
downloadaur-3c679f036143146ee23ce19a6fba7b3da1c406dc.tar.gz
Merge branch 'dev' into beta
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD50
1 files changed, 33 insertions, 17 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 5ee5fe0db4d0..fb310fe4d36a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,7 +5,7 @@
# Contributor: Daniel J Griffiths <ghost1227@archlinux.us>
pkgname=chromium-beta-ozone
-pkgver=81.0.4044.91
+pkgver=83.0.4103.14
pkgrel=1
_launcher_ver=6
pkgdesc="Chromium built with patches for wayland support via Ozone (beta channel)"
@@ -19,7 +19,8 @@ depends=('gtk3' 'nss' 'alsa-lib' 'xdg-utils' 'libxss' 'libcups' 'libgcrypt'
provides=('chromium')
conflicts=('chromium')
makedepends=('python' 'python2' 'gperf' 'yasm' 'mesa' 'ninja' 'nodejs' 'git'
- 'libpipewire02' 'clang' 'lld' 'gn' 'java-runtime-headless')
+ 'libpipewire02' 'clang' 'lld' 'gn' 'java-runtime-headless'
+ 'python2-setuptools')
optdepends=('pepper-flash: support for Flash content'
'libpipewire02: WebRTC desktop sharing under Wayland'
'kdialog: needed for file dialogs in KDE'
@@ -28,16 +29,28 @@ optdepends=('pepper-flash: support for Flash content'
install=chromium.install
source=(https://commondatastorage.googleapis.com/chromium-browser-official/chromium-$pkgver.tar.xz
chromium-launcher-$_launcher_ver.tar.gz::https://github.com/foutrelis/chromium-launcher/archive/v$_launcher_ver.tar.gz
- rename-Relayout-in-DesktopWindowTreeHostPlatform.patch
- rebuild-Linux-frame-button-cache-when-activation.patch
chromium-widevine.patch
- chromium-skia-harmony.patch)
-sha256sums=('cec9da1fe5c5a99e97e9ca29d0836b12239439ede40794e52a9a2fdef065d4ca'
+ chromium-skia-harmony.patch
+ 0001-Revert-RTCInsertableStreams-Make-RTCEncodedAudioFram.patch
+ 0002-Revert-RTCInsertableStreams-Make-RTCEncodedVideoFram.patch
+ 0003-Add-missing-algorithm-header-in-crx_install_error.cc.patch
+ 0004-libstdc-fix-incomplete-type-in-AXTree-for-NodeSetSiz.patch
+ 0005-Revert-Trace-ICU-object-creation-in-ICU.CreateInstan.patch
+ 0006-Revert-PM-Add-calculation-of-maximum-simultaneous-lo.patch
+ 0007-Add-missing-memory-header-in-trust_token_attribute_p.patch
+ 0008-Revert-FragmentItem-Two-fixes-for-outline.patch)
+sha256sums=('6e3d4853dcbd3c2375a1462a764102f6893c3b0505037e28c04bf90002e526e8'
'04917e3cd4307d8e31bfb0027a5dce6d086edb10ff8a716024fbb8bb0c7dccf1'
- 'ae3bf107834bd8eda9a3ec7899fe35fde62e6111062e5def7d24bf49b53db3db'
- '46f7fc9768730c460b27681ccf3dc2685c7e1fd22d70d3a82d9e57e3389bb014'
'709e2fddba3c1f2ed4deb3a239fc0479bfa50c46e054e7f32db4fb1365fed070'
- '771292942c0901092a402cc60ee883877a99fb804cb54d568c8c6c94565a48e1')
+ '771292942c0901092a402cc60ee883877a99fb804cb54d568c8c6c94565a48e1'
+ 'c53edc13ca335652608607e628284a79d91f5524d9b5e72a8f2d29b4d7618c75'
+ 'cf27aa2a98bc71686e3e0f482b720d7d25017158ab2c7d93b548b3578c4b53e2'
+ '9f2211edf347d54b8167a3b9d773e38aeabce5f98fb1932e7db1aeec845579f6'
+ '5db92d614aba64e9eb684f35e06f36786b74d5a1456308d4d40a65f12e32f62b'
+ '52b0129ac7db760078087a2839e257183f10df8e9f831ec07e6cfc8f5ba455eb'
+ '2b594ff5bc731897274027ddb79a77d247a52ef0990d574ec815b36082ac093a'
+ '91cc1ac6cd6568de8c45a3fb3c6b57fa9ea6e6ae6f2a05f1ff82677d0cdbdedb'
+ '771b862e16ff42e0d43d6f0f5fd49d65210732bb0ae19cc4ea18c2220b4cb041')
# Possible replacements are listed in build/linux/unbundle/replace_gn_files.py
# Keys are the names in the above script; values are the dependencies in Arch
@@ -46,7 +59,7 @@ declare -gA _system_libs=(
[flac]=flac
[fontconfig]=fontconfig
[freetype]=freetype2
- [harfbuzz-ng]=harfbuzz
+ # [harfbuzz-ng]=harfbuzz
[icu]=icu
[libdrm]=
#[libjpeg]=libjpeg
@@ -74,7 +87,7 @@ _google_api_key=AIzaSyDwr302FpOSkGRpLlUpPThNTDPbXcIn_FM
_google_default_client_id=413772536636.apps.googleusercontent.com
_google_default_client_secret=0ZChLK6AxeA3Isu96MkwqDR4
-# Branch point: 737173
+# Branch point: 756066
# Extra commits related specifically to wayland support:
# These consist of the above commits and their dependencies
@@ -95,10 +108,6 @@ prepare() {
third_party/blink/renderer/core/xml/parser/xml_document_parser.cc \
third_party/libxml/chromium/*.cc
- # https://crbug.com/1049258
- patch -Np1 -i ../rename-Relayout-in-DesktopWindowTreeHostPlatform.patch
- patch -Np1 -i ../rebuild-Linux-frame-button-cache-when-activation.patch
-
# Load bundled Widevine CDM if available (see chromium-widevine in the AUR)
# M79 is supposed to download it as a component but it doesn't seem to work
patch -Np1 -i ../chromium-widevine.patch
@@ -106,6 +115,15 @@ prepare() {
# https://crbug.com/skia/6663#c10
patch -Np0 -i ../chromium-skia-harmony.patch
+ patch -Np1 -i ../0001-Revert-RTCInsertableStreams-Make-RTCEncodedAudioFram.patch
+ patch -Np1 -i ../0002-Revert-RTCInsertableStreams-Make-RTCEncodedVideoFram.patch
+ patch -Np1 -i ../0003-Add-missing-algorithm-header-in-crx_install_error.cc.patch
+ patch -Np1 -i ../0004-libstdc-fix-incomplete-type-in-AXTree-for-NodeSetSiz.patch
+ patch -Np1 -i ../0005-Revert-Trace-ICU-object-creation-in-ICU.CreateInstan.patch
+ patch -Np1 -i ../0006-Revert-PM-Add-calculation-of-maximum-simultaneous-lo.patch
+ patch -Np1 -i ../0007-Add-missing-memory-header-in-trust_token_attribute_p.patch
+ patch -Np1 -i ../0008-Revert-FragmentItem-Two-fixes-for-outline.patch
+
for PATCH in ${_bugfix_patches[@]}
do
echo "Applying $PATCH"
@@ -162,8 +180,6 @@ build() {
'ozone_auto_platforms=false'
'use_glib=true'
'use_system_libwayland=true'
- 'use_system_minigbm=true'
- 'use_system_libdrm=true'
'use_vaapi=false'
'use_jumbo_build=false'
'enable_nacl=false'