summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorDaniel Playfair Cal2020-04-09 00:33:29 +1000
committerDaniel Playfair Cal2020-04-09 00:33:29 +1000
commit7157d19e4cbf4fcedcb2cf49f25e457f9dac8220 (patch)
tree9d43262939ddc148953d9b1dc7545c44d584c4c4 /PKGBUILD
parent8bf929c865c8a35cb71002480f4d04190bd62349 (diff)
parentd60157861037f70068f0b8c8a7427b8040230160 (diff)
downloadaur-7157d19e4cbf4fcedcb2cf49f25e457f9dac8220.tar.gz
81.0.4044.92-1
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD49
1 files changed, 6 insertions, 43 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 48e128e86929..85d0360e77c7 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,7 +5,7 @@
# Contributor: Daniel J Griffiths <ghost1227@archlinux.us>
pkgname=chromium-ozone
-pkgver=80.0.3987.163
+pkgver=81.0.4044.92
pkgrel=1
_launcher_ver=6
pkgdesc="Chromium built with patches for wayland support via Ozone"
@@ -28,28 +28,12 @@ optdepends=('pepper-flash: support for Flash content'
install=chromium.install
source=(https://commondatastorage.googleapis.com/chromium-browser-official/chromium-$pkgver.tar.xz
chromium-launcher-$_launcher_ver.tar.gz::https://github.com/foutrelis/chromium-launcher/archive/v$_launcher_ver.tar.gz
- 0001-Add-missing-algorithm-header-in-bitmap_cursor_factor.patch
- cros-search-service-Include-cmath-for-std-pow.patch
- move-RemoteTreeNode-declaration.patch
- sync-enable-USSPasswords-by-default.patch
- fix-shim-header-generation-when-unbundling-ICU.patch
- fix-building-with-system-zlib.patch
- remove-verbose-logging-in-local-unique-font-matching.patch
- fix-building-with-unbundled-libxml.patch
rename-Relayout-in-DesktopWindowTreeHostPlatform.patch
rebuild-Linux-frame-button-cache-when-activation.patch
chromium-widevine.patch
chromium-skia-harmony.patch)
-sha256sums=('b6ddefa9434877a9b923631b7525f7f2f80118dd986ecdac87f2c9f11f237346'
+sha256sums=('a2cf3fd07a66330b189724cdcb4549ddac72705fba6adb33020bc6444efb1a44'
'04917e3cd4307d8e31bfb0027a5dce6d086edb10ff8a716024fbb8bb0c7dccf1'
- '716c28bed9f6e9c32e3617e125c1b04806700aef691763923cd4ed14b8d23279'
- '0a8d1af2a3734b5f99ea8462940e332db4acee7130fe436ad3e4b7ad133e5ae5'
- '21f631851cdcb347f40793485b168cb5d0da65ae26ae39ba58d624c66197d0a5'
- '08ef82476780e0864b5bf7f20eb19db320e73b9a5d4f595351e12e97dda8746f'
- 'e477aa48a11ca4d53927f66a9593567fcd053325fb38af30ac3508465f1dd1f6'
- '18276e65c68a0c328601b12fefb7e8bfc632346f34b87e64944c9de8c95c5cfa'
- '5bc775c0ece84d67855f51b30eadcf96fa8163b416d2036e9f9ba19072f54dfe'
- 'e530d1b39504c2ab247e16f1602359c484e9e8be4ef6d4824d68b14d29a7f60b'
'ae3bf107834bd8eda9a3ec7899fe35fde62e6111062e5def7d24bf49b53db3db'
'46f7fc9768730c460b27681ccf3dc2685c7e1fd22d70d3a82d9e57e3389bb014'
'709e2fddba3c1f2ed4deb3a239fc0479bfa50c46e054e7f32db4fb1365fed070'
@@ -65,7 +49,7 @@ declare -gA _system_libs=(
[harfbuzz-ng]=harfbuzz
[icu]=icu
[libdrm]=
- [libjpeg]=libjpeg
+ #[libjpeg]=libjpeg
#[libpng]=libpng # https://crbug.com/752403#c10
[libvpx]=libvpx
[libwebp]=libwebp
@@ -79,7 +63,7 @@ declare -gA _system_libs=(
)
_unwanted_bundled_libs=(
${!_system_libs[@]}
- ${_system_libs[libjpeg]+libjpeg_turbo}
+ ${libjpeg_turbo}
)
depends+=(${_system_libs[@]})
@@ -90,7 +74,7 @@ _google_api_key=AIzaSyDwr302FpOSkGRpLlUpPThNTDPbXcIn_FM
_google_default_client_id=413772536636.apps.googleusercontent.com
_google_default_client_secret=0ZChLK6AxeA3Isu96MkwqDR4
-# Branch point: 722274
+# Branch point: 737173
# Extra commits related specifically to wayland support:
# These consist of the above commits and their dependencies
@@ -111,28 +95,6 @@ prepare() {
third_party/blink/renderer/core/xml/parser/xml_document_parser.cc \
third_party/libxml/chromium/*.cc
- # build fixes
- patch -Np1 -i ../0001-Add-missing-algorithm-header-in-bitmap_cursor_factor.patch
-
- # https://crbug.com/957519
- patch -Np1 -i ../cros-search-service-Include-cmath-for-std-pow.patch
- patch -Np1 -i ../move-RemoteTreeNode-declaration.patch
-
- # https://crbug.com/1027929
- patch -Np1 -i ../sync-enable-USSPasswords-by-default.patch
-
- # https://crbug.com/989153
- patch -Np1 -i ../fix-shim-header-generation-when-unbundling-ICU.patch
-
- # https://crbug.com/977964
- patch -Np1 -i ../fix-building-with-system-zlib.patch
-
- # https://crbug.com/1005508
- patch -Np1 -i ../remove-verbose-logging-in-local-unique-font-matching.patch
-
- # https://crbug.com/1043042
- patch -Np1 -i ../fix-building-with-unbundled-libxml.patch
-
# https://crbug.com/1049258
patch -Np1 -i ../rename-Relayout-in-DesktopWindowTreeHostPlatform.patch
patch -Np1 -i ../rebuild-Linux-frame-button-cache-when-activation.patch
@@ -240,6 +202,7 @@ package() {
cd "$srcdir/chromium-$pkgver"
install -D out/Release/chrome "$pkgdir/usr/lib/chromium/chromium"
+ install -D out/Release/crashpad_handler "$pkgdir/usr/lib/chromium/crashpad_handler"
install -Dm4755 out/Release/chrome_sandbox "$pkgdir/usr/lib/chromium/chrome-sandbox"
ln -s /usr/lib/chromium/chromedriver "$pkgdir/usr/bin/chromedriver"