summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorDaniel Playfair Cal2020-05-31 14:20:42 +1000
committerDaniel Playfair Cal2020-05-31 14:20:42 +1000
commitaa09cee0eec6ffdb731012c1249482422e098f97 (patch)
tree8c6ba7682701a46c22fdbbb1667ecea4f181c2b1 /PKGBUILD
parentf6da84d2ff90122b73a82ce4c765777627e779f2 (diff)
downloadaur-aa09cee0eec6ffdb731012c1249482422e098f97.tar.gz
83.0.4103.61-1
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD45
1 files changed, 13 insertions, 32 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 8f434d7b42f5..6fa074c71d8a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,13 +5,12 @@
# Contributor: Daniel J Griffiths <ghost1227@archlinux.us>
pkgname=chromium-ozone
-pkgver=81.0.4044.138
+pkgver=83.0.4103.61
pkgrel=1
_launcher_ver=6
pkgdesc="Chromium built with patches for wayland support via Ozone"
arch=('x86_64')
url="https://www.chromium.org/Home"
-options=(debug !strip)
license=('BSD')
depends=('gtk3' 'nss' 'alsa-lib' 'xdg-utils' 'libxss' 'libcups' 'libgcrypt'
'ttf-liberation' 'systemd' 'dbus' 'libpulse' 'pciutils' 'json-glib'
@@ -19,7 +18,8 @@ depends=('gtk3' 'nss' 'alsa-lib' 'xdg-utils' 'libxss' 'libcups' 'libgcrypt'
provides=('chromium')
conflicts=('chromium')
makedepends=('python' 'python2' 'gperf' 'yasm' 'mesa' 'ninja' 'nodejs' 'git'
- 'libpipewire02' 'clang' 'lld' 'gn' 'java-runtime-headless')
+ 'libpipewire02' 'clang' 'lld' 'gn' 'java-runtime-headless'
+ 'python2-setuptools')
optdepends=('pepper-flash: support for Flash content'
'libpipewire02: WebRTC desktop sharing under Wayland'
'kdialog: needed for file dialogs in KDE'
@@ -28,44 +28,37 @@ optdepends=('pepper-flash: support for Flash content'
install=chromium.install
source=(https://commondatastorage.googleapis.com/chromium-browser-official/chromium-$pkgver.tar.xz
chromium-launcher-$_launcher_ver.tar.gz::https://github.com/foutrelis/chromium-launcher/archive/v$_launcher_ver.tar.gz
- rename-Relayout-in-DesktopWindowTreeHostPlatform.patch
- rebuild-Linux-frame-button-cache-when-activation.patch
- icu67.patch
- chromium-widevine.patch
+ v8-remove-soon-to-be-removed-getAllFieldPositions.patch
chromium-skia-harmony.patch)
-sha256sums=('f478f28b8111cb70231df4c36e754d812ad7a94b7c844e9d0515345a71fd77a6'
+sha256sums=('4961f20c4ee6a94490e823f1b1c4128147068f1ce9cfc509e81815f2101405bc'
'04917e3cd4307d8e31bfb0027a5dce6d086edb10ff8a716024fbb8bb0c7dccf1'
- 'ae3bf107834bd8eda9a3ec7899fe35fde62e6111062e5def7d24bf49b53db3db'
- '46f7fc9768730c460b27681ccf3dc2685c7e1fd22d70d3a82d9e57e3389bb014'
- '5315977307e69d20b3e856d3f8724835b08e02085a4444a5c5cefea83fd7d006'
- '709e2fddba3c1f2ed4deb3a239fc0479bfa50c46e054e7f32db4fb1365fed070'
+ 'e042024423027ad3ef729a7e4709bdf9714aea49d64cfbbf46a645a05703abc2'
'771292942c0901092a402cc60ee883877a99fb804cb54d568c8c6c94565a48e1')
# Possible replacements are listed in build/linux/unbundle/replace_gn_files.py
# Keys are the names in the above script; values are the dependencies in Arch
declare -gA _system_libs=(
- [ffmpeg]=ffmpeg
+ # [ffmpeg]=ffmpeg # broken with recent ffmpeg git
[flac]=flac
[fontconfig]=fontconfig
[freetype]=freetype2
[harfbuzz-ng]=harfbuzz
[icu]=icu
[libdrm]=
- #[libjpeg]=libjpeg
+ [libjpeg]=libjpeg
#[libpng]=libpng # https://crbug.com/752403#c10
[libvpx]=libvpx
[libwebp]=libwebp
[libxml]=libxml2
[libxslt]=libxslt
[opus]=opus
- #[re2]=re2
+ # [re2]=re2 # Not possible with custom libcxx
[snappy]=snappy
[yasm]=
[zlib]=minizip
)
_unwanted_bundled_libs=(
- ${!_system_libs[@]}
- ${libjpeg_turbo}
+ $(printf "%s\n" ${!_system_libs[@]} | sed 's/^libjpeg$/&_turbo/')
)
depends+=(${_system_libs[@]})
@@ -76,7 +69,7 @@ _google_api_key=AIzaSyDwr302FpOSkGRpLlUpPThNTDPbXcIn_FM
_google_default_client_id=413772536636.apps.googleusercontent.com
_google_default_client_secret=0ZChLK6AxeA3Isu96MkwqDR4
-# Branch point: 737173
+# Branch point: 756066
# Extra commits related specifically to wayland support:
# These consist of the above commits and their dependencies
@@ -97,16 +90,8 @@ prepare() {
third_party/blink/renderer/core/xml/parser/xml_document_parser.cc \
third_party/libxml/chromium/*.cc
- # https://crbug.com/1049258
- patch -Np1 -i ../rename-Relayout-in-DesktopWindowTreeHostPlatform.patch
- patch -Np1 -i ../rebuild-Linux-frame-button-cache-when-activation.patch
-
# https://crbug.com/v8/10393
- patch -Np3 -d v8 <../icu67.patch
-
- # Load bundled Widevine CDM if available (see chromium-widevine in the AUR)
- # M79 is supposed to download it as a component but it doesn't seem to work
- patch -Np1 -i ../chromium-widevine.patch
+ patch -Np1 -d v8 <../v8-remove-soon-to-be-removed-getAllFieldPositions.patch
# https://crbug.com/skia/6663#c10
patch -Np0 -i ../chromium-skia-harmony.patch
@@ -131,6 +116,7 @@ prepare() {
find "third_party/$_lib" -type f \
\! -path "third_party/$_lib/chromium/*" \
\! -path "third_party/$_lib/google/*" \
+ \! -path "third_party/harfbuzz-ng/utils/hb_scoped.h" \
\! -path 'third_party/yasm/run_yasm.py' \
\! -regex '.*\.\(gn\|gni\|isolate\)' \
-delete
@@ -158,7 +144,6 @@ build() {
'use_gnome_keyring=false'
'use_sysroot=false'
'linux_use_bundled_binutils=false'
- 'use_custom_libcxx=false'
'enable_hangout_services_extension=true'
'enable_widevine=true'
'use_ozone=true'
@@ -167,10 +152,7 @@ build() {
'ozone_auto_platforms=false'
'use_glib=true'
'use_system_libwayland=true'
- 'use_system_minigbm=true'
- 'use_system_libdrm=true'
'use_vaapi=false'
- 'use_jumbo_build=false'
'enable_nacl=false'
'enable_swiftshader=false'
"google_api_key=\"${_google_api_key}\""
@@ -207,7 +189,6 @@ package() {
cd "$srcdir/chromium-$pkgver"
install -D out/Release/chrome "$pkgdir/usr/lib/chromium/chromium"
- install -D out/Release/crashpad_handler "$pkgdir/usr/lib/chromium/crashpad_handler"
install -Dm4755 out/Release/chrome_sandbox "$pkgdir/usr/lib/chromium/chrome-sandbox"
ln -s /usr/lib/chromium/chromedriver "$pkgdir/usr/bin/chromedriver"