summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorDaniel Playfair Cal2020-02-09 17:52:36 +1100
committerDaniel Playfair Cal2020-02-09 17:54:50 +1100
commitccd468a06a60d9e65e7742d2ee7d3b81e5cd8885 (patch)
treee27ef0d1fa3e93e3f949eeec9b347957157b0a0f /PKGBUILD
parent53d0cef916c867c66e7391ea89b57da33e5cb018 (diff)
downloadaur-ccd468a06a60d9e65e7742d2ee7d3b81e5cd8885.tar.gz
80.0.3987.87-1
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD79
1 files changed, 54 insertions, 25 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 537b1de5e2ab..32f7de480b16 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,8 +4,8 @@
# Contributor: Jan "heftig" Steffens <jan.steffens@gmail.com>
# Contributor: Daniel J Griffiths <ghost1227@archlinux.us>
-pkgname=chromium-beta-ozone
-pkgver=80.0.3987.42
+pkgname=chromium-ozone
+pkgver=80.0.3987.87
pkgrel=1
_launcher_ver=6
pkgdesc="Chromium built with patches for wayland support via Ozone (beta channel)"
@@ -14,13 +14,14 @@ url="https://www.chromium.org/Home"
options=(debug !strip)
license=('BSD')
depends=('gtk3' 'nss' 'alsa-lib' 'xdg-utils' 'libxss' 'libcups' 'libgcrypt'
- 'ttf-font' 'systemd' 'dbus' 'libpulse' 'pciutils' 'json-glib' 'libva'
+ 'ttf-liberation' 'systemd' 'dbus' 'libpulse' 'pciutils' 'json-glib'
'desktop-file-utils' 'hicolor-icon-theme')
provides=('chromium')
conflicts=('chromium')
makedepends=('python' 'python2' 'gperf' 'yasm' 'mesa' 'ninja' 'nodejs' 'git'
- 'clang' 'lld' 'gn' 'java-runtime-headless')
+ 'pipewire' 'clang' 'lld' 'gn' 'java-runtime-headless')
optdepends=('pepper-flash: support for Flash content'
+ 'pipewire: WebRTC desktop sharing under Wayland'
'kdialog: needed for file dialogs in KDE'
'org.freedesktop.secrets: password storage backend on GNOME / Xfce'
'kwallet: for storing passwords in KWallet on KDE desktops')
@@ -28,21 +29,31 @@ install=chromium.install
source=(https://commondatastorage.googleapis.com/chromium-browser-official/chromium-$pkgver.tar.xz
chromium-launcher-$_launcher_ver.tar.gz::https://github.com/foutrelis/chromium-launcher/archive/v$_launcher_ver.tar.gz
0001-Add-missing-algorithm-header-in-bitmap_cursor_factor.patch
- 0001-cros-search-service-Include-cmath-for-std-pow.patch
- 0001-BookmarkModelMerger-Move-RemoteTreeNode-declaration-.patch
- chromium-system-icu.patch
- chromium-system-zlib.patch
- fix-spammy-unique-font-matching-log.patch
+ cros-search-service-Include-cmath-for-std-pow.patch
+ move-RemoteTreeNode-declaration.patch
+ sync-enable-USSPasswords-by-default.patch
+ fix-shim-header-generation-when-unbundling-ICU.patch
+ fix-building-with-system-zlib.patch
+ remove-verbose-logging-in-local-unique-font-matching.patch
+ fix-building-with-unbundled-libxml.patch
+ fix-browser-frame-view-not-getting-a-relayout.patch
+ rename-Relayout-in-DesktopWindowTreeHostPlatform.patch
+ rebuild-Linux-frame-button-cache-when-activation.patch
chromium-widevine.patch
chromium-skia-harmony.patch)
-sha256sums=('160c02ed00d45a074246c8984144a35b092102e9b9a31e2bc9c2dad49f297945'
+sha256sums=('f51f6fca5d9abbef855aa6b5bf427410c6e96ae58b64a7d45f843868cfb0ac8e'
'04917e3cd4307d8e31bfb0027a5dce6d086edb10ff8a716024fbb8bb0c7dccf1'
'716c28bed9f6e9c32e3617e125c1b04806700aef691763923cd4ed14b8d23279'
- '4c892f046ab10df609aa39d9985248d368c77306783a64d335ff713dabad60b0'
- 'a44ed59db5258221ee187dc2501040e5ebfc5c1353ac98d4313ac6a12ae32d1f'
- 'e73cc2ee8d3ea35aab18c478d76fdfc68ca4463e1e10306fa1e738c03b3f26b5'
- 'eb67eda4945a89c3b90473fa8dc20637511ca4dcb58879a8ed6bf403700ca9c8'
- '6fbffe59b886195b92c9a55137cef83021c16593f49714acb20023633e3ebb19'
+ '0a8d1af2a3734b5f99ea8462940e332db4acee7130fe436ad3e4b7ad133e5ae5'
+ '21f631851cdcb347f40793485b168cb5d0da65ae26ae39ba58d624c66197d0a5'
+ '08ef82476780e0864b5bf7f20eb19db320e73b9a5d4f595351e12e97dda8746f'
+ 'e477aa48a11ca4d53927f66a9593567fcd053325fb38af30ac3508465f1dd1f6'
+ '18276e65c68a0c328601b12fefb7e8bfc632346f34b87e64944c9de8c95c5cfa'
+ '5bc775c0ece84d67855f51b30eadcf96fa8163b416d2036e9f9ba19072f54dfe'
+ 'e530d1b39504c2ab247e16f1602359c484e9e8be4ef6d4824d68b14d29a7f60b'
+ '5db225565336a3d9b9e9f341281680433c0b7bb343dff2698b2acffd86585cbe'
+ 'ae3bf107834bd8eda9a3ec7899fe35fde62e6111062e5def7d24bf49b53db3db'
+ '46f7fc9768730c460b27681ccf3dc2685c7e1fd22d70d3a82d9e57e3389bb014'
'709e2fddba3c1f2ed4deb3a239fc0479bfa50c46e054e7f32db4fb1365fed070'
'771292942c0901092a402cc60ee883877a99fb804cb54d568c8c6c94565a48e1')
@@ -57,10 +68,10 @@ declare -gA _system_libs=(
[icu]=icu
[libdrm]=
[libjpeg]=libjpeg
- #[libpng]=libpng # https://crbug.com/752403#c10
- #[libvpx]=libvpx # https://github.com/webmproject/libvpx/commit/5a0242ba5c
+ #[libpng]=libpng # https://crbug.com/752403#c10
+ [libvpx]=libvpx
[libwebp]=libwebp
- # [libxml]=libxml2
+ [libxml]=libxml2
[libxslt]=libxslt
[opus]=opus
[re2]=re2
@@ -100,19 +111,36 @@ prepare() {
sed -i -e 's/\<xmlMalloc\>/malloc/' -e 's/\<xmlFree\>/free/' \
third_party/blink/renderer/core/xml/*.cc \
third_party/blink/renderer/core/xml/parser/xml_document_parser.cc \
- third_party/libxml/chromium/libxml_utils.cc
+ third_party/libxml/chromium/*.cc
# build fixes
patch -Np1 -i ../0001-Add-missing-algorithm-header-in-bitmap_cursor_factor.patch
- patch -Np1 -i ../0001-cros-search-service-Include-cmath-for-std-pow.patch
- patch -Np1 -i ../0001-BookmarkModelMerger-Move-RemoteTreeNode-declaration-.patch
- # Fixes from Gentoo
- patch -Np1 -i ../chromium-system-icu.patch
- patch -Np1 -i ../chromium-system-zlib.patch
+ # https://crbug.com/957519
+ patch -Np1 -i ../cros-search-service-Include-cmath-for-std-pow.patch
+ patch -Np1 -i ../move-RemoteTreeNode-declaration.patch
+
+ # https://crbug.com/1027929
+ patch -Np1 -i ../sync-enable-USSPasswords-by-default.patch
+
+ # https://crbug.com/989153
+ patch -Np1 -i ../fix-shim-header-generation-when-unbundling-ICU.patch
+
+ # https://crbug.com/977964
+ patch -Np1 -i ../fix-building-with-system-zlib.patch
# https://crbug.com/1005508
- # patch -Np1 -i ../fix-spammy-unique-font-matching-log.patch
+ patch -Np1 -i ../remove-verbose-logging-in-local-unique-font-matching.patch
+
+ # https://crbug.com/1043042
+ patch -Np1 -i ../fix-building-with-unbundled-libxml.patch
+
+ # https://crbug.com/1046122
+ patch -Np1 -i ../fix-browser-frame-view-not-getting-a-relayout.patch
+
+ # https://crbug.com/1049258
+ patch -Np1 -i ../rename-Relayout-in-DesktopWindowTreeHostPlatform.patch
+ patch -Np1 -i ../rebuild-Linux-frame-button-cache-when-activation.patch
# Load bundled Widevine CDM if available (see chromium-widevine in the AUR)
# M79 is supposed to download it as a component but it doesn't seem to work
@@ -163,6 +191,7 @@ build() {
'fieldtrial_testing_like_official_build=true'
'ffmpeg_branding="Chrome"'
'proprietary_codecs=true'
+ 'rtc_use_pipewire=true'
'link_pulseaudio=true'
'use_gnome_keyring=false'
'use_sysroot=false'