summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorsL1pKn072017-01-06 20:29:30 +0100
committersL1pKn072017-01-06 20:29:30 +0100
commit5ddc507edf2fcc723598895b524650d2ea9c4623 (patch)
tree23ac31c8d09e38cdfeaf6a0b2db36dc3be17e0aa /PKGBUILD
parentaafe8ade75b893ff9a36cbbdd8f617f7311d39f6 (diff)
downloadaur-5ddc507edf2fcc723598895b524650d2ea9c4623.tar.gz
Update to 57.0.2970.0
- Fixed https://crbug.com/668446 (needs GTK2 in makedepends when use GTK3 build) - Fixed https://crbug.com/636229 (MADV_FREE patch) - Add patch from vaapi patch repository (https://github.com/saiarcot895/chromium-ubuntu-build/issues/7) - Use GCC instead of internal clang (broken build with clang, maybe a clang bug(?))
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD394
1 files changed, 204 insertions, 190 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 83316d2eb978..19c0420221fb 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -9,7 +9,7 @@
## -- Build options -- ##
#########################
-_use_clang=1 # Use clang compiler (downloaded binaries from google). Results in faster build and smaller chromium.
+_use_clang=0 # Use clang compiler (downloaded binaries from google). Results in faster build and smaller chromium.
_use_ccache=0 # Use ccache when build.
_use_pax=0 # Set 1 to change PaX permisions in executables NOTE: only use if use PaX environment.
_use_gtk3=1 # If set 1, then build with GTK3 support, if set 0, then build with GTK2.
@@ -20,7 +20,7 @@ _enable_vaapi=0 # Patch for VAAPI HW acceleration NOTE: don't work in som
## -- Package and components information -- ##
##############################################
pkgname=chromium-dev
-pkgver=56.0.2924.14
+pkgver=57.0.2970.0
_launcher_ver=3
pkgrel=1
pkgdesc="The open-source project behind Google Chrome (Dev Channel)"
@@ -85,10 +85,10 @@ source=( #"https://gsdview.appspot.com/chromium-browser-official/chromium-${pkgv
'https://raw.githubusercontent.com/gentoo/gentoo/master/www-client/chromium/files/chromium-system-ffmpeg-r4.patch'
'https://raw.githubusercontent.com/gentoo/gentoo/master/www-client/chromium/files/chromium-system-jinja-r14.patch'
# Misc Patches
- "enable_vaapi_on_linux_${pkgver}.diff::https://raw.githubusercontent.com/saiarcot895/chromium-ubuntu-build/c2443d1d7815e55912a857e67685af03f276ea5d/debian/patches/enable_vaapi_on_linux.diff"
- "specify-max-resolution_${pkgver}.patch::https://raw.githubusercontent.com/saiarcot895/chromium-ubuntu-build/c2443d1d7815e55912a857e67685af03f276ea5d/debian/patches/specify-max-resolution.patch"
+ "enable_vaapi_on_linux_${pkgver}.diff::https://raw.githubusercontent.com/saiarcot895/chromium-ubuntu-build/f02f22cdc0923ab18c44dc46dda0942e078b870d/debian/patches/enable_vaapi_on_linux.diff"
+ "specify-max-resolution_${pkgver}.patch::https://raw.githubusercontent.com/saiarcot895/chromium-ubuntu-build/f02f22cdc0923ab18c44dc46dda0942e078b870d/debian/patches/specify-max-resolution.patch"
+ "fix-gl-image_${pkgver}.patch::https://raw.githubusercontent.com/saiarcot895/chromium-ubuntu-build/f02f22cdc0923ab18c44dc46dda0942e078b870d/debian/patches/fix-gl-image.patch"
'minizip.patch'
- 'unset-madv_free.patch'
# Patch from crbug (chromium bugtracker)
'chromium-widevine-r1.patch'
)
@@ -101,10 +101,10 @@ sha256sums=( #"$(curl -sL https://gsdview.appspot.com/chromium-browser-official/
'e3c474dbf3822a0be50695683bd8a2c9dfc82d41c1524a20b4581883c0c88986'
'a9cb08fbac8ffcf6371edd7ab67833efd42c5b92938f1e2e7922d1d22d226db8'
# Misc Patches
- '1e8f671b0358cc22ab91bf5474d198c5c024d52567528b213a89a11d3675ab42'
+ 'a2d5fc1a5ef77b2f810508a928c30db7efa1a7798818c05211d41f65c525cef2'
'025042ac038ea5fdaabc91e67b13a410d2cacd9afc2d74f89b36fdf2388d4afc'
+ '89178b6549f09737d7455fe8923c93ead3556c59914ba4375db49789b73b45f3'
'95ba939b9372e533ecbcc9ca034f3e9fc6621d3bddabb57c4d092ea69fa6c840'
- '3b3aa9e28f29e6f539ed1c7832e79463b13128863a02e9c6fecd16c30d61c227'
# Patch from crbug (chromium bugtracker)
'0d537830944814fe0854f834b5dc41dc5fc2428f77b2ad61d4a5e76b0fe99880'
)
@@ -150,7 +150,6 @@ fi
# Build with GTK3?.
if [ "${_use_gtk3}" = "1" ]; then
depends+=('gtk3')
- makedepends+=('gtk2') # https://crbug.com/668446
_launcher_gtk='GTK=3'
optdepends+=('libappindicator-gtk3: Needed for show systray icon in the panel in plasma-next (KF5)')
_gtk3=true
@@ -176,149 +175,153 @@ if [ -e /usr/lib/security/pam_gnome_keyring.so ]; then
fi
# List of third-party components needed for build chromium. The rest is remove by remove_bundled_libraries srcipt in prepare().
-_keeplibs=('base/third_party/dmg_fp'
- 'base/third_party/dynamic_annotations'
- 'base/third_party/icu'
- 'base/third_party/libevent'
- 'base/third_party/nspr'
- 'base/third_party/superfasthash'
- 'base/third_party/symbolize'
- 'base/third_party/valgrind'
- 'base/third_party/xdg_mime'
- 'base/third_party/xdg_user_dirs'
- 'breakpad/src/third_party/curl'
- 'chrome/third_party/mozilla_security_manager'
- 'courgette/third_party'
- 'native_client/src/third_party/dlmalloc'
- 'native_client_sdk/src/libraries/third_party/newlib-extras'
- 'net/third_party/mozilla_security_manager'
- 'net/third_party/nss'
- 'third_party/WebKit'
- 'third_party/adobe'
- 'third_party/analytics'
- 'third_party/angle'
- 'third_party/angle/src/common/third_party/numerics'
- 'third_party/angle/src/third_party/compiler'
- 'third_party/angle/src/third_party/murmurhash'
- 'third_party/angle/src/third_party/trace_event'
- 'third_party/angle/src/third_party/libXNVCtrl'
- 'third_party/boringssl'
- 'third_party/brotli'
- 'third_party/cacheinvalidation'
- 'third_party/catapult'
- 'third_party/catapult/third_party/polymer'
- 'third_party/catapult/third_party/py_vulcanize'
- 'third_party/catapult/third_party/py_vulcanize/third_party/rcssmin'
- 'third_party/catapult/third_party/py_vulcanize/third_party/rjsmin'
- 'third_party/catapult/tracing/third_party/d3'
- 'third_party/catapult/tracing/third_party/gl-matrix'
- 'third_party/catapult/tracing/third_party/jszip'
- 'third_party/catapult/tracing/third_party/mannwhitneyu'
- 'third_party/ced'
- 'third_party/cld_2'
- 'third_party/cld_3'
- 'third_party/cros_system_api'
- 'third_party/devscripts'
- 'third_party/dom_distiller_js'
- 'third_party/fips181'
- 'third_party/flatbuffers'
- 'third_party/flot'
- 'third_party/google_input_tools'
- 'third_party/google_input_tools/third_party/closure_library'
- 'third_party/google_input_tools/third_party/closure_library/third_party/closure'
- 'third_party/hunspell'
- 'third_party/iccjpeg'
- 'third_party/inspector_protocol'
- 'third_party/jstemplate'
- 'third_party/khronos'
- 'third_party/leveldatabase'
- 'third_party/libXNVCtrl'
- 'third_party/libaddressinput'
- 'third_party/libjingle'
- 'third_party/libphonenumber'
- 'third_party/libsecret'
- 'third_party/libsrtp'
- 'third_party/libudev'
- 'third_party/libusb'
- 'third_party/libva'
- 'third_party/libwebm'
- 'third_party/libxml'
- 'third_party/libyuv'
- 'third_party/lss'
- 'third_party/lzma_sdk'
- 'third_party/mesa'
- 'third_party/modp_b64'
- 'third_party/mt19937ar'
- 'third_party/openh264'
- 'third_party/openmax_dl'
- 'third_party/opus'
- 'third_party/ots'
- 'third_party/pdfium'
- 'third_party/pdfium/third_party/agg23'
- 'third_party/pdfium/third_party/base'
- 'third_party/pdfium/third_party/bigint'
- 'third_party/pdfium/third_party/freetype'
- 'third_party/pdfium/third_party/lcms2-2.6'
- 'third_party/pdfium/third_party/libjpeg'
- 'third_party/pdfium/third_party/libopenjpeg20'
- 'third_party/pdfium/third_party/libpng16'
- 'third_party/pdfium/third_party/libtiff'
- 'third_party/pdfium/third_party/zlib_v128'
- 'third_party/polymer'
- 'third_party/protobuf'
- 'third_party/protobuf/third_party/six'
- 'third_party/qcms'
- 'third_party/sfntly'
- 'third_party/skia'
- 'third_party/smhasher'
- 'third_party/speech-dispatcher'
- 'third_party/sqlite'
- 'third_party/tcmalloc'
- 'third_party/usb_ids'
- 'third_party/usrsctp'
- 'third_party/web-animations-js'
- 'third_party/webdriver'
- 'third_party/webrtc'
- 'third_party/widevine'
- 'third_party/woff2'
- 'third_party/x86inc'
- 'third_party/xdg-utils'
- 'third_party/yasm/run_yasm.py'
- 'third_party/zlib/google'
- 'url/third_party/mozilla'
- 'v8/src/third_party/valgrind'
- 'v8/third_party/inspector_protocol'
- )
+_keeplibs=(
+ 'base/third_party/dmg_fp'
+ 'base/third_party/dynamic_annotations'
+ 'base/third_party/icu'
+ 'base/third_party/nspr'
+ 'base/third_party/superfasthash'
+ 'base/third_party/symbolize'
+ 'base/third_party/valgrind'
+ 'base/third_party/xdg_mime'
+ 'base/third_party/xdg_user_dirs'
+ 'breakpad/src/third_party/curl'
+ 'chrome/third_party/mozilla_security_manager'
+ 'courgette/third_party'
+ 'native_client/src/third_party/dlmalloc'
+ 'native_client_sdk/src/libraries/third_party/newlib-extras'
+ 'net/third_party/mozilla_security_manager'
+ 'net/third_party/nss'
+ 'third_party/WebKit'
+ 'third_party/analytics'
+ 'third_party/angle'
+ 'third_party/angle/src/common/third_party/numerics'
+ 'third_party/angle/src/third_party/compiler'
+ 'third_party/angle/src/third_party/murmurhash'
+ 'third_party/angle/src/third_party/trace_event'
+ 'third_party/angle/src/third_party/libXNVCtrl'
+ 'third_party/boringssl'
+ 'third_party/brotli'
+ 'third_party/cacheinvalidation'
+ 'third_party/catapult'
+ 'third_party/catapult/third_party/polymer'
+ 'third_party/catapult/third_party/py_vulcanize'
+ 'third_party/catapult/third_party/py_vulcanize/third_party/rcssmin'
+ 'third_party/catapult/third_party/py_vulcanize/third_party/rjsmin'
+ 'third_party/catapult/tracing/third_party/d3'
+ 'third_party/catapult/tracing/third_party/gl-matrix'
+ 'third_party/catapult/tracing/third_party/jszip'
+ 'third_party/catapult/tracing/third_party/mannwhitneyu'
+ 'third_party/ced'
+ 'third_party/cld_2'
+ 'third_party/cld_3'
+ 'third_party/cros_system_api'
+ 'third_party/devscripts'
+ 'third_party/dom_distiller_js'
+ 'third_party/fips181'
+ 'third_party/flatbuffers'
+ 'third_party/flot'
+ 'third_party/google_input_tools'
+ 'third_party/google_input_tools/third_party/closure_library'
+ 'third_party/google_input_tools/third_party/closure_library/third_party/closure'
+ 'third_party/hunspell'
+ 'third_party/iccjpeg'
+ 'third_party/inspector_protocol'
+ 'third_party/jstemplate'
+ 'third_party/khronos'
+ 'third_party/leveldatabase'
+ 'third_party/libXNVCtrl'
+ 'third_party/libaddressinput'
+ 'third_party/libjingle'
+ 'third_party/libphonenumber'
+ 'third_party/libsecret'
+ 'third_party/libsrtp'
+ 'third_party/libudev'
+ 'third_party/libusb'
+ 'third_party/libva'
+ 'third_party/libwebm'
+ 'third_party/libyuv'
+ 'third_party/libxml/chromium'
+ 'third_party/lss'
+ 'third_party/lzma_sdk'
+ 'third_party/mesa'
+ 'third_party/modp_b64'
+ 'third_party/mt19937ar'
+ 'third_party/openh264'
+ 'third_party/openmax_dl'
+ 'third_party/opus'
+ 'third_party/ots'
+ 'third_party/pdfium'
+ 'third_party/pdfium/third_party/agg23'
+ 'third_party/pdfium/third_party/base'
+ 'third_party/pdfium/third_party/bigint'
+ 'third_party/pdfium/third_party/freetype'
+ 'third_party/pdfium/third_party/lcms2-2.6'
+ 'third_party/pdfium/third_party/libjpeg'
+ 'third_party/pdfium/third_party/libopenjpeg20'
+ 'third_party/pdfium/third_party/libpng16'
+ 'third_party/pdfium/third_party/libtiff'
+ 'third_party/pdfium/third_party/zlib_v128'
+ 'third_party/polymer'
+ 'third_party/protobuf'
+ 'third_party/protobuf/third_party/six'
+ 'third_party/qcms'
+ 'third_party/sfntly'
+ 'third_party/skia'
+ 'third_party/smhasher'
+ 'third_party/sqlite'
+ 'third_party/tcmalloc'
+ 'third_party/usrsctp'
+ 'third_party/web-animations-js'
+ 'third_party/webdriver'
+ 'third_party/webrtc'
+ 'third_party/widevine'
+ 'third_party/woff2'
+ 'third_party/x86inc'
+ 'third_party/zlib/google'
+ 'url/third_party/mozilla'
+ 'v8/src/third_party/valgrind'
+ 'v8/third_party/inspector_protocol'
+
+ # gyp -> gn leftovers
+ 'base/third_party/libevent'
+ 'third_party/adobe'
+ 'third_party/speech-dispatcher'
+ 'third_party/usb_ids'
+ 'third_party/xdg-utils'
+ 'third_party/yasm/run_yasm.py'
+)
# Set build flags.
-_flags=('is_debug=false'
- 'enable_widevine=true'
- 'enable_hangout_services_extension=false'
- "ffmpeg_branding=\"ChromeOS\""
- 'proprietary_codecs=true'
- "google_api_key=\"${_google_api_key}\""
- "google_default_client_id=\"${_google_default_client_id}\""
- "google_default_client_secret=\"${_google_default_client_secret}\""
- 'fieldtrial_testing_like_official_build=false'
- "remove_webcore_debug_symbols=${_strip}"
- 'use_gconf=false'
- "use_gio=false"
- "use_gnome_keyring=${_gnome_keyring}"
- "use_gtk3=${_gtk3}"
- "use_pulseaudio=true"
- "link_pulseaudio=true"
- 'use_kerberos=true'
- 'use_cups=true'
- 'use_sysroot=false'
- 'use_gold=false'
- "use_allocator=\"none\""
- 'linux_use_bundled_binutils=false'
- 'fatal_linker_warnings=false'
- 'treat_warnings_as_errors=false'
- "enable_nacl=${_nacl}"
- "enable_nacl_nonsfi=${_nacl}"
- )
+_flags=(
+ 'is_debug=false'
+ 'enable_widevine=true'
+ 'enable_hangout_services_extension=false'
+ "ffmpeg_branding=\"ChromeOS\""
+ 'proprietary_codecs=true'
+ "google_api_key=\"${_google_api_key}\""
+ "google_default_client_id=\"${_google_default_client_id}\""
+ "google_default_client_secret=\"${_google_default_client_secret}\""
+ 'fieldtrial_testing_like_official_build=false'
+ "remove_webcore_debug_symbols=${_strip}"
+ 'use_gconf=false'
+ "use_gio=false"
+ "use_gnome_keyring=${_gnome_keyring}"
+ "use_gtk3=${_gtk3}"
+ "use_pulseaudio=true"
+ "link_pulseaudio=true"
+ 'use_kerberos=true'
+ 'use_cups=true'
+ 'use_sysroot=false'
+ 'use_gold=false'
+ "use_allocator=\"none\""
+ 'linux_use_bundled_binutils=false'
+ 'fatal_linker_warnings=false'
+ 'treat_warnings_as_errors=false'
+ "enable_nacl=${_nacl}"
+ "enable_nacl_nonsfi=${_nacl}"
+)
# Set the bundled/external components.
# TODO: need ported to GN as GYP doing before. see status page: https://crbug.com/551343
@@ -330,29 +333,35 @@ _flags=('is_debug=false'
# libsrtp
# protobuf
-_use_system=('ffmpeg'
- 'flac'
- 'harfbuzz-ng'
-# 'libevent' # Get segfaults and other problems https://bugs.gentoo.org/593458
- 'libjpeg'
- 'libpng'
- 'libvpx'
- 'libwebp'
-# 'libxml' # https://bugs.archlinux.org/task/29939
- 'libxslt'
- 're2'
- 'snappy'
- 'yasm'
- 'zlib'
- )
+_use_system=(
+ 'ffmpeg'
+ 'flac'
+ 'harfbuzz-ng'
+# 'icu'
+# 'libevent' # Get segfaults and other problems https://bugs.gentoo.org/593458
+ 'libjpeg'
+ 'libpng'
+ 'libvpx'
+ 'libwebp'
+ 'libxml'
+ 'libxslt'
+ 're2'
+ 'snappy'
+ 'yasm'
+ 'zlib'
+)
# Conditionals.
if [ "${_debug_mode}" = "1" ]; then
- _keeplibs+=('native_client/src/third_party/valgrind')
+ _keeplibs+=(
+ 'native_client/src/third_party/valgrind'
+ )
fi
if [ "${_build_nacl}" = "1" ]; then
- _keeplibs+=('third_party/icu')
+ _keeplibs+=(
+ 'third_party/icu' # https://crbug.com/678661
+ )
elif [ "${_build_nacl}" = "0" ]; then
depends+=('icu')
_use_system+=('icu')
@@ -363,7 +372,9 @@ fi
prepare() {
# Use custom toolchain.
- _flags+=("custom_toolchain=\"${srcdir}:default\"")
+ _flags+=(
+ "custom_toolchain=\"${srcdir}:default\""
+ )
# Set Python2 path.
mkdir -p python-path
@@ -388,6 +399,7 @@ prepare() {
if [ "${_enable_vaapi}" = 1 ]; then
patch -p1 -i "${srcdir}/enable_vaapi_on_linux_${pkgver}.diff"
patch -p1 -i "${srcdir}/specify-max-resolution_${pkgver}.patch"
+ patch -p1 -i "${srcdir}/fix-gl-image_${pkgver}.patch"
fi
# Fix paths.
@@ -398,7 +410,6 @@ prepare() {
-i content/common/sandbox_linux/bpf_gpu_policy_linux.cc
patch -p1 -i "${srcdir}/minizip.patch"
- patch -p1 -i "${srcdir}/unset-madv_free.patch"
# Patch from crbug (chromium bugtracker).
# https://crbug.com/473866
@@ -449,27 +460,29 @@ prepare() {
python2 tools/clang/scripts/update.py
fi
+_set_gcc() {
+ _flags+=(
+ 'is_clang=false'
+ 'clang_use_chrome_plugins=false'
+ )
+ export CC="${_ccache} gcc -Wall"
+ export CXX="${_ccache} g++ -Wall"
+}
+
# Setup compilers.
# Use system/bundled Clang? or GCC?.
if [ "${_use_clang}" = "0" ]; then
- _flags+=('is_clang=false'
- 'clang_use_chrome_plugins=false'
- )
- export CC="${_ccache} gcc -Wall"
- export CXX="${_ccache} g++ -Wall"
+ _set_gcc
elif [ "${_use_clang}" = "1" ]; then
if [ "${CARCH}" = 'i686' ]; then
msg2 "Build with (bundled) clang is not possible in 32bit systems. then, Use system GCC"
- _flags+=('is_clang=false'
- 'clang_use_chrome_plugins=false'
- )
- export CC="${_ccache} gcc -Wall"
- export CXX="${_ccache} g++ -Wall"
+ _set_gcc
elif [ "${CARCH}" = 'x86_64' ]; then
msg2 "Setup for use clang"
- _flags+=('is_clang=true'
- 'clang_use_chrome_plugins=true'
- )
+ _flags+=(
+ 'is_clang=true'
+ 'clang_use_chrome_plugins=true'
+ )
_clang_path="${srcdir}/chromium-${pkgver}/third_party/llvm-build/Release+Asserts/bin"
export CXXFLAGS="${CXXFLAGS} -Wno-unknown-warning-option"
export CC="${_ccache} ${_clang_path}/clang -Qunused-arguments"
@@ -531,16 +544,17 @@ package() {
install -Dm644 natives_blob.bin "${pkgdir}/usr/lib/chromium-dev/natives_blob.bin"
install -Dm644 snapshot_blob.bin "${pkgdir}/usr/lib/chromium-dev/snapshot_blob.bin"
- _resources=('chrome_100_percent'
- 'chrome_200_percent'
- 'keyboard_resources'
- 'mus_app_resources_100'
- 'mus_app_resources_200'
- 'mus_app_resources_strings'
- 'resources'
- 'views_mus_resources'
- )
# Install Resources.
+ _resources=(
+ 'chrome_100_percent'
+ 'chrome_200_percent'
+ 'keyboard_resources'
+ 'mus_app_resources_100'
+ 'mus_app_resources_200'
+ 'mus_app_resources_strings'
+ 'resources'
+ 'views_mus_resources'
+ )
for i in "${_resources[@]}"; do
install -Dm644 "${i}.pak" "${pkgdir}/usr/lib/chromium-dev/${i}.pak"
done
@@ -564,7 +578,7 @@ package() {
install -Dm755 nacl_helper "${pkgdir}/usr/lib/chromium-dev/nacl_helper"
install -Dm755 nacl_helper_bootstrap "${pkgdir}/usr/lib/chromium-dev/nacl_helper_bootstrap"
install -Dm755 nacl_helper_nonsfi "${pkgdir}/usr/lib/chromium-dev/nacl_helper_nonsfi"
- install -Dm755 "nacl_irt_x86_64.nexe" "${pkgdir}/usr/lib/chromium-dev/nacl_irt_x86_64.nexe"
+ install -Dm755 nacl_irt_x86_64.nexe "${pkgdir}/usr/lib/chromium-dev/nacl_irt_x86_64.nexe"
install -Dm644 icudtl.dat "${pkgdir}/usr/lib/chromium-dev/icudtl.dat"
fi