summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorJulian Xhokaxhiu2016-09-27 15:57:58 +0200
committerJulian Xhokaxhiu2016-09-27 15:57:58 +0200
commitcf9ee355545cecf18f3346413a4c99667a5d8765 (patch)
treee754c98454a584492e5904a8f1468d7506b31036 /PKGBUILD
parent20c1bcfcc6d444e3c67821af7cda955c5841877f (diff)
downloadaur-cf9ee355545cecf18f3346413a4c99667a5d8765.tar.gz
Disable web security was not the right solution
In order to disable X-Frame-Option header security, we need to tackle this via an extension. So provide a way to automatically load it, every time the chromium process starts.
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD14
1 files changed, 11 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 89631adff23c..41eff33b9777 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Author: Julian Xhokaxhiu <info@julianxhokaxhiu.com>
pkgname=chromium-fullscreen
pkgver=1
-pkgrel=4
+pkgrel=5
pkgdesc="A script in order to run Chromium in fullscreen mode under the chromium user"
url=""
arch=('x86_64' 'i686' 'arm' 'armv6h' 'armv7h')
@@ -9,9 +9,13 @@ license=('MIT')
depends=('xorg-server' 'xorg-xinit' 'unclutter' 'chromium' 'xlogin-git')
install='chromium-fullscreen.install'
source=('chromium-fullscreen.sysuser'
- 'chromium-fullscreen.xinitrc')
+ 'chromium-fullscreen.xinitrc'
+ 'disable-x-frame-option-background.js'
+ 'disable-x-frame-option-manifest.json')
md5sums=('9e979fbdd1e4a5a04fd0e91ce6a9a7be'
- '7f2ce7a70ebb06b9b8ff0e222f08bb37')
+ '1a2b2cd4bd67769948edcdaabb5592eb'
+ 'c700c36f4ea3e353c6d49df823561fc4'
+ 'f543ec018edbaf5533e6bddd5068ff54')
package() {
# Copy autorun script
@@ -19,4 +23,8 @@ package() {
#Install sysuser config
install -Dm644 ${srcdir}/chromium-fullscreen.sysuser "$pkgdir/usr/lib/sysusers.d/chromium-fullscreen.conf"
+
+ # Copy the extensions files
+ install -Dm644 ${srcdir}/disable-x-frame-option-background.js "$pkgdir/home/chromium/.extensions/disable-x-frame-option/background.js"
+ install -Dm644 ${srcdir}/disable-x-frame-option-manifest.json "$pkgdir/home/chromium/.extensions/disable-x-frame-option/manifest.json"
}