summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorWorMzy Tykashi2018-03-14 14:36:56 +0000
committerWorMzy Tykashi2018-03-14 14:36:56 +0000
commit15fb71c5143af77df12582d6ba5f09009a3c5d60 (patch)
tree6bebf8cbe10adada75fe58c15e69bd3cad836dd4 /PKGBUILD
parent32c8948303af5a0697081c7f3b8bbe16fce93906 (diff)
downloadaur-15fb71c5143af77df12582d6ba5f09009a3c5d60.tar.gz
Updated to 65.0.3325.162
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD62
1 files changed, 22 insertions, 40 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 42455a88acb9..54a2f194d46d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -7,8 +7,8 @@
pkgname=chromium-gtk2
_pkgname=chromium
-pkgver=64.0.3282.140
-pkgrel=2
+pkgver=65.0.3325.162
+pkgrel=1
_launcher_ver=5
pkgdesc="A web browser built for speed, simplicity, and security (GTK2 version)"
arch=('i686' 'x86_64')
@@ -28,34 +28,30 @@ install=chromium.install
source=(https://commondatastorage.googleapis.com/chromium-browser-official/$_pkgname-$pkgver.tar.xz
chromium-launcher-$_launcher_ver.tar.gz::https://github.com/foutrelis/chromium-launcher/archive/v$_launcher_ver.tar.gz
chromium-$pkgver.txt::https://chromium.googlesource.com/chromium/src.git/+/$pkgver?format=TEXT
- chromium-use-fromUTF8-for-UnicodeString-construction.patch
- chromium-omnibox-unescape-fragment.patch
chromium-skia-harmony.patch
- chromium-memcpy-r0.patch
chromium-clang-r2.patch
+ chromium-math.h-r0.patch
+ chromium-stdint.patch
chromium-widevine.patch
- fix-nav-button-layout.patch
- fix-gtk2-namespace.patch)
-sha256sums=('146afbab37982c52251e5c71b6e19e6e7053b527217fe1da9966c794478c29ce'
+ chromium-gtk2-fix-build.patch)
+sha256sums=('627e7bfd84795de1553fac305239130d25186acf2d3c77d39d824327cd116cce'
'4dc3428f2c927955d9ae117f2fb24d098cc6dd67adb760ac9c82b522ec8b0587'
- 'cc3a328836af87f3a262ac7a7bc848e0f3a4b2f9f0346ef76b9b059c6f6d32bc'
- 'c82c830bac7ab328a76d85fb141e150a17d02d97138a6daa4720a8a8c371a402'
- '814eb2cecb10cb697e24036b08aac41e88d0e38971741f9e946200764e2401ae'
+ 'bed2a7ef4b1ebd53b28e2f38963a2dd761267ccc8818693c34ce8596db53dd4c'
'feca54ab09ac0fc9d0626770a6b899a6ac5a12173c7d0c1005bc3964ec83e7b3'
- '455f0029987d9f0532bd9a5250669af5146a9c2b65b776d4a6e2499e8aca7bb4'
'4495e8b29dae242c79ffe4beefc5171eb3c7aacb7e9aebfd2d4d69b9d8c958d3'
+ 'fe0ab86aa5b0072db730eccda3e1582ebed4af25815bfd49fe0da24cf63ca902'
+ 'c00d2506f1078b38a8ebec474a7318e76a61db1298afb40088a34210f137210f'
'd6fdcb922e5a7fbe15759d39ccc8ea4225821c44d98054ce0f23f9d1f00c9808'
- '377cb60201a9bf6a095499273a1d96f43543a4f1dae62e591748eec5c652cf52'
- '500a6b96c62aad2a7f1c9c85372bc30dbed277744290e9c55de53e96da540ffb')
+ 'b57a3e0c10134a3731f07e993d8350b1958fb66114f2663cf411c6e001848422')
# Possible replacements are listed in build/linux/unbundle/replace_gn_files.py
# Keys are the names in the above script; values are the dependencies in Arch
-readonly -A _system_libs=(
+declare -gA _system_libs=(
#[ffmpeg]=ffmpeg # https://crbug.com/731766
[flac]=flac
- #[fontconfig]=fontconfig # Enable for M65
- #[freetype]=freetype2 # Using 'use_system_freetype=true' until M65
- #[harfbuzz-ng]=harfbuzz # Using 'use_system_harfbuzz=true' until M65
+ [fontconfig]=fontconfig
+ [freetype]=freetype2
+ [harfbuzz-ng]=harfbuzz
[icu]=icu
[libdrm]=
[libjpeg]=libjpeg
@@ -70,13 +66,11 @@ readonly -A _system_libs=(
[yasm]=
[zlib]=minizip
)
-readonly _unwanted_bundled_libs=(
+_unwanted_bundled_libs=(
${!_system_libs[@]}
${_system_libs[libjpeg]+libjpeg_turbo}
- freetype
- harfbuzz-ng
)
-depends+=(${_system_libs[@]} freetype2 harfbuzz)
+depends+=(${_system_libs[@]})
# Google API keys (see https://www.chromium.org/developers/how-tos/api-keys)
# Note: These are for Arch Linux use ONLY. For your own distribution, please
@@ -103,18 +97,13 @@ prepare() {
sed "s/@WIDEVINE_VERSION@/Pinkie Pie/" ../chromium-widevine.patch |
patch -Np1
- # https://crbug.com/772655
- patch -Np1 -i ../chromium-use-fromUTF8-for-UnicodeString-construction.patch
-
- # https://crbug.com/789163
- patch -Np1 -i ../chromium-omnibox-unescape-fragment.patch
-
# https://crbug.com/skia/6663#c10
patch -Np4 -i ../chromium-skia-harmony.patch
# Fixes from Gentoo
- patch -Np1 -i ../chromium-memcpy-r0.patch
patch -Np1 -i ../chromium-clang-r2.patch
+ patch -Np1 -i ../chromium-math.h-r0.patch
+ patch -Np1 -i ../chromium-stdint.patch
# Remove compiler flags not supported by our system clang
sed -i \
@@ -124,11 +113,9 @@ prepare() {
-e '/"-Wno-tautological-constant-compare"/d' \
build/config/compiler/BUILD.gn
- # fix NavButtonLayoutManager
- patch -Np1 -i ../fix-nav-button-layout.patch
-
- # fix namespace problem with GTK2 build
- patch -Np1 -i ../fix-gtk2-namespace.patch
+ # Fix GTK2 build
+ # https://chromium-review.googlesource.com/c/chromium/src/+/894993
+ patch -Np1 -i ../chromium-gtk2-fix-build.patch
# Use Python 2
find . -name '*.py' -exec sed -i -r 's|/usr/bin/python$|&2|g' {} +
@@ -149,7 +136,7 @@ prepare() {
\! -path "*third_party/$_lib/chromium/*" \
\! -path "*third_party/$_lib/google/*" \
\! -path './base/third_party/icu/*' \
- \! -path './third_party/freetype/src/src/psnames/pstables.h' \
+ \! -path './third_party/pdfium/third_party/freetype/include/pstables.h' \
\! -path './third_party/yasm/run_yasm.py' \
\! -regex '.*\.\(gn\|gni\|isolate\)' \
-delete
@@ -191,10 +178,7 @@ build() {
'ffmpeg_branding="Chrome"'
'proprietary_codecs=true'
'link_pulseaudio=true'
- 'use_system_freetype=true'
- 'use_system_harfbuzz=true'
'use_gtk3=false'
- 'use_gconf=false'
'use_gnome_keyring=false'
'use_gold=false'
'use_lld=false'
@@ -211,8 +195,6 @@ build() {
)
if check_option strip y; then
- # https://chromium-review.googlesource.com/c/chromium/src/+/712575
- # _flags+=('exclude_unwind_tables=true')
CFLAGS+=' -fno-unwind-tables -fno-asynchronous-unwind-tables'
CXXFLAGS+=' -fno-unwind-tables -fno-asynchronous-unwind-tables'
CPPFLAGS+=' -DNO_UNWIND_TABLES'