summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorWorMzy Tykashi2018-08-14 00:59:53 +0100
committerWorMzy Tykashi2018-08-14 00:59:53 +0100
commit7bb81b75f97a5bdaa25554a395632d32ff2ecd49 (patch)
tree0af892e6023fc07afcccbba37e0482ca8048c920 /PKGBUILD
parenta96f97df27f173ed348583cfa04ca3660b0762fd (diff)
downloadaur-7bb81b75f97a5bdaa25554a395632d32ff2ecd49.tar.gz
Update to 68.0.3440.106
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD20
1 files changed, 12 insertions, 8 deletions
diff --git a/PKGBUILD b/PKGBUILD
index d54b7ee115fa..1da6fb25575d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -7,7 +7,7 @@
pkgname=chromium-gtk2
_pkgname=chromium
-pkgver=68.0.3440.75
+pkgver=68.0.3440.106
pkgrel=1
_launcher_ver=6
pkgdesc="A web browser built for speed, simplicity, and security (GTK2 version)"
@@ -18,7 +18,7 @@ depends=('gtk2' 'nss' 'alsa-lib' 'xdg-utils' 'libxss' 'libcups' 'libgcrypt'
'ttf-font' 'systemd' 'dbus' 'libpulse' 'pciutils' 'json-glib'
'desktop-file-utils' 'hicolor-icon-theme')
makedepends=('python' 'python2' 'gperf' 'yasm' 'mesa' 'ninja' 'nodejs' 'git'
- 'clang' 'lld')
+ 'clang' 'lld' 'gn')
optdepends=('pepper-flash: support for Flash content'
'kdialog: needed for file dialogs in KDE'
'gnome-keyring: for storing passwords in GNOME keyring'
@@ -30,16 +30,20 @@ source=(https://commondatastorage.googleapis.com/chromium-browser-official/$_pkg
chromium-launcher-$_launcher_ver.tar.gz::https://github.com/foutrelis/chromium-launcher/archive/v$_launcher_ver.tar.gz
x11-fix-mixup-between-DIP-pixel-coordinates.patch
blink-disable-XML-catalogs-at-runtime.patch
+ fix-cfi-icall-failure-with-use_system_libjpeg-true.patch
+ only-disable-cfi-icall-when-use_system_libjpeg-true.patch
chromium-cors-string-r0.patch
chromium-ffmpeg-r1.patch
chromium-libjpeg-r0.patch
chromium-libwebp-shim-r0.patch
chromium-widevine-r2.patch
chromium-skia-harmony.patch)
-sha256sums=('dc17783267853bdc0fb726363d2b8e30a0bf43b6cc2c768e1f37c92e8eb59541'
+sha256sums=('7021040635a0a0d47f699bdb22e3ef5c91482e4f51b428d1de3016da95f0e698'
'04917e3cd4307d8e31bfb0027a5dce6d086edb10ff8a716024fbb8bb0c7dccf1'
'e2c2754536243a60fa70541bbd4121715eccd83caa8f1fb1873bd994cd81f871'
'98a5c41cf9687c52ee380d2b683c95387334c76254479c347bdb733646dab815'
+ '97b421bc60a4abdf37de2d88a51b973e9f68fb44d1eccd464adfb3d9f5d71478'
+ '9cae9ded6497afd15ad72d963897425ab6c7f28941bb3c3948e7996610a0d180'
'f4141e48a25a1403250e9040c18936a16250ab707064dd54103066f40c7db41c'
'aa885330bc4180b78d915f9dfdfc3210038a0acab7b16735ea9828ab6a633bde'
'6b8fc570607631d3558e99a82e92c11eeae9c960ebb0a83c13d46344d4b6adca'
@@ -95,6 +99,10 @@ prepare() {
# https://crbug.com/736026
patch -Np1 -i ../blink-disable-XML-catalogs-at-runtime.patch
+ # https://crbug.com/866290
+ patch -Np1 -i ../fix-cfi-icall-failure-with-use_system_libjpeg-true.patch
+ patch -Np1 -i ../only-disable-cfi-icall-when-use_system_libjpeg-true.patch
+
# https://crbug.com/skia/6663#c10
patch -Np4 -i ../chromium-skia-harmony.patch
@@ -153,7 +161,6 @@ build() {
'host_toolchain="//build/toolchain/linux/unbundle:default"'
'clang_use_chrome_plugins=false'
'is_official_build=true' # implies is_cfi=true on x86_64
- 'use_cfi_icall=false' # https://crbug.com/866290
'is_debug=false'
'treat_warnings_as_errors=false'
'fieldtrial_testing_like_official_build=true'
@@ -189,10 +196,7 @@ build() {
CPPFLAGS+=' -DNO_UNWIND_TABLES'
fi
- python2 tools/gn/bootstrap/bootstrap.py -s --no-clean
- out/Release/gn gen out/Release --args="${_flags[*]}" \
- --script-executable=/usr/bin/python2
-
+ gn gen out/Release --args="${_flags[*]}" --script-executable=/usr/bin/python2
ninja -C out/Release chrome chrome_sandbox chromedriver
}