summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorgraysky2023-10-28 06:10:15 -0400
committergraysky2023-10-28 06:10:15 -0400
commit22b331f9b0540b9be0929e62839cac580225938e (patch)
tree1010d14e07e64cd436b9e817b15974bab6052e8e /PKGBUILD
parent59c8ffa08e29962dd6c56e8ce073164ba9d17281 (diff)
downloadaur-22b331f9b0540b9be0929e62839cac580225938e.tar.gz
Update to 119.0.6045.59-1
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD18
1 files changed, 7 insertions, 11 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 547507d3a0e9..41c8c1921f44 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,7 +6,7 @@
_pkgname=chromium
pkgname=chromium-no-extras
-pkgver=118.0.5993.117
+pkgver=119.0.6045.59
pkgrel=1
_launcher_ver=8
_manual_clone=0
@@ -30,13 +30,11 @@ options=('!lto') # Chromium adds its own flags for ThinLTO
source=(https://commondatastorage.googleapis.com/chromium-browser-official/chromium-$pkgver.tar.xz
https://github.com/foutrelis/chromium-launcher/archive/v$_launcher_ver/chromium-launcher-$_launcher_ver.tar.gz
https://gitlab.com/Matt.Jolly/chromium-patches/-/archive/${pkgver%%.*}/chromium-patches-${pkgver%%.*}.tar.bz2
- free-the-X11-pixmap-in-the-NativePixmapEGLX11Bind.patch
REVERT-disable-autoupgrading-debug-info.patch
use-oauth2-client-switches-as-default.patch)
-sha256sums=('7029d851e4a2e8d5a145a6f6ba76f18f5c3043f57b2c750b35d96e92f3453786'
+sha256sums=('039cba06c694aef9318f2a2c89c176ce3e9147a7bc2324f856077f8002b15d0e'
'213e50f48b67feb4441078d50b0fd431df34323be15be97c55302d3fdac4483a'
- '0d1eb054965711a2d4ed6b4cb7f06cbda5b374a48e1b99c8c38ebf6375a781a9'
- 'ab1eb107ec1c915065dc59cf4832da27e17d60eb29038e2aec633daeb946cc6a'
+ '09ecf142254525ddb9c2dbbb2c71775e68722412923a5a9bba5cc2e46af8d087'
'1b782b0f6d4f645e4e0daa8a4852d63f0c972aa0473319216ff04613a0592a69'
'e393174d7695d0bafed69e868c5fbfecf07aa6969f3b64596d0bae8b067e1711')
@@ -58,7 +56,7 @@ declare -gA _system_libs=(
[icu]=icu
[jsoncpp]=jsoncpp
#[libaom]=aom
- [libavif]=libavif
+ #[libavif]=libavif # needs https://github.com/AOMediaCodec/libavif/commit/5410b23f76
[libdrm]=
[libjpeg]=libjpeg
[libpng]=libpng
@@ -116,19 +114,17 @@ prepare() {
patch -Np1 -i ../use-oauth2-client-switches-as-default.patch
# Upstream fixes
- patch -Np1 -i ../free-the-X11-pixmap-in-the-NativePixmapEGLX11Bind.patch
# Revert addition of compiler flag that needs newer clang
patch -Rp1 -i ../REVERT-disable-autoupgrading-debug-info.patch
# Fixes for building with libstdc++ instead of libc++
- patch -Np1 -i ../chromium-patches-*/chromium-114-maldoca-include.patch
patch -Np1 -i ../chromium-patches-*/chromium-114-ruy-include.patch
patch -Np1 -i ../chromium-patches-*/chromium-114-vk_mem_alloc-include.patch
patch -Np1 -i ../chromium-patches-*/chromium-117-material-color-include.patch
- patch -Np1 -i ../chromium-patches-*/chromium-118-SensorReadingField-include.patch
- patch -Np1 -i ../chromium-patches-*/chromium-118-LightweightDetector-include.patch
- patch -Np1 -i ../chromium-patches-*/chromium-118-system-freetype.patch
+ patch -Np1 -i ../chromium-patches-*/chromium-119-FragmentDataIterator-std.patch
+ patch -Np1 -i ../chromium-patches-*/chromium-119-at-spi-variable-consumption.patch
+ patch -Np1 -i ../chromium-patches-*/chromium-119-clang16.patch
# Link to system tools required by the build
mkdir -p third_party/node/linux/node-linux-x64/bin