summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorgraysky2022-09-03 04:41:28 -0400
committergraysky2022-09-03 04:42:00 -0400
commit4ecdd49bd370c7cc22f9107240b06170bc906cea (patch)
treef320a12c3a9df05244e31b070d1db84144be6943 /PKGBUILD
parent5fd6a3e2723c719b9c56ed15b9a7b7583eae469e (diff)
downloadaur-4ecdd49bd370c7cc22f9107240b06170bc906cea.tar.gz
Update to 105.0.5195.102-1
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD38
1 files changed, 21 insertions, 17 deletions
diff --git a/PKGBUILD b/PKGBUILD
index b676e40f164f..e0881ec3dfe8 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -11,10 +11,10 @@
pkgname=chromium-no-extras
_pkgname=chromium
-pkgver=104.0.5112.101
+pkgver=105.0.5195.102
pkgrel=1
_launcher_ver=8
-_gcc_patchset=2
+_gcc_patchset=1
pkgdesc="Chromium without hangout services, widevine, pipewire, or chromedriver"
arch=('x86_64')
url="https://www.chromium.org/Home"
@@ -34,31 +34,34 @@ options=('debug' '!lto') # Chromium adds its own flags for ThinLTO
source=(https://commondatastorage.googleapis.com/chromium-browser-official/chromium-$pkgver.tar.xz
https://github.com/foutrelis/chromium-launcher/archive/v$_launcher_ver/chromium-launcher-$_launcher_ver.tar.gz
https://github.com/stha09/chromium-patches/releases/download/chromium-${pkgver%%.*}-patchset-$_gcc_patchset/chromium-${pkgver%%.*}-patchset-$_gcc_patchset.tar.xz
- x11-ozone-fix-X11-screensaver-suspension.patch
+ fix-TFLite-build-on-linux-with-system-zlib.patch
enable-GlobalMediaControlsCastStartStop.patch
roll-src-third_party-ffmpeg.patch
- chromium-tflite-system-zlib.patch
- remove-no-opaque-pointers-flag.patch
+ angle-wayland-include-protocol.patch
use-oauth2-client-switches-as-default.patch)
-sha256sums=('60f015e1559de4044cdfa3bdc1f8fde535927c8ab15b0959ccc9b6feec832f5b'
+sha256sums=('1cba0527c951e3c506ade96cf6ec2507ee9d43661764731ed896348182369262'
'213e50f48b67feb4441078d50b0fd431df34323be15be97c55302d3fdac4483a'
- 'ce702099849465927cf47f7bc3a4a27045d0e35e16b17481ebf35e14506bafa7'
- '9956a843bc8a765c130080616ccd3ebc46ea95c3a2324c4b403bc293a8705eb2'
+ 'f0c437c02cab7a6efc958f82fbb4ea35d5440f73d65731bad7c0dcaecb932121'
+ '5db1fae8a452774b5b177e493a2d1a435b980137b16ed74616d1fb86fe342ec7'
'779fb13f2494209d3a7f1f23a823e59b9dded601866d3ab095937a1a04e19ac6'
'30df59a9e2d95dcb720357ec4a83d9be51e59cc5551365da4c0073e68ccdec44'
- '588c166bf748793758a7df438cfa665b32e09ca8fbd6380be28bc5984a33523c'
- 'ab46b2c26a4dfe86486fd7e31bfc7211c515994a61a8c0cbd742f9c9e3c91873'
+ 'cd0d9d2a1d6a522d47c3c0891dabe4ad72eabbebc0fe5642b9e22efa3d5ee572'
'e393174d7695d0bafed69e868c5fbfecf07aa6969f3b64596d0bae8b067e1711')
# Possible replacements are listed in build/linux/unbundle/replace_gn_files.py
# Keys are the names in the above script; values are the dependencies in Arch
declare -gA _system_libs=(
+ [brotli]=brotli
+ [dav1d]=dav1d
[ffmpeg]=ffmpeg
[flac]=flac
[fontconfig]=fontconfig
[freetype]=freetype2
[harfbuzz-ng]=harfbuzz
[icu]=icu
+ [jsoncpp]=jsoncpp
+ [libaom]=aom
+ [libavif]=libavif
[libdrm]=
[libjpeg]=libjpeg
[libpng]=libpng
@@ -69,6 +72,7 @@ declare -gA _system_libs=(
[opus]=opus
[re2]=re2
[snappy]=snappy
+ [woff2]=woff2
[zlib]=minizip
)
_unwanted_bundled_libs=(
@@ -103,14 +107,8 @@ prepare() {
# runtime -- this allows signing into Chromium without baked-in values
patch -Np1 -i ../use-oauth2-client-switches-as-default.patch
- # Remove '-Xclang -no-opaque-pointers' flag not supported by our clang
- patch -Np1 -i ../remove-no-opaque-pointers-flag.patch
-
- # Fix build with unbundled zlip (patch from Gentoo)
- patch -Np1 -i ../chromium-tflite-system-zlib.patch
-
# Upstream fixes
- patch -Np1 -i ../x11-ozone-fix-X11-screensaver-suspension.patch
+ patch -Np1 -i ../fix-TFLite-build-on-linux-with-system-zlib.patch
# Revert kGlobalMediaControlsCastStartStop enabled by default
# https://crbug.com/1314342
@@ -120,8 +118,14 @@ prepare() {
# https://crbug.com/1325301
patch -Rp1 -i ../roll-src-third_party-ffmpeg.patch
+ # https://crbug.com/angleproject/7582
+ patch -Np0 -i ../angle-wayland-include-protocol.patch
+
# Fixes for building with libstdc++ instead of libc++
patch -Np1 -i ../patches/chromium-103-VirtualCursor-std-layout.patch
+ patch -Np1 -i ../patches/chromium-105-Bitmap-include.patch
+ patch -Np1 -i ../patches/chromium-105-browser_finder-include.patch
+ patch -Np1 -i ../patches/chromium-105-AdjustMaskLayerGeometry-ceilf.patch
# Link to system tools required by the build
mkdir -p third_party/node/linux/node-linux-x64/bin