summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorgraysky2024-03-13 15:29:08 -0400
committergraysky2024-03-13 15:29:08 -0400
commit5d92980bf8bcde3b8665c59f2c4357beb41c44aa (patch)
tree85e2052585f30dccd7de8843fe95ecedf8c87d33 /PKGBUILD
parentda8e117c6337b43e8f9bc9afc3f6419715f83abc (diff)
downloadaur-5d92980bf8bcde3b8665c59f2c4357beb41c44aa.tar.gz
Update to 122.0.6261.128-1
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD35
1 files changed, 10 insertions, 25 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 91e0aae030f5..833098d3e0e6 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,7 +6,7 @@
_pkgname=chromium
pkgname=chromium-no-extras
-pkgver=122.0.6261.111
+pkgver=122.0.6261.128
pkgrel=1
_launcher_ver=8
_manual_clone=0
@@ -33,21 +33,15 @@ source=(https://commondatastorage.googleapis.com/chromium-browser-official/chrom
https://github.com/foutrelis/chromium-launcher/archive/v$_launcher_ver/chromium-launcher-$_launcher_ver.tar.gz
https://gitlab.com/Matt.Jolly/chromium-patches/-/archive/${pkgver%%.*}/chromium-patches-${pkgver%%.*}.tar.bz2
support-ICU-74-in-LazyTextBreakIterator.patch
- REVERT-simplify-blink-NativeValueTraitsBase.patch
- REVERT-use-v8-Array-Iterate-for-converting-script-wrappables.patch
- chromium-constexpr.patch
- drop-flags-unsupported-by-clang16.patch
- compiler-rt-16.patch
+ drop-flag-unsupported-by-clang17.patch
+ compiler-rt-adjust-paths.patch
use-oauth2-client-switches-as-default.patch)
-sha256sums=('0b3da2f0ca63625e84a1b36571f23591248b8fcb422ce683c09283dbfc35c309'
+sha256sums=('51757e7ecf5bb1db4881562d021547be5f8065e4f22a6ba9bf6e9a3a0d32c2ea'
'213e50f48b67feb4441078d50b0fd431df34323be15be97c55302d3fdac4483a'
'1f6acf165578288dc84edc7d9dcfabf7d38f55153b63a37ee5afa929f0e2baad'
'8c256b2a9498a63706a6e7a55eadbeb8cc814be66a75e49aec3716c6be450c6c'
- '318df8f8662071cebcdf953698408058e17f59f184500b7e12e01a04a4206b50'
- '00e06b889e4face0ef41293233ce55bd52064ab040f1fdd84aa19525f8ac3601'
- 'a061f83e2b628927feb4dbc441eb54f8b8c3d81348e447cf3b90755d7cda5f54'
- '53774fd7f807ad42f77d45cab9e5480cc2bcb0a5c5138110a434407521af9607'
- '8a2649dcc6ff8d8f24ddbe40dc2a171824f681c6f33c39c4792b645b87c9dcab'
+ '3bd35dab1ded5d9e1befa10d5c6c4555fe0a76d909fb724ac57d0bf10cb666c1'
+ 'b3de01b7df227478687d7517f61a777450dca765756002c80c4915f271e2d961'
'e393174d7695d0bafed69e868c5fbfecf07aa6969f3b64596d0bae8b067e1711')
if (( _manual_clone )); then
@@ -128,20 +122,11 @@ prepare() {
# Upstream fixes
patch -Np1 -i ../support-ICU-74-in-LazyTextBreakIterator.patch
- # Fix "error: defaulted definition of equality comparison operator cannot
- # be declared constexpr because it invokes a non-constexpr comparison
- # function" (patch for Chromium 121 from Fedora, later extended for 122)
- patch -Np1 -i ../chromium-constexpr.patch
+ # Drop compiler flag that needs newer clang
+ patch -Np1 -i ../drop-flag-unsupported-by-clang17.patch
- # Revert usage of C++20 features which likely need newer clang
- patch -Rp1 -i ../REVERT-use-v8-Array-Iterate-for-converting-script-wrappables.patch
- patch -Rp1 -i ../REVERT-simplify-blink-NativeValueTraitsBase.patch
-
- # Drop compiler flags that need newer clang
- patch -Np1 -i ../drop-flags-unsupported-by-clang16.patch
-
- # Allow libclang_rt.builtins from compiler-rt 16 to be used
- patch -Np1 -i ../compiler-rt-16.patch
+ # Allow libclang_rt.builtins from compiler-rt >= 16 to be used
+ patch -Np1 -i ../compiler-rt-adjust-paths.patch
# Fixes for building with libstdc++ instead of libc++
patch -Np1 -i ../chromium-patches-*/chromium-114-ruy-include.patch