summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorgraysky2019-06-21 19:08:15 -0400
committergraysky2019-06-21 19:08:15 -0400
commitbd7fdbd9417281765063fb7dde17821a81ed9ce5 (patch)
tree178a5ee1a8e7147a90e9e0a660cc09baa205a260 /PKGBUILD
parentbe7aa3c14bd495f2a57eeca44ec056f9e5478d40 (diff)
downloadaur-bd7fdbd9417281765063fb7dde17821a81ed9ce5.tar.gz
Update to 75.0.3770.100-2
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD20
1 files changed, 14 insertions, 6 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 97b0289f8485..eaac93a74e68 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,8 +6,8 @@
pkgname=chromium-no-extras
_pkgname=chromium
-pkgver=75.0.3770.90
-pkgrel=3
+pkgver=75.0.3770.100
+pkgrel=2
_launcher_ver=6
pkgdesc="Chromium without hangout services, widevine, pipewire"
arch=('x86_64')
@@ -28,14 +28,16 @@ install=chromium.install
source=(https://commondatastorage.googleapis.com/chromium-browser-official/$_pkgname-$pkgver.tar.xz
chromium-launcher-$_launcher_ver.tar.gz::https://github.com/foutrelis/chromium-launcher/archive/v$_launcher_ver.tar.gz
chromium-system-icu.patch
+ chromium-non-const-deltas.patch
libstdc-do-not-assume-unique_ptr-has-ostream-operator.patch
disallow-partial-swaps-for-linux-based-on-gl_version.patch
chromium-fix-window-flash-for-some-WMs.patch
chromium-widevine.patch
chromium-skia-harmony.patch)
-sha256sums=('b1b59abbe19ecb88c17d99fa68f5c1c5585a5d66c100858f944aa3b93b943839'
+sha256sums=('9e1360101b6d9f9635e540db77626e3e15b452f413d8750518244ac37b73fca0'
'04917e3cd4307d8e31bfb0027a5dce6d086edb10ff8a716024fbb8bb0c7dccf1'
'e2d284311f49c529ea45083438a768db390bde52949995534034d2a814beab89'
+ '09c5f16b726ef7031d74807b534fbbfa49a7276ee2a239b70602de2704fa197c'
'e309dfd9d790f32cb1d23103726ac25e405b6ae6757a1c957a8395667d753908'
'1e4686de75c019f38a3ed947463e429a777d5387fd29310deef2108c58617b07'
'183d8cc712f0bcf1afcb01ce90c4c104a4c8d8070a06f94974a28b007d9e2ce4'
@@ -108,6 +110,9 @@ prepare() {
# https://bugs.gentoo.org/661880#c21
patch -Np1 -i ../chromium-system-icu.patch
+ # https://bugs.gentoo.org/686982#c5
+ patch -Np1 -i ../chromium-non-const-deltas.patch
+
# Force script incompatible with Python 3 to use /usr/bin/python2
sed -i '1s|python$|&2|' third_party/dom_distiller_js/protoc_plugins/*.py
@@ -155,6 +160,8 @@ build() {
'fieldtrial_testing_like_official_build=true'
'ffmpeg_branding="Chrome"'
'proprietary_codecs=true'
+ 'rtc_use_pipewire=false'
+ 'rtc_link_pipewire=false'
'link_pulseaudio=true'
'use_gnome_keyring=false'
'use_sysroot=false'
@@ -184,7 +191,8 @@ build() {
fi
gn gen out/Release --args="${_flags[*]}" --script-executable=/usr/bin/python2
- ninja -C out/Release chrome chrome_sandbox chromedriver
+ #ninja -C out/Release chrome chrome_sandbox chromedriver
+ ninja -C out/Release chrome chrome_sandbox
}
package() {
@@ -197,7 +205,7 @@ package() {
install -D out/Release/chrome "$pkgdir/usr/lib/chromium/chromium"
install -Dm4755 out/Release/chrome_sandbox "$pkgdir/usr/lib/chromium/chrome-sandbox"
- ln -s /usr/lib/chromium/chromedriver "$pkgdir/usr/bin/chromedriver"
+ #ln -s /usr/lib/chromium/chromedriver "$pkgdir/usr/bin/chromedriver"
install -Dm644 chrome/installer/linux/common/desktop.template \
"$pkgdir/usr/share/applications/chromium.desktop"
@@ -212,7 +220,7 @@ package() {
cp \
out/Release/{chrome_{100,200}_percent,resources}.pak \
- out/Release/{*.bin,chromedriver} \
+ out/Release/{*.bin} \
"$pkgdir/usr/lib/chromium/"
install -Dm644 -t "$pkgdir/usr/lib/chromium/locales" out/Release/locales/*.pak