summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorgraysky2019-12-18 06:45:17 -0500
committergraysky2019-12-18 06:45:17 -0500
commitfb7ad0903810e29b0fcfc528fcd30c2cdefe873f (patch)
tree876c70602386a3218c497bd1872581bb68c7bcbe /PKGBUILD
parent55f89e1ebc9680ccb083c5e6b43477cc396a8796 (diff)
downloadaur-fb7ad0903810e29b0fcfc528fcd30c2cdefe873f.tar.gz
Update to 79.0.3945.88-1
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD43
1 files changed, 19 insertions, 24 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 035ea797bf8a..42377b25e409 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,8 +6,8 @@
pkgname=chromium-no-extras
_pkgname=chromium
-pkgver=78.0.3904.108
-pkgrel=2
+pkgver=79.0.3945.88
+pkgrel=1
_launcher_ver=6
pkgdesc="Chromium without hangout services, widevine, pipewire, or chromedriver"
arch=('x86_64')
@@ -22,30 +22,28 @@ makedepends=('python' 'python2' 'gperf' 'yasm' 'mesa' 'ninja' 'nodejs' 'git'
'clang' 'lld' 'gn' 'java-runtime-headless')
optdepends=('pepper-flash: support for Flash content'
'kdialog: needed for file dialogs in KDE'
- 'gnome-keyring: for storing passwords in GNOME keyring'
- 'kwallet: for storing passwords in KWallet')
+ 'org.freedesktop.secrets: password storage backend on GNOME / Xfce'
+ 'kwallet: for storing passwords in KWallet on KDE desktops')
install=chromium.install
source=(https://commondatastorage.googleapis.com/chromium-browser-official/$_pkgname-$pkgver.tar.xz
chromium-launcher-$_launcher_ver.tar.gz::https://github.com/foutrelis/chromium-launcher/archive/v$_launcher_ver.tar.gz
- add-missing-include-for-unique_ptr.patch
- dns_util-make-DohUpgradeEntry-non-const.patch
- fix-shutdown-crash-in-ProfileManager.patch
+ launch_manager.h-uses-std-vector.patch
+ include-algorithm-to-use-std-lower_bound.patch
icu65.patch
chromium-system-icu.patch
chromium-system-zlib.patch
+ chromium-system-hb.patch
fix-spammy-unique-font-matching-log.patch
- chromium-widevine.patch
chromium-skia-harmony.patch)
-sha256sums=('f9c53839f306d2973de27723360024f7904101d426b9e7e9cdb56e8bcc775b0e'
+sha256sums=('4f18171d2225502018fcafae860ce9329199bcd6a0e50f8d83de041afd723fc9'
'04917e3cd4307d8e31bfb0027a5dce6d086edb10ff8a716024fbb8bb0c7dccf1'
- '49052e8aa630c4aa57bf46823edc32b7b309493275163c3bb3f9fd390c73356e'
- '69694ab12a5ced389916c0c5e8c7bdc191544f576b134ddfb2fe9d4ed9ec4494'
- '4f81612c28957987f7344d8ce2b95a4a63136a8319c9751819436b11c62df057'
+ 'bd0fae907c451252e91c4cbf1ad301716bc9f8a4644ecc60e9590a64197477d3'
+ '1f906676563e866e2b59719679e76e0b2f7f082f48ef0593e86da0351a586c73'
'1de9bdbfed482295dda45c7d4e323cee55a34e42f66b892da1c1a778682b7a41'
'e73cc2ee8d3ea35aab18c478d76fdfc68ca4463e1e10306fa1e738c03b3f26b5'
'eb67eda4945a89c3b90473fa8dc20637511ca4dcb58879a8ed6bf403700ca9c8'
+ 'c0ad3fa426cb8fc1a237ddc6309a6b2dd4055bbe41dd07f50071ee61f969b81a'
'6fbffe59b886195b92c9a55137cef83021c16593f49714acb20023633e3ebb19'
- 'd081f2ef8793544685aad35dea75a7e6264a2cb987ff3541e6377f4a3650a28b'
'771292942c0901092a402cc60ee883877a99fb804cb54d568c8c6c94565a48e1')
# Possible replacements are listed in build/linux/unbundle/replace_gn_files.py
@@ -96,14 +94,9 @@ prepare() {
third_party/blink/renderer/core/xml/parser/xml_document_parser.cc \
third_party/libxml/chromium/libxml_utils.cc
- # Missing include in third_party/blink/public/platform/web_rtc_rtp_source.h
- patch -Np1 -i ../add-missing-include-for-unique_ptr.patch
-
- # https://crbug.com/957519#c23
- patch -Np1 -i ../dns_util-make-DohUpgradeEntry-non-const.patch
-
- # https://crbug.com/1005244
- patch -Np1 -i ../fix-shutdown-crash-in-ProfileManager.patch
+ # https://crbug.com/819294
+ patch -Np1 -i ../launch_manager.h-uses-std-vector.patch
+ patch -Np1 -i ../include-algorithm-to-use-std-lower_bound.patch
# https://crbug.com/1014272
patch -Np1 -i ../icu65.patch
@@ -111,13 +104,11 @@ prepare() {
# Fixes from Gentoo
patch -Np1 -i ../chromium-system-icu.patch
patch -Np1 -i ../chromium-system-zlib.patch
+ patch -Np1 -i ../chromium-system-hb.patch
# https://crbug.com/1005508
patch -Np1 -i ../fix-spammy-unique-font-matching-log.patch
- # Load Widevine CDM if available
- patch -Np1 -i ../chromium-widevine.patch
-
# https://crbug.com/skia/6663#c10
patch -Np0 -i ../chromium-skia-harmony.patch
@@ -184,6 +175,10 @@ build() {
"google_default_client_secret=\"${_google_default_client_secret}\""
)
+ if [[ -n ${_system_libs[icu]+set} ]]; then
+ _flags+=('icu_use_data_file=false')
+ fi
+
if check_option strip y; then
_flags+=('symbol_level=0')
fi