summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorlilac2019-06-17 09:09:44 +0800
committerlilac2019-06-17 09:09:44 +0800
commit9df5c282a90429cbae4feb2e9449b34f1ef2188f (patch)
tree2db5bac212cfc78761ea73e255af8f2d341c1a6b /PKGBUILD
downloadaur-9df5c282a90429cbae4feb2e9449b34f1ef2188f.tar.gz
update by lilac
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD30
1 files changed, 30 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..b44dcb412ebd
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,30 @@
+# Maintainer: Yardena Cohen <yardenack at gmail dot com>
+
+# check for new commits:
+# https://github.com/gorhill/uBlock/commits/master
+
+gitname=uMatrix
+pkgname=chromium-umatrix-git
+pkgver=1.3.17rc4.2.g3da449b
+pkgrel=1
+pkgdesc="Point and click matrix to filter net requests according to source, destination and type"
+arch=('any')
+url="https://github.com/gorhill/${gitname}"
+license=('GPL3')
+makedepends=(git zip python)
+source=("git+${url}.git" "git+https://github.com/uBlockOrigin/uAssets.git")
+sha512sums=('SKIP' 'SKIP')
+
+pkgver() {
+ cd "${srcdir}/${gitname}"
+ local ver="$(git describe --tags | sed 's|-|\.|g')"
+ printf "%s" "${ver//-/.}"
+}
+build() {
+ cd "${srcdir}/${gitname}"
+ ./tools/make-chromium.sh
+}
+package() {
+ mkdir -p "${pkgdir}/usr/share/${pkgname}"
+ cp -dr --no-preserve=ownership "${srcdir}/${gitname}/dist/build/uMatrix.chromium"/* "${pkgdir}/usr/share/${pkgname}/"
+}