summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorKien Dang Tran2017-05-17 14:29:51 +0200
committerKien Dang Tran2017-05-17 14:29:51 +0200
commit3f187fe2452b474922d2db30c7c581c14734e233 (patch)
tree5a281d0801d91ef2010fee861c2125723f18a786 /PKGBUILD
parent116588f3988e3aa2fb7e5d009bd75d1d670d1db7 (diff)
downloadaur-3f187fe2452b474922d2db30c7c581c14734e233.tar.gz
Updated to version 58.0.3029.110
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD280
1 files changed, 116 insertions, 164 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 1dd67aca3554..191cf3847b19 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,6 +1,7 @@
-# Maintainer: Samantha McVey samantham@posteo.net
+# Maintainer: Kien Dang Tran loganeast257@gmail.com
+# Ex-Maintainer: Samantha McVey samantham@posteo.net
# Based off the official Chromium package, but with a patch to enable VA-API
-#
+# The VA-API patch is taken from the chromium-dev package source
# Official Arch Linux Chromium package Maintainers and Contributors:
#
# Maintainer: Evangelos Foutras <evangelos@foutrelis.com>
@@ -8,47 +9,58 @@
# Contributor: Jan "heftig" Steffens <jan.steffens@gmail.com>
# Contributor: Daniel J Griffiths <ghost1227@archlinux.us>
#
+
+declare -rgA _system_libs=(
+ #[ffmpeg]=ffmpeg # https://bugs.archlinux.org/task/53796
+ [flac]=flac
+ [harfbuzz-ng]=harfbuzz-icu
+ #[icu]=icu # Enable again when upstream supports ICU 59
+ [libjpeg]=libjpeg
+ [libpng]=libpng
+ #[libvpx]=libvpx # https://bugs.gentoo.org/show_bug.cgi?id=611394
+ [libwebp]=libwebp
+ [libxml]=libxml2
+ [libxslt]=libxslt
+ [re2]=re2
+ [snappy]=snappy
+ [yasm]=
+ [zlib]=minizip
+)
+
pkgname=chromium-vaapi
-pkgver=53.0.2785.143
+pkgver=58.0.3029.110
pkgrel=1
_launcher_ver=3
-pkgdesc="Chromium compiled with support for VA-API, allowing GPU accelerated decode of H.264 and other video formats supported by
-your GPU."
+pkgdesc="Chromium compiled with support for VA-API, allowing GPU accelerated decode of H.264 and other video formats supported by your GPU"
arch=('i686' 'x86_64')
-url="http://www.chromium.org/"
+url="https://www.chromium.org/Home"
license=('BSD')
-depends=('gtk2' 'nss' 'alsa-lib' 'xdg-utils' 'bzip2' 'libevent' 'libxss'
- 'libexif' 'libgcrypt' 'ttf-font' 'systemd' 'dbus' 'flac' 'snappy'
- 'speech-dispatcher' 'pciutils' 'libpulse' 'harfbuzz' 'libsecret'
- 'libvpx' 'perl' 'perl-file-basedir' 'desktop-file-utils'
- 'hicolor-icon-theme')
+depends=('gtk2' 'nss' 'alsa-lib' 'xdg-utils' 'libxss' 'libexif' 'libgcrypt'
+ 'ttf-font' 'systemd' 'dbus' 'libpulse' 'perl' 'perl-file-basedir'
+ 'pciutils' 'desktop-file-utils' 'hicolor-icon-theme')
+depends+=(${_system_libs[@]})
provides=('chromium')
conflicts=('chromium')
-makedepends=('python2' 'gperf' 'yasm' 'mesa' 'ninja')
-makedepends_x86_64=('lib32-gcc-libs' 'lib32-zlib')
-optdepends=('libva-intel-driver: Needed to support VA-API for Intel graphics cards'
- 'mesa-vdpau: needed for ATI graphics cards to enable VDPAU'
- 'nvidia-utils: needed for NVIDIA graphics cards to enable VDPAU'
- 'libva-vdpau-driver: needed by NVIDIA/ATI graphics cards to expose VA-API using a VDPAU backend'
+makedepends=('python2' 'gperf' 'yasm' 'mesa' 'ninja' 'nodejs' 'git')
+optdepends=('kdialog: needed for file dialogs in KDE'
+ 'gnome-keyring: for storing passwords in GNOME keyring'
'kwallet: for storing passwords in KWallet')
-options=('!strip')
install=chromium.install
source=(https://commondatastorage.googleapis.com/chromium-browser-official/chromium-$pkgver.tar.xz
chromium-launcher-$_launcher_ver.tar.gz::https://github.com/foutrelis/chromium-launcher/archive/v$_launcher_ver.tar.gz
chromium.desktop
+ chromium-system-ffmpeg-r4.patch
+ chromium-gn-bootstrap-r2.patch
chromium-widevine.patch
- chromium-52.0.2743.116-unset-madv_free.patch
- chromium_vaapi.patch
- chromium_vaapi-intel.patch
- chromium_vaapi-other.patch)
-sha256sums=('c52a58b79bfb27bb87e4a0a6ff213001485fbc747657b290f75d39ddce07dcc3'
+ vaapi_patch_r0.patch)
+sha256sums=('f24cef3dd2acf9dd5ccdeeca47fea42d1c1ddff32b7375dc9e0cd35a4e8d78ff'
'8b01fb4efe58146279858a754d90b49e5a38c9a0b36a1f84cbb7d12f92b84c28'
'028a748a5c275de9b8f776f97909f999a8583a4b77fd1cd600b4fc5c0c3e91e9'
+ 'e3c474dbf3822a0be50695683bd8a2c9dfc82d41c1524a20b4581883c0c88986'
+ '64d743c78183c302c42d1f289863e34c74832fca57443833e46a0a3157e2b5de'
'd6fdcb922e5a7fbe15759d39ccc8ea4225821c44d98054ce0f23f9d1f00c9808'
- '3b3aa9e28f29e6f539ed1c7832e79463b13128863a02e9c6fecd16c30d61c227'
- '4700a2d75c5cec59ff4d78c284d20df591c07321565bb25e4bbbd5c671a5d22e'
- 'c479910bc405666f8c8c7760e983abc20ab65764ca1d889040bcba34e8b5b4b9'
- 'b0965313c6bd653ffda8dae6a6d9f2863488159b49a24a29b1303068321243c6')
+ 'fef17ee6b80b9c60e4579ec4afec72fedb6ab1807ecc5903ab6aa2ccbb9fc8b0')
+
# Google API keys (see http://www.chromium.org/developers/how-tos/api-keys)
# Note: These are for Arch Linux use ONLY. For your own distribution, please
# get your own set of keys. Feel free to contact foutrelis@archlinux.org for
@@ -57,178 +69,122 @@ _google_api_key=AIzaSyDwr302FpOSkGRpLlUpPThNTDPbXcIn_FM
_google_default_client_id=413772536636.apps.googleusercontent.com
_google_default_client_secret=0ZChLK6AxeA3Isu96MkwqDR4
-# We can't build (P)NaCL on i686 because the toolchain is x86_64 only and the
-# instructions on how to build the toolchain from source don't work that well
-# (at least not from within the Chromium 39 source tree).
-# https://sites.google.com/a/chromium.org/dev/nativeclient/pnacl/building-pnacl-components-for-distribution-packagers
-_build_nacl=1
-if [[ $CARCH == i686 ]]; then
- _build_nacl=0
-fi
-
prepare() {
cd "$srcdir/chromium-$pkgver"
- # https://groups.google.com/a/chromium.org/d/topic/chromium-packagers/9JX1N2nf4PU/discussion
- touch chrome/test/data/webui/i18n_process_css_test.html
-
# Enable support for the Widevine CDM plugin
# libwidevinecdm.so is not included, but can be copied over from Chrome
# (Version string doesn't seem to matter so let's go with "Pinkie Pie")
sed "s/@WIDEVINE_VERSION@/Pinkie Pie/" ../chromium-widevine.patch |
patch -Np1
- # Patch to enable VA-API
- printf "Applying chromium_vaapi.patch\n"
- patch -p1 -i "$srcdir"/chromium_vaapi.patch
-
- if [ $pkgname == "chromium-vaapi" ]; then
- printf "Applying chromium_vaapi-intel.patch\n"
- patch -p1 -i "$srcdir"/chromium_vaapi-intel.patch
- else
- printf "Applying chromium_vaapi-other.patch\n"
- patch -p1 -i "$srcdir"/chromium_vaapi-other.patch
- fi
- # Commentception – use bundled ICU due to build failures (50.0.2661.75)
- # See https://crbug.com/584920 and https://crbug.com/592268
- # ---
- ## Remove bundled ICU; its header files appear to get picked up instead of
- ## the system ones, leading to errors during the final link stage.
- ## https://groups.google.com/a/chromium.org/d/topic/chromium-packagers/BNGvJc08B6Q
- #find third_party/icu -type f \! -regex '.*\.\(gyp\|gypi\|isolate\)' -delete
-
- # Disable MADV_FREE (if set by glibc)
- # https://bugzilla.redhat.com/show_bug.cgi?id=1361157
- patch -p1 -i "$srcdir"/chromium-52.0.2743.116-unset-madv_free.patch
-
+ # Fixes from Gentoo
+ #patch -Np1 -i ../chromium-system-ffmpeg-r4.patch
+ patch -Np1 -i ../chromium-gn-bootstrap-r2.patch
# Use Python 2
find . -name '*.py' -exec sed -i -r 's|/usr/bin/python$|&2|g' {} +
+
# There are still a lot of relative calls which need a workaround
mkdir -p "$srcdir/python2-path"
ln -sf /usr/bin/python2 "$srcdir/python2-path/python"
- # Download the PNaCL toolchain on x86_64; i686 toolchain is no longer provided
- if (( $_build_nacl )); then
- python2 build/download_nacl_toolchains.py \
- --packages nacl_x86_newlib,pnacl_newlib,pnacl_translator \
- sync --extract
- fi
+ mkdir -p third_party/node/linux/node-linux-x64/bin
+ ln -s /usr/bin/node third_party/node/linux/node-linux-x64/bin/
+
+ # VA-API patch
+ patch -p1 -i "${srcdir}/vaapi_patch_r0.patch"
+ # Fix paths.
+ sed -e 's|i386-linux-gnu/||g' \
+ -e 's|x86_64-linux-gnu/||g' \
+ -e 's|/usr/lib/va/drivers|/usr/lib/dri|g' \
+ -e 's|/usr/lib64/va/drivers|/usr/lib/dri|g' \
+ -i content/common/sandbox_linux/bpf_gpu_policy_linux.cc
+
+ # Remove bundled libraries for which we will use the system copies; this
+ # *should* do what the remove_bundled_libraries.py script does, with the
+ # added benefit of not having to list all the remaining libraries
+ local _lib
+ for _lib in ${!_system_libs[@]} ${_system_libs[libjpeg]+libjpeg_turbo}; do
+ find -type f -path "*third_party/$_lib/*" \
+ \! -path "*third_party/$_lib/chromium/*" \
+ \! -path "*third_party/$_lib/google/*" \
+ \! -path "*base/third_party/icu/*" \
+ \! -regex '.*\.\(gn\|gni\|isolate\|py\)' \
+ -delete
+ done
+
+ python2 build/linux/unbundle/replace_gn_files.py \
+ --system-libraries "${!_system_libs[@]}"
+
+ python2 third_party/libaddressinput/chromium/tools/update-strings.py
}
build() {
- cd "$srcdir/chromium-launcher-$_launcher_ver"
-
- make PREFIX=/usr
+ make -C "$srcdir/chromium-launcher-$_launcher_ver" PREFIX=/usr
cd "$srcdir/chromium-$pkgver"
export PATH="$srcdir/python2-path:$PATH"
-
- # CFLAGS are passed through release_extra_cflags below
- export -n CFLAGS CXXFLAGS
-
- # Work around bug in v8 in which GCC 6 optimizes away null pointer checks
- # https://bugs.chromium.org/p/v8/issues/detail?id=3782
- # https://gcc.gnu.org/bugzilla/show_bug.cgi?id=69234
- CFLAGS+=' -fno-delete-null-pointer-checks'
-
- local _chromium_conf=(
- -Dgoogle_api_key=$_google_api_key
- -Dgoogle_default_client_id=$_google_default_client_id
- -Dgoogle_default_client_secret=$_google_default_client_secret
- -Dwerror=
- -Dclang=0
- -Dpython_ver=2.7
- -Dlinux_link_gsettings=1
- -Dlinux_link_libpci=1
- -Dlinux_link_libspeechd=1
- -Dlinux_link_pulseaudio=1
- -Dlinux_strip_binary=1
- -Dlinux_use_bundled_binutils=0
- -Dlinux_use_bundled_gold=0
- -Dlinux_use_gold_flags=0
- -Dicu_use_data_file_flag=1
- -Dlogging_like_official_build=1
- -Dtracing_like_official_build=1
- -Dfieldtrial_testing_like_official_build=1
- -Drelease_extra_cflags="$CFLAGS"
- -Dlibspeechd_h_prefix=speech-dispatcher/
- -Dffmpeg_branding=Chrome
- -Dproprietary_codecs=1
- -Duse_gnome_keyring=0
- -Duse_system_bzip2=1
- -Duse_system_flac=1
- -Duse_system_ffmpeg=0
- -Duse_system_harfbuzz=1
- -Duse_system_icu=0
- -Duse_system_libevent=1
- -Duse_system_libjpeg=1
- -Duse_system_libpng=1
- -Duse_system_libvpx=1
- -Duse_system_libxml=0
- -Duse_system_snappy=1
- -Duse_system_xdg_utils=1
- -Duse_system_yasm=1
- -Duse_system_zlib=0
- -Dusb_ids_path=/usr/share/hwdata/usb.ids
- -Duse_mojo=0
- -Duse_gconf=0
- -Duse_sysroot=0
- -Denable_hangout_services_extension=1
- -Denable_widevine=1
- -Ddisable_fatal_linker_warnings=1
- -Ddisable_glibc=1)
-
- if (( ! $_build_nacl )); then
- _chromium_conf+=(
- -Ddisable_nacl=1
- -Ddisable_pnacl=1
- )
- fi
-
- build/linux/unbundle/replace_gyp_files.py "${_chromium_conf[@]}"
- build/gyp_chromium --depth=. "${_chromium_conf[@]}"
-
- ninja -C out/Release chrome chrome_sandbox chromedriver
+ export TMPDIR="$srcdir/temp"
+ mkdir -p "$TMPDIR"
+
+ local _flags=(
+ 'is_clang=false'
+ 'clang_use_chrome_plugins=false'
+ 'is_debug=false'
+ 'fatal_linker_warnings=false'
+ 'treat_warnings_as_errors=false'
+ 'fieldtrial_testing_like_official_build=true'
+ 'remove_webcore_debug_symbols=true'
+ 'ffmpeg_branding="Chrome"'
+ 'proprietary_codecs=true'
+ 'link_pulseaudio=true'
+ 'linux_use_bundled_binutils=false'
+ 'use_gconf=false'
+ 'use_gnome_keyring=false'
+ 'use_gold=false'
+ 'use_sysroot=false'
+ 'enable_hangout_services_extension=true'
+ 'enable_widevine=true'
+ 'enable_nacl=false'
+ "google_api_key=\"${_google_api_key}\""
+ "google_default_client_id=\"${_google_default_client_id}\""
+ "google_default_client_secret=\"${_google_default_client_secret}\""
+ )
+
+ python2 tools/gn/bootstrap/bootstrap.py --gn-gen-args "${_flags[*]}"
+ out/Release/gn gen out/Release --args="${_flags[*]}" \
+ --script-executable=/usr/bin/python2
+
+ ninja -C out/Release chrome chrome_sandbox chromedriver widevinecdmadapter
}
package() {
cd "$srcdir/chromium-launcher-$_launcher_ver"
- make PREFIX=/usr DESTDIR="$pkgdir" install-strip
+ make PREFIX=/usr DESTDIR="$pkgdir" install
install -Dm644 LICENSE \
"$pkgdir/usr/share/licenses/chromium/LICENSE.launcher"
- cd "$srcdir/chromium-$pkgver"
+ cd "$srcdir/$chromium-$pkgver"
install -D out/Release/chrome "$pkgdir/usr/lib/chromium/chromium"
+ install -Dm644 out/Release/chrome.1 "$pkgdir/usr/share/man/man1/chromium.1"
+ install -Dm644 "$srcdir/chromium.desktop" \
+ "$pkgdir/usr/share/applications/chromium.desktop"
install -Dm4755 out/Release/chrome_sandbox \
"$pkgdir/usr/lib/chromium/chrome-sandbox"
- install -D out/Release/chromedriver "$pkgdir/usr/lib/chromium/chromedriver"
-
- cp out/Release/{*.pak,*.bin,libwidevinecdmadapter.so} \
+ cp -a \
+ out/Release/{chrome_{100,200}_percent,resources}.pak \
+ out/Release/{*.bin,chromedriver,libwidevinecdmadapter.so} \
+ out/Release/locales \
+ out/Release/icudtl.dat \
"$pkgdir/usr/lib/chromium/"
- # Manually strip binaries so that 'nacl_irt_*.nexe' is left intact
- strip $STRIP_BINARIES "$pkgdir/usr/lib/chromium/"{chromium,chrome-sandbox} \
- "$pkgdir/usr/lib/chromium/chromedriver"
- strip $STRIP_SHARED "$pkgdir/usr/lib/chromium/libwidevinecdmadapter.so"
-
- if (( $_build_nacl )); then
- cp out/Release/nacl_helper{,_bootstrap} out/Release/nacl_irt_*.nexe \
- "$pkgdir/usr/lib/chromium/"
- strip $STRIP_BINARIES "$pkgdir/usr/lib/chromium/"nacl_helper{,_bootstrap}
- fi
-
- cp -a out/Release/locales "$pkgdir/usr/lib/chromium/"
-
- install -Dm644 out/Release/chrome.1 "$pkgdir/usr/share/man/man1/chromium.1"
-
- install -Dm644 "$srcdir/chromium.desktop" \
- "$pkgdir/usr/share/applications/chromium.desktop"
+ ln -s /usr/lib/chromium/chromedriver "$pkgdir/usr/bin/chromedriver"
for size in 22 24 48 64 128 256; do
install -Dm644 "chrome/app/theme/chromium/product_logo_$size.png" \
@@ -240,11 +196,7 @@ package() {
"$pkgdir/usr/share/icons/hicolor/${size}x${size}/apps/chromium.png"
done
- ln -s /usr/lib/chromium/chromedriver "$pkgdir/usr/bin/chromedriver"
-
install -Dm644 LICENSE "$pkgdir/usr/share/licenses/chromium/LICENSE"
-
- install -Dm644 out/Release/icudtl.dat "${pkgdir}/usr/lib/chromium/icudtl.dat"
}
# vim:set ts=2 sw=2 et: