summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorSamantha McVey2016-08-18 20:16:07 -0700
committerSamantha McVey2016-08-18 20:16:07 -0700
commit7398112cb0460d175675f0d0523fd8ad2b0bb07e (patch)
tree068e42806b727c9d085dd13282c348de01e4571d /PKGBUILD
parentfe54e8f8a464723abf1f7ee4e623982aba99d80b (diff)
downloadaur-7398112cb0460d175675f0d0523fd8ad2b0bb07e.tar.gz
update to 52.0.2743.116, and adding the madv patch that has been added to the official chromium package.
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD18
1 files changed, 12 insertions, 6 deletions
diff --git a/PKGBUILD b/PKGBUILD
index d911baf381f7..1c633a329faf 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -9,7 +9,7 @@
# Contributor: Daniel J Griffiths <ghost1227@archlinux.us>
#
pkgname=chromium-vaapi
-pkgver=52.0.2743.85
+pkgver=52.0.2743.116
pkgrel=1
_launcher_ver=3
pkgdesc="Chromium compiled with support for VA-API, allowing GPU accelerated decode of H.264 and other video formats supported by
@@ -20,8 +20,7 @@ license=('BSD')
depends=('gtk2' 'nss' 'alsa-lib' 'xdg-utils' 'bzip2' 'libevent' 'libxss'
'libexif' 'libgcrypt' 'ttf-font' 'systemd' 'dbus' 'flac' 'snappy'
'speech-dispatcher' 'pciutils' 'libpulse' 'harfbuzz' 'libsecret'
- #'libvpx'
- 'perl' 'perl-file-basedir' 'desktop-file-utils'
+ 'libvpx' 'perl' 'perl-file-basedir' 'desktop-file-utils'
'hicolor-icon-theme')
provides=('chromium')
conflicts=('chromium')
@@ -39,12 +38,14 @@ source=(https://commondatastorage.googleapis.com/chromium-browser-official/chrom
chromium.desktop
chromium-widevine.patch
PNGImageDecoder.patch
+ chromium-52.0.2743.116-unset-madv_free.patch
chromium_vaapi.patch)
-sha256sums=('b70e3e77d8d80fbe2303c889d557864f576709ebb543f402b77bad6d6c74edc3'
+sha256sums=('a194ae1edb041024b3d4b6ba438f32fefdb6f1ecb24a96c50248a486b237a101'
'8b01fb4efe58146279858a754d90b49e5a38c9a0b36a1f84cbb7d12f92b84c28'
'028a748a5c275de9b8f776f97909f999a8583a4b77fd1cd600b4fc5c0c3e91e9'
'd6fdcb922e5a7fbe15759d39ccc8ea4225821c44d98054ce0f23f9d1f00c9808'
'd9fd982ba6d50edb7743db6122b975ad1d3da5a9ad907c8ab7cf574395b186cd'
+ '3b3aa9e28f29e6f539ed1c7832e79463b13128863a02e9c6fecd16c30d61c227'
'a84baad70b205dc051ac42fcd14df0c5e069195ec326c3fd21e246bfdf052d24')
# Google API keys (see http://www.chromium.org/developers/how-tos/api-keys)
@@ -86,8 +87,13 @@ prepare() {
## the system ones, leading to errors during the final link stage.
## https://groups.google.com/a/chromium.org/d/topic/chromium-packagers/BNGvJc08B6Q
#find third_party/icu -type f \! -regex '.*\.\(gyp\|gypi\|isolate\)' -delete
+
+ # Disable MADV_FREE (if set by glibc)
+ # https://bugzilla.redhat.com/show_bug.cgi?id=1361157
+ patch -p1 -i "$srcdir"/chromium-52.0.2743.116-unset-madv_free.patch
- # Use Python 2
+
+ # Use Python 2
find . -name '*.py' -exec sed -i -r 's|/usr/bin/python$|&2|g' {} +
# There are still a lot of relative calls which need a workaround
mkdir -p "$srcdir/python2-path"
@@ -150,7 +156,7 @@ build() {
-Duse_system_libevent=1
-Duse_system_libjpeg=1
-Duse_system_libpng=1
- -Duse_system_libvpx=0
+ -Duse_system_libvpx=1
-Duse_system_libxml=0
-Duse_system_snappy=1
-Duse_system_xdg_utils=1