summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorMaxim Baz2017-10-18 11:40:28 +0200
committerMaxim Baz2017-10-18 12:25:35 +0200
commit7a4890d174ac8bf732ec8bc085d050b38a754a9e (patch)
tree8237da9668ea1ab8f9000be8033747d38954993e /PKGBUILD
parent656731953b94e6f7f6401f5750574ddcae9228b7 (diff)
downloadaur-7a4890d174ac8bf732ec8bc085d050b38a754a9e.tar.gz
Update to 62.0.3202.62
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD48
1 files changed, 24 insertions, 24 deletions
diff --git a/PKGBUILD b/PKGBUILD
index ad99ed115404..436d0ef26efe 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -10,7 +10,7 @@
# Contributor: Daniel J Griffiths <ghost1227@archlinux.us>
pkgname=chromium-vaapi
-pkgver=61.0.3163.100
+pkgver=62.0.3202.62
pkgrel=1
_launcher_ver=5
pkgdesc="Chromium compiled with VA-API support for Intel Graphics"
@@ -33,25 +33,19 @@ source=(https://commondatastorage.googleapis.com/chromium-browser-official/chrom
chromium-launcher-$_launcher_ver.tar.gz::https://github.com/foutrelis/chromium-launcher/archive/v$_launcher_ver.tar.gz
chromium.desktop
breakpad-use-ucontext_t.patch
- chromium-gcc-r1.patch
- chromium-gn-bootstrap-r14.patch
- chromium-atk-r1.patch
- chromium-blink-gcc7.patch
+ crc32c-string-view-check.patch
+ chromium-gn-bootstrap-r17.patch
chromium-widevine.patch
- chromium-libva-remove.patch.gz
- chromium-vaapi-r12.patch)
+ chromium-vaapi-r14.patch)
-sha256sums=('4135968cac6623c1d2b224494600cd274098cce41c298f8c3908b354a34c281b'
+sha256sums=('e8df3150386729ddcb4971636627e54815ad447be5f122201e310f5bb0bcc362'
'4dc3428f2c927955d9ae117f2fb24d098cc6dd67adb760ac9c82b522ec8b0587'
'028a748a5c275de9b8f776f97909f999a8583a4b77fd1cd600b4fc5c0c3e91e9'
'6e9a345f810d36068ee74ebba4708c70ab30421dad3571b6be5e9db635078ea8'
- '11cffe305dd49027c91638261463871e9ecb0ecc6ecc02bfa37b203c5960ab58'
- '98784c4a0a793ecf34987bc8f91ae360d78596a4a59dd47651411381f752a080'
- 'fc0e9abb77b6f8e21a7601ff53f267a854736d711b530be5bbd80d976678e98d'
- 'f94310a7ba9b8b777adfb4442bcc0a8f0a3d549b2cf4a156066f8e2e28e2f323'
+ '35435e8dae76737baafecdc76d74a1c97281c4179e416556e033a06a31468e6d'
+ 'd81319f168dad0e411c8e810f73daa2f56ff579578771bd9c9bb1aa2d7c09a8b'
'd6fdcb922e5a7fbe15759d39ccc8ea4225821c44d98054ce0f23f9d1f00c9808'
- '6339c9f1058a1595fabf5622b95e8dc93abed62e2772e3a06041a48ce6876dac'
- 'f8ec3b1ee04c4830ae6c9c0c9b9d757107430ab52ac0b8d485403bb9a4ef26c7')
+ 'dd4fa56c084083a550799217ff65d6216c835a8ef2b7aa22bab3fe3932e4a9d6')
# Possible replacements are listed in build/linux/unbundle/replace_gn_files.py
# Keys are the names in the above script; values are the dependencies in Arch
@@ -60,7 +54,7 @@ declare -rgA _system_libs=(
[flac]=flac
#[freetype]=freetype2 # https://crbug.com/pdfium/733
[harfbuzz-ng]=harfbuzz-icu
- #[icu]=icu # Enable again when upstream supports ICU 59
+ [icu]=icu
[libdrm]=
[libjpeg]=libjpeg
#[libpng]=libpng # https://crbug.com/752403#c10
@@ -86,22 +80,29 @@ _google_default_client_secret=0ZChLK6AxeA3Isu96MkwqDR4
prepare() {
cd "$srcdir/chromium-$pkgver"
+ # https://crbug.com/710701
+ local _chrome_build_hash=$(curl -s https://chromium.googlesource.com/chromium/src.git/+/$pkgver?format=TEXT |
+ base64 -d | grep -Po '^parent \K[0-9a-f]{40}$')
+ if [[ -z $_chrome_build_hash ]]; then
+ error "Unable to fetch Chrome build hash."
+ return 1
+ fi
+ echo "LASTCHANGE=$_chrome_build_hash-" >build/util/LASTCHANGE
+
# Enable support for the Widevine CDM plugin
# libwidevinecdm.so is not included, but can be copied over from Chrome
# (Version string doesn't seem to matter so let's go with "Pinkie Pie")
sed "s/@WIDEVINE_VERSION@/Pinkie Pie/" ../chromium-widevine.patch |
patch -Np1
- # https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=853347
- patch -Np1 -i ../chromium-blink-gcc7.patch
-
# Fix build with glibc 2.26
patch -Np1 -i ../breakpad-use-ucontext_t.patch
+ # Fix incorrect inclusion of <string_view> in modes other than >= C++17
+ patch -Np1 -d third_party/crc32c/src <../crc32c-string-view-check.patch
+
# Fixes from Gentoo
- patch -Np1 -i ../chromium-gcc-r1.patch
- patch -Np1 -i ../chromium-gn-bootstrap-r14.patch
- patch -Np1 -i ../chromium-atk-r1.patch
+ patch -Np1 -i ../chromium-gn-bootstrap-r17.patch
# Use Python 2
find . -name '*.py' -exec sed -i -r 's|/usr/bin/python$|&2|g' {} +
@@ -114,9 +115,7 @@ prepare() {
ln -s /usr/bin/node third_party/node/linux/node-linux-x64/bin/
# VA-API patch
- gzip -df "${srcdir}/chromium-libva-remove.patch.gz"
- patch -p1 -i "${srcdir}/chromium-libva-remove.patch"
- patch -p1 -i "${srcdir}/chromium-vaapi-r12.patch"
+ patch -p1 -i "${srcdir}/chromium-vaapi-r14.patch"
# Fix paths.
sed -e 's|i386-linux-gnu/||g' \
@@ -155,6 +154,7 @@ build() {
'is_clang=false'
'clang_use_chrome_plugins=false'
'is_debug=false'
+ 'exclude_unwind_tables=true'
'fatal_linker_warnings=false'
'treat_warnings_as_errors=false'
'fieldtrial_testing_like_official_build=true'