summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorMaxim Baz2018-01-05 18:11:34 +0100
committerMaxim Baz2018-01-05 18:16:49 +0100
commit7f3cd63cc482a3104d7ad56fa7484b67b2fb49c8 (patch)
treee20ccd658dbb7a2e1e8642f02a1051fff778513a /PKGBUILD
parent05b5564a35763e1c9f11a5ec96a6e66c91c2adb2 (diff)
downloadaur-7f3cd63cc482a3104d7ad56fa7484b67b2fb49c8.tar.gz
Update to 63.0.3239.132
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD58
1 files changed, 32 insertions, 26 deletions
diff --git a/PKGBUILD b/PKGBUILD
index a3f8756a677b..7515a574f8a3 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -10,7 +10,7 @@
# Contributor: Daniel J Griffiths <ghost1227@archlinux.us>
pkgname=chromium-vaapi
-pkgver=63.0.3239.108
+pkgver=63.0.3239.132
pkgrel=1
_launcher_ver=5
pkgdesc="Chromium compiled with VA-API support for Intel Graphics"
@@ -33,37 +33,37 @@ install=chromium.install
source=(https://commondatastorage.googleapis.com/chromium-browser-official/chromium-$pkgver.tar.xz
chromium-launcher-$_launcher_ver.tar.gz::https://github.com/foutrelis/chromium-launcher/archive/v$_launcher_ver.tar.gz
chromium-$pkgver.txt::https://chromium.googlesource.com/chromium/src.git/+/$pkgver?format=TEXT
- chromium.desktop
- chromium-exclude_unwind_tables.patch
+ chromium-omnibox-unescape-fragment.patch
chromium-clang-r1.patch
chromium-webrtc-r0.patch
+ chromium-exclude_unwind_tables.patch
chromium-widevine.patch
chromium-vaapi-r15.patch
chromium-libva-r2.patch)
-sha256sums=('47d80798194da78bdd519b7ce012425b13cf89d6eb287e22a34342a245c31a2b'
+sha256sums=('84c46c2c42faaa102abe0647ee1213615a2522627124924c2741ddc2161b3d8d'
'4dc3428f2c927955d9ae117f2fb24d098cc6dd67adb760ac9c82b522ec8b0587'
- '6da2cc8e4ae13547763f946c331b2f819fbb8af01681b8b90564a95f8a423e58'
- '028a748a5c275de9b8f776f97909f999a8583a4b77fd1cd600b4fc5c0c3e91e9'
- 'e53dc6f259acd39df13874f8a0f440528fae764b859dd71447991a5b1fac7c9c'
+ 'ab330f30c14ea3b5e77976d674304b91cfb02251fe8771cecb0bb4092c7f6b74'
+ '814eb2cecb10cb697e24036b08aac41e88d0e38971741f9e946200764e2401ae'
'ab5368a3e3a67fa63b33fefc6788ad5b4a79089ef4db1011a14c3bee9fdf70c6'
'bcb2f4588cf5dcf75cde855c7431e94fdcc34bdd68b876a90f65ab9938594562'
+ 'e53dc6f259acd39df13874f8a0f440528fae764b859dd71447991a5b1fac7c9c'
'd6fdcb922e5a7fbe15759d39ccc8ea4225821c44d98054ce0f23f9d1f00c9808'
'a15b2ca40b5ca17d4763e41e226fb5faca22277027e8321675c87038dd9879d5'
'fe45088f04d6f5bb8b2aaad2ef2d4b495ee3a3a91b89fa342e54ac00fe99a97b')
# Possible replacements are listed in build/linux/unbundle/replace_gn_files.py
# Keys are the names in the above script; values are the dependencies in Arch
-declare -rgA _system_libs=(
- #[ffmpeg]=ffmpeg # https://crbug.com/731766
+readonly -A _system_libs=(
+ #[ffmpeg]=ffmpeg # https://crbug.com/731766
[flac]=flac
- #[freetype]=freetype2 # https://crbug.com/pdfium/733
- #[harfbuzz-ng]=harfbuzz-icu # https://crbug.com/768938
- #[icu]=icu # https://crbug.com/772655
+ #[freetype]=freetype2 # Using 'use_system_freetype=true' until M65
+ #[harfbuzz-ng]=harfbuzz # Using 'use_system_harfbuzz=true' until M65
+ #[icu]=icu # https://crbug.com/772655 + need M64 for ICU 60
[libdrm]=
[libjpeg]=libjpeg
- #[libpng]=libpng # https://crbug.com/752403#c10
- #[libvpx]=libvpx # https://bugs.gentoo.org/611394
+ #[libpng]=libpng # https://crbug.com/752403#c10
+ #[libvpx]=libvpx # https://bugs.gentoo.org/611394
[libwebp]=libwebp
[libxml]=libxml2
[libxslt]=libxslt
@@ -73,7 +73,13 @@ declare -rgA _system_libs=(
[yasm]=
[zlib]=minizip
)
-depends+=(${_system_libs[@]})
+readonly _unwanted_bundled_libs=(
+ ${!_system_libs[@]}
+ ${_system_libs[libjpeg]+libjpeg_turbo}
+ freetype
+ harfbuzz-ng
+)
+depends+=(${_system_libs[@]} freetype2 harfbuzz)
# Google API keys (see https://www.chromium.org/developers/how-tos/api-keys)
# Note: These are for Arch Linux use ONLY. For your own distribution, please
@@ -89,7 +95,7 @@ prepare() {
local _chrome_build_hash=$(base64 -d ../chromium-$pkgver.txt |
grep -Po '^parent \K[0-9a-f]{40}$')
if [[ -z $_chrome_build_hash ]]; then
- error "Unable to fetch Chrome build hash."
+ error "Unable to find Chrome build hash."
return 1
fi
echo "LASTCHANGE=$_chrome_build_hash-" >build/util/LASTCHANGE
@@ -103,6 +109,9 @@ prepare() {
# https://chromium-review.googlesource.com/c/chromium/src/+/712575
patch -Np1 -i ../chromium-exclude_unwind_tables.patch
+ # https://crbug.com/789163
+ patch -Np1 -i ../chromium-omnibox-unescape-fragment.patch
+
# Fixes from Gentoo
patch -Np1 -i ../chromium-clang-r1.patch
patch -Np1 -i ../chromium-webrtc-r0.patch
@@ -129,23 +138,18 @@ prepare() {
patch -p1 -i "${srcdir}/chromium-vaapi-r15.patch"
patch -p1 -i "${srcdir}/chromium-libva-r2.patch"
- # Fix paths.
- sed -e 's|i386-linux-gnu/||g' \
- -e 's|x86_64-linux-gnu/||g' \
- -e 's|/usr/lib/va/drivers|/usr/lib/dri|g' \
- -e 's|/usr/lib64/va/drivers|/usr/lib/dri|g' \
- -i content/common/sandbox_linux/bpf_gpu_policy_linux.cc
-
# Remove bundled libraries for which we will use the system copies; this
# *should* do what the remove_bundled_libraries.py script does, with the
# added benefit of not having to list all the remaining libraries
local _lib
- for _lib in ${!_system_libs[@]} ${_system_libs[libjpeg]+libjpeg_turbo}; do
+ for _lib in ${_unwanted_bundled_libs[@]}; do
find -type f -path "*third_party/$_lib/*" \
\! -path "*third_party/$_lib/chromium/*" \
\! -path "*third_party/$_lib/google/*" \
- \! -path "*base/third_party/icu/*" \
- \! -regex '.*\.\(gn\|gni\|isolate\|py\)' \
+ \! -path './base/third_party/icu/*' \
+ \! -path './third_party/freetype/src/src/psnames/pstables.h' \
+ \! -path './third_party/yasm/run_yasm.py' \
+ \! -regex '.*\.\(gn\|gni\|isolate\)' \
-delete
done
@@ -185,6 +189,8 @@ build() {
'ffmpeg_branding="Chrome"'
'proprietary_codecs=true'
'link_pulseaudio=true'
+ 'use_system_freetype=true'
+ 'use_system_harfbuzz=true'
'use_gtk3=true'
'use_gconf=false'
'use_gnome_keyring=false'