summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorMaxim Baz2018-07-26 17:04:04 +0200
committerMaxim Baz2018-07-26 17:32:57 +0200
commita2cb3caad2f7c9e7c05cabf0ba8a9b437e2a7353 (patch)
tree4d475c4e383e3ca8d24b858c232b631474caa50b /PKGBUILD
parent66781ed2d3b0f6c8be3c18e54b68839bcdc8d928 (diff)
downloadaur-a2cb3caad2f7c9e7c05cabf0ba8a9b437e2a7353.tar.gz
Update to 68.0.3440.75
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD25
1 files changed, 15 insertions, 10 deletions
diff --git a/PKGBUILD b/PKGBUILD
index ec49c363406a..d04b8b77bcdd 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -10,7 +10,7 @@
# Contributor: Daniel J Griffiths <ghost1227@archlinux.us>
pkgname=chromium-vaapi
-pkgver=67.0.3396.99
+pkgver=68.0.3440.75
pkgrel=1
_launcher_ver=6
pkgdesc="Chromium compiled with VA-API support for Intel Graphics"
@@ -32,22 +32,26 @@ optdepends=('pepper-flash: support for Flash content'
install=chromium.install
source=(https://commondatastorage.googleapis.com/chromium-browser-official/chromium-$pkgver.tar.xz
chromium-launcher-$_launcher_ver.tar.gz::https://github.com/foutrelis/chromium-launcher/archive/v$_launcher_ver.tar.gz
- remove-dependency-on-ffmpeg-internals-for-start-time.patch
x11-fix-mixup-between-DIP-pixel-coordinates.patch
blink-disable-XML-catalogs-at-runtime.patch
+ chromium-cors-string-r0.patch
chromium-ffmpeg-r1.patch
+ chromium-libjpeg-r0.patch
+ chromium-libwebp-shim-r0.patch
chromium-widevine-r2.patch
chromium-skia-harmony.patch
- chromium-vaapi-r18.patch)
-sha256sums=('452d6b9d8df6c88600aaeff3fad4c065574fd6dbee804e628b70e73a39c0a02a'
+ chromium-vaapi-r19.patch)
+sha256sums=('dc17783267853bdc0fb726363d2b8e30a0bf43b6cc2c768e1f37c92e8eb59541'
'04917e3cd4307d8e31bfb0027a5dce6d086edb10ff8a716024fbb8bb0c7dccf1'
- '2cc80f5ed8a9b42495a0f3ab3c1bae026b9081972269a1b6d407331d33f7d257'
'e2c2754536243a60fa70541bbd4121715eccd83caa8f1fb1873bd994cd81f871'
'98a5c41cf9687c52ee380d2b683c95387334c76254479c347bdb733646dab815'
+ 'f4141e48a25a1403250e9040c18936a16250ab707064dd54103066f40c7db41c'
'aa885330bc4180b78d915f9dfdfc3210038a0acab7b16735ea9828ab6a633bde'
+ '6b8fc570607631d3558e99a82e92c11eeae9c960ebb0a83c13d46344d4b6adca'
+ 'b368f3827ee4c47c942085e3d2cfbea43f8899b101e01500dbf6a7b01b2b29e0'
'02c69bb3954087db599def7f5b6d65cf8f7cf2ed81dfbdaa4bb7b51863b4df15'
'feca54ab09ac0fc9d0626770a6b899a6ac5a12173c7d0c1005bc3964ec83e7b3'
- 'a7dbcbfc5ec18606c260df67b98fb2440fe59a4c9ede0823fc43f3bcf439887b')
+ '4646e9f54a182cd7f7bb2df57063a729307c83959d6c4e6ca9ebd82bea9fbace')
# Possible replacements are listed in build/linux/unbundle/replace_gn_files.py
# Keys are the names in the above script; values are the dependencies in Arch
@@ -91,9 +95,6 @@ prepare() {
sed -i 's/OFFICIAL_BUILD/GOOGLE_CHROME_BUILD/' \
tools/generate_shim_headers/generate_shim_headers.py
- # https://crbug.com/731766
- patch -Np1 -i ../remove-dependency-on-ffmpeg-internals-for-start-time.patch
-
# https://crbug.com/707721
patch -Np1 -i ../x11-fix-mixup-between-DIP-pixel-coordinates.patch
@@ -104,7 +105,10 @@ prepare() {
patch -Np4 -i ../chromium-skia-harmony.patch
# Fixes from Gentoo
+ patch -Np1 -i ../chromium-cors-string-r0.patch
patch -Np1 -i ../chromium-ffmpeg-r1.patch
+ patch -Np1 -i ../chromium-libjpeg-r0.patch
+ patch -Np1 -i ../chromium-libwebp-shim-r0.patch
patch -Np1 -i ../chromium-widevine-r2.patch
# Remove compiler flags not supported by our system clang
@@ -120,7 +124,7 @@ prepare() {
# VA-API patch
msg2 'Applying VA-API patches'
- patch -Np1 -i ../chromium-vaapi-r18.patch
+ patch -Np1 -i ../chromium-vaapi-r19.patch
# Remove bundled libraries for which we will use the system copies; this
# *should* do what the remove_bundled_libraries.py script does, with the
@@ -159,6 +163,7 @@ build() {
'host_toolchain="//build/toolchain/linux/unbundle:default"'
'clang_use_chrome_plugins=false'
'is_official_build=true' # implies is_cfi=true on x86_64
+ 'use_cfi_icall=false' # https://crbug.com/866290
'is_debug=false'
'treat_warnings_as_errors=false'
'fieldtrial_testing_like_official_build=true'