summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorMaxim Baz2018-03-30 21:14:31 +0200
committerMaxim Baz2018-03-30 21:14:31 +0200
commitd7acf405c458be700b8f7c29a882b35e7a2576db (patch)
treefb91a238be154f11c4d108b3b657288590f06bc4 /PKGBUILD
parent617599a9a1f4dd3e84090dbe14d3e99813226b73 (diff)
downloadaur-d7acf405c458be700b8f7c29a882b35e7a2576db.tar.gz
Update to 65.0.3325.181-4
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD39
1 files changed, 20 insertions, 19 deletions
diff --git a/PKGBUILD b/PKGBUILD
index ea2c9ca0ae21..501b6e01c9bb 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -11,8 +11,8 @@
pkgname=chromium-vaapi
pkgver=65.0.3325.181
-pkgrel=3
-_launcher_ver=5
+pkgrel=4
+_launcher_ver=6
pkgdesc="Chromium compiled with VA-API support for Intel Graphics"
arch=('x86_64')
url="https://www.chromium.org/Home"
@@ -22,8 +22,8 @@ depends=('gtk3' 'nss' 'alsa-lib' 'xdg-utils' 'libxss' 'libcups' 'libgcrypt'
'desktop-file-utils' 'hicolor-icon-theme' 'libva')
provides=('chromium')
conflicts=('chromium')
-makedepends=('python2' 'gperf' 'yasm' 'mesa' 'ninja' 'nodejs' 'git' 'clang'
- 'lld')
+makedepends=('python' 'python2' 'gperf' 'yasm' 'mesa' 'ninja' 'nodejs' 'git'
+ 'clang' 'lld')
optdepends=('pepper-flash: support for Flash content'
'kdialog: needed for file dialogs in KDE'
'gnome-keyring: for storing passwords in GNOME keyring'
@@ -43,7 +43,7 @@ source=(https://commondatastorage.googleapis.com/chromium-browser-official/chrom
chromium-vaapi-r16.patch)
sha256sums=('93666448c6b96ec83e6a35a64cff40db4eb92a154fe1db4e7dab4761d0e38687'
- '4dc3428f2c927955d9ae117f2fb24d098cc6dd67adb760ac9c82b522ec8b0587'
+ '04917e3cd4307d8e31bfb0027a5dce6d086edb10ff8a716024fbb8bb0c7dccf1'
'2771c049b66c9aba3b945fe065f2610f164d55506eb5d71751a26aaf8b40d4ee'
'e3fb73b43bb8c69ff517e66b2cac73d6e759fd240003eb35598df9af442422fe'
'feca54ab09ac0fc9d0626770a6b899a6ac5a12173c7d0c1005bc3964ec83e7b3'
@@ -101,6 +101,10 @@ prepare() {
fi
echo "LASTCHANGE=$_chrome_build_hash-" >build/util/LASTCHANGE
+ # Allow building against system libraries in official builds
+ sed -i 's/OFFICIAL_BUILD/GOOGLE_CHROME_BUILD/' \
+ tools/generate_shim_headers/generate_shim_headers.py
+
# Enable support for the Widevine CDM plugin
# libwidevinecdm.so is not included, but can be copied over from Chrome
# (Version string doesn't seem to matter so let's go with "Pinkie Pie")
@@ -118,12 +122,8 @@ prepare() {
patch -Np1 -i ../chromium-math.h-r0.patch
patch -Np1 -i ../chromium-stdint.patch
- # Use Python 2
- find . -name '*.py' -exec sed -i -r 's|/usr/bin/python$|&2|g' {} +
-
- # There are still a lot of relative calls which need a workaround
- mkdir "$srcdir/python2-path"
- ln -s /usr/bin/python2 "$srcdir/python2-path/python"
+ # Force script incompatible with Python 3 to use /usr/bin/python2
+ sed -i '1s|python$|&2|' third_party/dom_distiller_js/protoc_plugins/*.py
mkdir -p third_party/node/linux/node-linux-x64/bin
ln -s /usr/bin/node third_party/node/linux/node-linux-x64/bin/
@@ -162,10 +162,6 @@ build() {
export CCACHE_SLOPPINESS=time_macros
fi
- export PATH="$srcdir/python2-path:$PATH"
- export TMPDIR="$srcdir/temp"
- mkdir -p "$TMPDIR"
-
export CC=clang
export CXX=clang++
export AR=ar
@@ -174,11 +170,9 @@ build() {
local _flags=(
'custom_toolchain="//build/toolchain/linux/unbundle:default"'
'host_toolchain="//build/toolchain/linux/unbundle:default"'
- 'is_clang=true'
'clang_use_chrome_plugins=false'
- 'is_cfi=true'
+ 'is_official_build=true'
'is_debug=false'
- 'fatal_linker_warnings=false'
'treat_warnings_as_errors=false'
'fieldtrial_testing_like_official_build=true'
'remove_webcore_debug_symbols=true'
@@ -186,7 +180,6 @@ build() {
'proprietary_codecs=true'
'link_pulseaudio=true'
'use_gnome_keyring=false'
- 'use_gold=false'
'use_sysroot=false'
'linux_use_bundled_binutils=false'
'use_custom_libcxx=false'
@@ -200,7 +193,15 @@ build() {
'use_vaapi=true'
)
+ # Facilitate deterministic builds (taken from build/config/compiler/BUILD.gn)
+ CFLAGS+=' -Wno-builtin-macro-redefined'
+ CXXFLAGS+=' -Wno-builtin-macro-redefined'
+ CPPFLAGS+=' -D__DATE__= -D__TIME__= -D__TIMESTAMP__='
+
if check_option strip y; then
+ _flags+=('symbol_level=0')
+
+ # Mimic exclude_unwind_tables=true
CFLAGS+=' -fno-unwind-tables -fno-asynchronous-unwind-tables'
CXXFLAGS+=' -fno-unwind-tables -fno-asynchronous-unwind-tables'
CPPFLAGS+=' -DNO_UNWIND_TABLES'