summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorDoug Newgard2018-08-09 22:42:44 -0500
committerDoug Newgard2018-08-09 22:42:44 -0500
commit7f4bf5b5aac0c7367f48378328f9aba022968670 (patch)
tree982c0b69a531a018f41ea2068abd4af638bbcee6 /PKGBUILD
parent7f1728858512bf2368ce1b50d9092e76350b44f0 (diff)
downloadaur-7f4bf5b5aac0c7367f48378328f9aba022968670.tar.gz
License update
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD10
1 files changed, 6 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 9380f9aefa9e..767cef87a713 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,15 +4,17 @@ pkgname=chromium-widevine
pkgdesc='A browser plugin designed for the viewing of premium video content'
pkgver=4.10.1146.0
_chrome_ver=68.0.3440.106
-pkgrel=2
+_license_date=$(curl -sI https://www.google.com/intl/en/chrome/privacy/eula_text.html | awk '/^last-modified/ {print $3" "$4" "$5}' | date +"%Y%m%d" -f -)
+_license_last=20180809
+pkgrel=3
epoch=1
arch=('x86_64')
url='https://www.widevine.com/'
license=('custom')
options=('!strip')
-source=('chrome-eula_text.html::https://www.google.com/intl/en/chrome/privacy/eula_text.html'
+source=("chrome-eula_text-$_license_date.html::https://www.google.com/intl/en/chrome/privacy/eula_text.html"
"https://dl.google.com/linux/deb/pool/main/g/google-chrome-stable/google-chrome-stable_${_chrome_ver}-1_amd64.deb")
-sha256sums=('8a0e9057c2a27bfcc74e210b848e6824e3c6c8f41232ca034362bcddfb95acbd'
+sha256sums=('f6aa8b7920d20c874deabc745517e0486e88fe9de667ad3d5fe6f61665ec725c'
'b2dd6af541bf4f44b65d487f7b208ee5ae922c78800d6d21786098c055156534')
prepare() {
@@ -27,5 +29,5 @@ package() {
depends=('chromium' 'gcc-libs' 'glib2' 'glibc' 'nspr' 'nss')
install -Dm644 libwidevinecdm.so -t "$pkgdir/usr/lib/chromium/"
- install -Dm644 chrome-eula_text.html "$pkgdir/usr/share/licenses/$pkgname/eula_text.html"
+ install -Dm644 chrome-eula_text-$_license_date.html "$pkgdir/usr/share/licenses/$pkgname/eula_text.html"
}