summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorbartus2020-07-03 17:43:46 +0200
committerbartus2020-07-04 02:41:34 +0200
commit53b1044804f6a923f1517cd07c7ed994c83e854a (patch)
treeed85beaf59376bcc8b89ca8f41ae96c62cb83fac /PKGBUILD
parentacab56a5ae99b73c5151162c3653261feb158180 (diff)
downloadaur-53b1044804f6a923f1517cd07c7ed994c83e854a.tar.gz
Fix pkgdesc and drop commented out lines.
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD16
1 files changed, 2 insertions, 14 deletions
diff --git a/PKGBUILD b/PKGBUILD
index d66051d0f57b..a77740cae5c8 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,7 +5,7 @@ pkgname=chronoengine
pkgver=4.0.0
_fragment="#tag=${pkgver}"
pkgrel=1
-pkgdesc="C++ library for physics simulation"
+pkgdesc="An Open Source Multi-physics Simulation Engine"
license=('custom')
arch=('i686' 'x86_64')
url="https://projectchrono.org/"
@@ -24,13 +24,8 @@ optdepends=(
"python: Python bindings"
"nvidia-utils: CUDA support in PARALLEL module"
"opencascade: add 3D CAD file support (STEP format)"
- )
+ )
#optdepends+=("intel-mkl: This library is currently used in Chrono for its parallel direct solver (Pardiso)")
-#options=(!buildflags) # discard arch buildflags as -fno-plt is not supported by gcc5 (cuda host compiler)
-#CPPFLAGS="-D_FORTIFY_SOURCE=2"
-#CXXFLAGS="-O2 -pipe -fstack-protector-strong"
-#CFLAGS=${CXXFLAGS}
-
source=("${pkgname}::git+https://github.com/projectchrono/chrono.git${_fragment}"
"git+https://github.com/google/benchmark.git"
"git+https://github.com/google/googletest.git"
@@ -60,13 +55,6 @@ CMAKE_FLAGS=( -DENABLE_MODULE_POSTPROCESS=ON
-DENABLE_MODULE_FSI=ON
-DCUDA_HOST_COMPILER=/opt/cuda/bin/gcc
)
-# -DCMAKE_C_COMPILER=/usr/bin/gcc-5
-# -DCMAKE_CXX_COMPILER=/usr/bin/g++-5
-# )
-# -DCUDA_PROPAGATE_HOST_FLAGS=OFF
-# )
-#CUDA_PROPAGATE_HOST_FLAGS=OFF also could be used to discard arch buildflags but drops also all internaly defined ones.
-#MKL works but building intel-mkl is such a paint that I skipped this feature
prepare() {
cd ${pkgname}