summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorschaap1372017-03-03 04:04:12 +0100
committerschaap1372017-03-03 04:04:12 +0100
commit66d44438e19fd6459a8f1c02cdbd5f7f33d14331 (patch)
tree42a660c0d2d8a1d4f0c0e337a236bc4ae03be935 /PKGBUILD
downloadaur-66d44438e19fd6459a8f1c02cdbd5f7f33d14331.tar.gz
initial commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD38
1 files changed, 38 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..ebc4d8a2ba50
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,38 @@
+# Maintainer: schaap137 <dojo86@gmail.com>
+pkgname=chugins-git
+pkgver=1.3.5.2.r86.g9ed524f
+pkgrel=1
+pkgdesc="Repository for ChuGins (to use with chuck)"
+arch=('i686' 'x86_64')
+url="https://github.com/ccrma/chugins"
+license=('GPL')
+ depends=('chuck')
+makedepends=('git')
+source=("$pkgname"::"git://github.com/ccrma/chugins.git")
+sha256sums=('SKIP')
+
+pkgver() {
+ # The version
+ cd "$srcdir/$pkgname"
+ git describe --long --tags | sed "s/\([^-]*-g\)/r\1/;s/-/./g" | sed "s/chugins.//g"
+}
+
+prepare() {
+ cd "$srcdir/$pkgname"
+ # Change JACK to PULSE if you use chuck-pulse
+ # or comment out the next line if you use chuck-alsa
+ sed -e 's/__LINUX_ALSA__/__LINUX_JACK__/g' -i **/makefile.linux
+ sed -e 's/\/usr\/local\/lib/\/usr\/lib/g' -i **/makefile.linux
+ sed -e 's/\/usr\/local\/lib/\/usr\/lib/g' -i makefile
+}
+
+build() {
+ cd "$srcdir/$pkgname"
+ make linux
+}
+
+package() {
+ cd "$srcdir/$pkgname"
+ mkdir -p "$pkgdir"/usr/lib/chuck
+ install -Dm755 **/*.chug "$pkgdir"/usr/lib/chuck/
+}