summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorÉtienne Deparis2019-03-23 20:12:42 +0100
committerÉtienne Deparis2019-03-23 20:12:42 +0100
commit0d0dd493fb36c823e6c0261a832703c86f5c7da3 (patch)
tree0669f4d4fd3aaa8487e075a7bc90073ec8948930 /PKGBUILD
downloadaur-0d0dd493fb36c823e6c0261a832703c86f5c7da3.tar.gz
0.4.1
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD19
1 files changed, 19 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..afe744427fbd
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,19 @@
+# Maintainer: Étienne Deparis <etienne@depar.is>
+pkgname=chwall
+pkgver=0.4.1
+pkgrel=1
+pkgdesc="A tiny wallpaper changer, written in python"
+arch=("any")
+url="https://git.deparis.io/chwall/about/"
+license=("WTFPL")
+depends=("gtk3" "python-cssselect" "python-gobject" "python-lxml"
+ "python-requests" "python-xdg" "python-yaml")
+makedepends=("python-setuptools" "imagemagick")
+source=("https://git.deparis.io/${pkgname}/snapshot/${pkgname}-${pkgver}.tar.gz")
+sha256sums=('6daeb1e54571284ba5affba5b7d3155b7dfa5f78d0775888a311b28c4c03a9b6')
+
+package() {
+ cd "$srcdir/$pkgname-$pkgver"
+
+ make ROOT="$pkgdir/" dist
+}