summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorÉtienne Deparis2023-04-04 20:18:34 +0200
committerÉtienne Deparis2023-04-04 20:18:34 +0200
commitb518014cc3cbeb6d23d12459d194438aac4f2651 (patch)
treeead84b0d038f30842adb9a648bbb6ee44f1dda8f /PKGBUILD
parentd37a02e0fd0fd41c2da18c82ae7e32f2323700b8 (diff)
downloadaur-b518014cc3cbeb6d23d12459d194438aac4f2651.tar.gz
0.5.12
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD19
1 files changed, 13 insertions, 6 deletions
diff --git a/PKGBUILD b/PKGBUILD
index cd86bc5cd567..40cdc8753549 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,16 +1,23 @@
# Maintainer: Étienne Deparis <etienne@depar.is>
pkgname=chwall
-pkgver=0.5.11
+pkgver=0.5.12
pkgrel=1
pkgdesc="A tiny wallpaper changer, written in python"
arch=("any")
url="https://git.umaneti.net/chwall/about/"
-license=("WTFPL")
-depends=("gtk3" "python-cssselect" "python-gobject" "python-lxml"
- "python-pillow" "python-requests" "python-xdg" "python-yaml")
-makedepends=("python-setuptools" "imagemagick")
+license=("custom:WTFPL")
+depends=("gdk-pixbuf2" "gobject-introspection-runtime" "gtk3"
+ "hicolor-icon-theme" "procps-ng" "python" "python-cssselect"
+ "python-gobject" "python-importlib-metadata" "python-lxml"
+ "python-pillow" "python-requests" "python-setuptools" "python-xdg"
+ "python-yaml")
+makedepends=("imagemagick")
+optdepends=('imagemagick: to extract wallpaper size in nitrogen mode'
+ 'libnotify: to send notification when wallpaper change'
+ 'nitrogen: to apply wallpaper on independant desktop manager'
+ 'xorg-xrandr: to extract screen config in nitrogen mode')
source=("https://git.umaneti.net/${pkgname}/snapshot/${pkgname}-${pkgver}.tar.gz")
-sha256sums=('bb2a90c40c7832ac834158ffa2b23ed41fc97e889eb6bb71c5473e9c07ccd9f1')
+sha256sums=('2c921aa0749a77f27075efad96a880a8ea15d7a442e9667dfccca6df88b97401')
package() {
cd "$pkgname-$pkgver"