summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorBalló György2018-01-29 00:55:01 +0100
committerBalló György2018-01-29 00:55:01 +0100
commita12b2c676772f2f8ee549547101317c7e8ce4f52 (patch)
tree5f01d64a53bd1807fd0fa6a1a41d800df61d3e18 /PKGBUILD
downloadaur-a12b2c676772f2f8ee549547101317c7e8ce4f52.tar.gz
Moved from [comunity] repository
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD59
1 files changed, 59 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..9650c113b0db
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,59 @@
+# $Id: PKGBUILD 266875 2017-11-15 14:29:11Z foutrelis $
+# Maintainer:
+# Contributor: tobias [tobias.archlinux.org]
+
+pkgname=cinepaint
+_realver=1.0-4
+pkgver=${_realver/-/.}
+pkgrel=6
+epoch=1
+pkgdesc="Sophisticated graphics manipulation programm supporting > 8bit pictures"
+arch=('x86_64')
+license=('LGPL' 'GPL' 'MIT')
+url="http://www.cinepaint.org"
+depends=('gtk2' 'openexr' 'lcms' 'libxpm' 'fltk' 'ftgl' 'libxxf86vm')
+makedepends=('python2' 'gutenprint>=5.2.9' 'optipng')
+optdepends=('python2: for python plug-ins'
+ 'gutenprint: for print plug-ins'
+ 'ghostscript: for pdf plug-ins')
+source=(http://downloads.sourceforge.net/sourceforge/$pkgname/$pkgname-$_realver.tar.gz
+ LICENSE cinepaint-libpng15.patch)
+sha1sums=('2049958784d211cc0be8f41f3473433479ba71fe'
+ 'ca8411db87f3fc51bbdfade22f4e1f555b2ee19e'
+ '3dfc9f06f02791aee59b60d33ddf9d305b0f1de5')
+
+prepare() {
+ cd $pkgname-$_realver
+ patch -p1 -i ../cinepaint-libpng15.patch
+ find . -name \*.png -exec optipng -quiet -force -fix {} +
+}
+
+build() {
+ export LDFLAGS="$LDFLAGS -lstdc++ -lm -lX11"
+
+ cd $pkgname-$_realver
+ ./configure --prefix=/usr \
+ --libdir=/usr/lib --mandir=/usr/share/man \
+ --enable-gtk2 --enable-pygimp --with-python=/usr/bin/python2
+
+ find . -name Makefile -exec sed -i 's/-Wl,,/-Wl,/g' {} +
+
+ make
+
+ sed -i -e "s|-I$srcdir/cinepaint||" \
+ -e "s|-I$srcdir/cinepaint-${_realver}/lib||" \
+ -e "/libcinepaint.la/d" \
+ -e "s|$srcdir/cinepaint-${_realver}/lib/.libs/\$dlname||" \
+ "cinepainttool"
+ sed -i "s/cinepaint.png/cinepaint/" "cinepaint.desktop"
+}
+
+package() {
+ cd $pkgname-$_realver
+ make DESTDIR="$pkgdir" install
+
+ # Fix default settings (FS#44464)
+ mv "$pkgdir/usr/share/cinepaint/${_realver}/gimprc" "$pkgdir/usr/share/cinepaint/${_realver}/cinepaintrc"
+
+ install -Dm644 "$srcdir/LICENSE" "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+}