summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorLucas Saliés Brum2017-09-22 21:35:35 -0400
committerLucas Saliés Brum2017-09-22 21:35:35 -0400
commit3fdd05dc32d47a44daffe5afae1a75de8c3e9539 (patch)
tree4524c2bd51d8892af0dd47238091bf65ec13963e /PKGBUILD
downloadaur-3fdd05dc32d47a44daffe5afae1a75de8c3e9539.tar.gz
Initial Commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD28
1 files changed, 28 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..d24d2a1707b9
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,28 @@
+# Maintainer: Lucas Saliés Brum <lucas@archlinux.com.br>
+
+pkgname='cinnamon-applet-desktop-capture-git'
+pkgver=r99.d9eb339
+pkgrel=1
+pkgdesc='A comprehensive screenshot and screencasting applet for Cinnamon.'
+arch=('any')
+url='https://github.com/rjanja/desktop-capture'
+license=('GPL')
+depends=('cinnamon')
+makedepends=('git')
+provides=('cinnamon-applet-desktop-capture')
+conflicts=('cinnamon-applet-desktop-capture')
+source=("${pkgname}::git+https://github.com/rjanja/desktop-capture")
+md5sums=(SKIP)
+_appletname='capture@rjanja'
+_appletdir="usr/share/cinnamon/applets/${_appletname}"
+
+pkgver() {
+ cd "${pkgname}"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+package() {
+ cd "${pkgname}"
+ install -dm0755 "${pkgdir}/${_appletdir}"
+ find "${_appletname}" -maxdepth 1 -type f -exec install -m0644 '{}' "${pkgdir}/${_appletdir}" \;
+}