summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorRealex-fire2015-06-09 00:09:26 +0700
committerRealex-fire2015-06-09 00:09:26 +0700
commite00ff34062be1f3361e3f05c0730a512ec4a3cce (patch)
tree4b7f3573c85b713e5cc2ae932d4c24ff51314306 /PKGBUILD
parent3dd86f11efb6738a764b7d5f2aab46e8cfb9917e (diff)
downloadaur-e00ff34062be1f3361e3f05c0730a512ec4a3cce.tar.gz
Add patch 'fix_build.patch'
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD15
1 files changed, 11 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index ac45790f9528..feef19ee6654 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,19 +4,21 @@
_pkgname=cinnamon-desktop
pkgname=${_pkgname}-git
-pkgver=103.f4ee205
+pkgver=174.15af3e9
pkgrel=1
pkgdesc="Library with common API for various Cinnamon modules"
arch=(i686 x86_64)
license=(GPL LGPL)
depends=('gtk3' 'libxkbfile')
-makedepends=('intltool' 'gobject-introspection' 'gnome-common' 'git')
+makedepends=('intltool' 'gobject-introspection' 'gnome-common' 'git' 'patch')
url="https://github.com/linuxmint/cinnamon-desktop"
provides=("${_pkgname}")
conflicts=("${_pkgname}")
options=('!emptydirs')
-source=("git+https://github.com/linuxmint/${_pkgname}.git")
-sha512sums=('SKIP')
+source=("git+https://github.com/linuxmint/${_pkgname}.git"
+ "fix_build.patch")
+sha512sums=("SKIP"
+ "6a58333fc2bd637c637aeb3823fa50c0f60492022927df086257d47a4e39c9afaa12196da60623c817b1fccb5d9c3a2b819df7904e930055452ebe9e5ba8f326")
install="${pkgname}.install"
pkgver() {
@@ -24,6 +26,11 @@ pkgver() {
echo $(git rev-list --count master).$(git rev-parse --short master)
}
+prepare() {
+ cd ${srcdir}/cinnamon-desktop
+ patch -Np1 -i ../fix_build.patch
+}
+
build() {
cd ${srcdir}/${_pkgname}
./autogen.sh --prefix=/usr --sysconfdir=/etc --localstatedir=/var \