summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorFabioLolix2023-01-27 22:11:42 +0100
committerFabioLolix2023-01-27 22:11:42 +0100
commit3902c6a34cd01fb8a60bde4663acccb6fd17e33a (patch)
tree3379dbbd5b079969b99e55d2f50c49eb8294053f /PKGBUILD
parent74967a0035ef1ff4d183ddc85bc7466cbaea0872 (diff)
downloadaur-cinnamon-git.tar.gz
revision
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD110
1 files changed, 52 insertions, 58 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 1d41b080b4e9..08a488916120 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,3 +1,4 @@
+# Maintainer: Fabio 'Lolix' Loli <lolix@disroot.org>
# Maintainer: Eli Schwartz <eschwartz@archlinux.org>
# Contributor: Alexandre Filgueira <alexfilgueira@cinnarch.com>
# Contributor: M0Rf30
@@ -5,90 +6,83 @@
# Contributor: CReimer
pkgname=cinnamon-git
-pkgver=4.4.8.r70.g14e5ccee8
+pkgver=5.6.7.r2.g4af7ab39c
pkgrel=1
pkgdesc="Linux desktop which provides advanced innovative features and a traditional user experience"
-arch=('x86_64')
-url="https://github.com/linuxmint/${pkgname%-git}"
-license=('GPL2')
-depends=('accountsservice' 'caribou' 'cinnamon-control-center' 'cinnamon-menus' 'cinnamon-screensaver'
- 'cinnamon-session' 'cinnamon-settings-daemon' 'cjs' 'gnome-backgrounds'
- 'gnome-themes-extra' 'gstreamer' 'libcroco' 'libgnomekbd' 'libkeybinder3' 'librsvg' 'muffin'
- 'network-manager-applet' 'nemo' 'polkit-gnome' 'python-cairo' 'python-dbus'
- 'python-gobject' 'python-pam' 'python-pexpect' 'python-pillow' 'python-pyinotify'
- 'python-pytz' 'python-tinycss2' 'python-xapp' 'timezonemap' 'xapps')
-optdepends=('blueberry: Bluetooth support'
+arch=(x86_64)
+url="https://github.com/linuxmint/cinnamon"
+license=(GPL2)
+depends=(accountsservice caribou cinnamon-control-center cinnamon-menus cinnamon-screensaver
+ cinnamon-session cinnamon-settings-daemon cjs gnome-backgrounds gsound
+ gnome-themes-extra gstreamer libcroco libgnomekbd libkeybinder3 librsvg muffin
+ network-manager-applet nemo polkit-gnome python-cairo python-dbus
+ python-gobject python-pam python-pexpect python-pillow python-pyinotify
+ python-pytz python-tinycss2 python-xapp python-requests timezonemap xapps)
+optdepends=('blueman: Bluetooth support'
'cinnamon-translations: i18n'
'gnome-panel: fallback mode'
'metacity: fallback mode'
- 'system-config-printer: printer settings')
-provides=("${pkgname%-git}=${pkgver}")
-conflicts=("${pkgname%-git}")
-makedepends=('git' 'intltool' 'gtk-doc' 'gobject-introspection')
+ 'system-config-printer: printer settings'
+ 'wget: cover download support in audio applet')
+makedepends=(git meson samurai gobject-introspection intltool)
+provides=(cinnamon)
+conflicts=(cinnamon)
options=('!emptydirs')
-source=("git+${url}.git"
- "0001-cinnamon-settings-don-t-rely-on-the-presence-of-cinn.patch"
+source=("git+https://github.com/linuxmint/cinnamon.git"
"set_wheel.diff"
"default-theme.patch")
-sha256sums=('SKIP'
- 'edb5c1cf43913da086aa11f303b0919bbea232d140afa33ceac52fe367d15fcf'
- '7517d651d440361947f9539fe8f42548d5eb43a09c28c9a11f51cfdfdefd042f'
- '566585873f38a79ec248b916645a2e081abec3c6d4df2c34339cde1f35375cc5')
+b2sums=('SKIP'
+ '3becf1f40068fc629109e6e7d464c3c484296afacc9ab6328b2ccbb3c9735bcbfa9550f9f73b430ede178ae668e37c660ce322b5b4d1873526de3d3d41185160'
+ '86c3a29acd132ca321f08fd81dd5a45707accdc035b2aeec95bf358b29072ff1eedb77b2566cf48d7253d1d791599f0f44938c4600761d711cb18b59019f1c62')
pkgver() {
- cd "${srcdir}"/${pkgname%-git}
-
- git describe --long | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+ cd cinnamon
+ git describe --long | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
}
prepare() {
- cd "${srcdir}"/${pkgname%-git}
-
- # Check for the cc-panel module path, not for the irrelevant binary
- # https://github.com/linuxmint/Cinnamon/pull/7382
- patch --no-backup-if-mismatch -p1 -i ../0001-cinnamon-settings-don-t-rely-on-the-presence-of-cinn.patch
+ cd cinnamon
- # Use wheel group instread of sudo (taken from Fedora)
- patch -Np1 -i ../set_wheel.diff
+ # Use wheel group instread of sudo (taken from Fedora)
+ #patch -Np1 -i ../set_wheel.diff
- # Set default theme to 'cinnamon'
- patch -Np1 -i ../default-theme.patch
+ # Set default theme to 'cinnamon'
+ patch -Np1 -i ../default-theme.patch
- # Replace MintInstall with GNOME Software
- sed -i 's/mintinstall.desktop/org.gnome.Software.desktop/' data/org.cinnamon.gschema.xml.in
+ # Replace MintInstall with GNOME Software
+ sed -i 's/mintinstall.desktop/org.gnome.Software.desktop/' data/org.cinnamon.gschema.xml
- # Add polkit agent to required components
- sed -i 's/RequiredComponents=\(.*\)$/RequiredComponents=\1polkit-gnome-authentication-agent-1;/' \
- files/cinnamon*.session.in
+ # Add polkit agent to required components
+ sed -i 's/RequiredComponents=\(.*\)$/RequiredComponents=\1polkit-gnome-authentication-agent-1;/' \
+ cinnamon*.session.in
- # https://github.com/linuxmint/Cinnamon/issues/3575#issuecomment-374887122
- # Cinnamon has no upstream backgrounds, use GNOME backgrounds instead
- sed -i 's|/usr/share/cinnamon-background-properties|/usr/share/gnome-background-properties|' \
- files/usr/share/cinnamon/cinnamon-settings/modules/cs_backgrounds.py
+ # https://github.com/linuxmint/Cinnamon/issues/3575#issuecomment-374887122
+ # Cinnamon has no upstream backgrounds, use GNOME backgrounds instead
+ sed -i 's|/usr/share/cinnamon-background-properties|/usr/share/gnome-background-properties|' \
+ files/usr/share/cinnamon/cinnamon-settings/modules/cs_backgrounds.py
- NOCONFIGURE=1 ./autogen.sh
+ [[ -d build ]] || mkdir build
}
build() {
- cd "${srcdir}"/${pkgname%-git}
+ cd cinnamon/build
- ./configure --prefix=/usr \
- --sysconfdir=/etc \
- --libexecdir=/usr/lib/cinnamon \
- --localstatedir=/var \
- --disable-static \
- --disable-gtk-doc \
- --disable-schemas-compile \
- --enable-compile-warnings=yes
+ # fix -mfpu= flags that break a build e.g. for neon on armv7 due to
+ # basically makepkg.conf being "bad' with default CFLAGS having
+ # -mfpu=vfpv3-d16
+ #export CFLAGS=`echo -n $CFLAGS | sed 's/-mfpu=vfpv3-d16/-mfpu=neon-vfpv4/g'`
+ #export CFLAGS="$CFLAGS -fvisibility=hidden"
+ #export CXXFLAGS="$CXXFLAGS -fvisibility=hidden"
- # https://bugzilla.gnome.org/show_bug.cgi?id=656231
- sed -i -e 's/ -shared / -Wl,-O1,--as-needed\0/g' libtool
+ meson --prefix=/usr \
+ --libexecdir=lib/cinnamon \
+ --buildtype=plain \
+ ..
- make
+ samu
}
package() {
- cd "${srcdir}"/${pkgname%-git}
-
- make DESTDIR="${pkgdir}" install
+ cd cinnamon/build
+ DESTDIR="${pkgdir}" samu install
}