summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorcodestation2015-07-02 20:19:27 -0430
committercodestation2015-07-02 20:20:19 -0430
commitdb9d11e7cfed543571e1fae774a60846216458b1 (patch)
tree9f9968567e4796a181845b5c399a895e468d10ea /PKGBUILD
downloadaur-db9d11e7cfed543571e1fae774a60846216458b1.tar.gz
Updated to 1.0.0
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD26
1 files changed, 26 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..24df819a887e
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,26 @@
+# Contributor: codestation <codestation404 at gmail dot com>
+pkgname=ciso
+pkgver=1.0.0
+pkgrel=1
+pkgdesc="PSP Iso Compressor"
+arch=(i686 x86_64)
+url="http://ciso.tenshu.fr"
+license=('GPL')
+depends=('zlib')
+source=(http://downloads.sourceforge.net/sourceforge/$pkgname/$pkgname-$pkgver.tar.gz)
+md5sums=('6091333f30fd61852d7d629b937aee34')
+
+build() {
+ cd "$srcdir/$pkgname-$pkgver"
+ # Avoid warnings about memset/memcpy
+ sed -i '/#include <stdlib.h>/ a\#include <string.h>' ciso.c
+ # Replace data type 'long' with 'int' for mantain structure sizes in 32/64 bits
+ sed -i '/long long/!s/long/int/' ciso.c ciso.h
+ make
+}
+
+package() {
+ cd "$srcdir/$pkgname-$pkgver"
+ mkdir -p "${pkgdir}/usr/bin"
+ make DESTDIR="${pkgdir}" install
+}