summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorHurricanePootis2023-12-22 10:09:52 -0600
committerHurricanePootis2023-12-22 10:09:52 -0600
commit8e8cf2c41a7d18802aeb449cb60092427f3ca2d0 (patch)
tree007c2357b1ac645759878f983db19422b3fbf823 /PKGBUILD
parent76275f969ebe379fdf062403516a457d653680e5 (diff)
downloadaur-8e8cf2c41a7d18802aeb449cb60092427f3ca2d0.tar.gz
Rework dependencies and cmake stuff
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD26
1 files changed, 18 insertions, 8 deletions
diff --git a/PKGBUILD b/PKGBUILD
index f4882706b86e..d37119a1b7e7 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -7,7 +7,7 @@
_pkgbase='citra'
pkgbase="$_pkgbase-git"
pkgname=("$_pkgbase-git" "$_pkgbase-qt-git")
-pkgver=r9914.59beeac4c
+pkgver=r9934.dccb8f6b1
pkgrel=1
pkgdesc="An experimental open-source Nintendo 3DS emulator/debugger"
arch=('i686' 'x86_64')
@@ -24,8 +24,8 @@ else
_enable_lto=off
fi
license=('GPL2')
-depends=('ffmpeg' 'speexdsp' 'mbedtls' 'libusb' 'openssl' 'glibc' 'gcc-libs' 'libfdk-aac' 'sndio' 'libbacktrace-git' 'zstd' 'soundtouch' 'fmt' 'libinih' 'openal')
-makedepends=('git' 'cmake' 'python' 'doxygen' 'rapidjson' 'llvm' 'qt6-tools' 'qt6-multimedia' 'gcc' 'glslang' 'vulkan-headers' 'nlohmann-json')
+depends=('ffmpeg' 'speexdsp' 'mbedtls' 'libusb' 'openssl' 'glibc' 'gcc-libs' 'libfdk-aac' 'sndio' 'libbacktrace-git' 'zstd' 'soundtouch' 'fmt' 'libinih' 'openal' 'enet')
+makedepends=('git' 'cmake' 'python' 'doxygen' 'rapidjson' 'llvm' 'qt6-tools' 'qt6-multimedia' 'gcc' 'glslang' 'vulkan-headers' 'nlohmann-json' 'catch2')
source=("$_pkgbase::git+https://github.com/citra-emu/citra.git"
"boost::git+https://github.com/citra-emu/ext-boost.git"
"nihstro::git+https://github.com/neobrain/nihstro.git"
@@ -169,16 +169,26 @@ build() {
-DENABLE_COMPATIBILITY_LIST_DOWNLOAD=ON \
-DUSE_DISCORD_PRESENCE=ON \
-DUSE_SYSTEM_BOOST=OFF \
+ -DUSE_SYSTEM_CATCH2=ON \
+ -DUSE_SYSTEM_CPP_HTTPLIB=OFF \
+ -DUSE_SYSTEM_CPP_JWT=OFF \
+ -DUSE_SYSTEM_CRYPTOPP=OFF \
+ -DUSE_SYSTEM_CUBEB=OFF \
+ -DUSE_SYSTEM_DYNARMIC=OFF \
+ -DUSE_SYSTEM_ENET=ON \
-DUSE_SYSTEM_FFMPEG_HEADERS=ON \
-DUSE_SYSTEM_FMT=ON \
- -DUSE_SYSTEM_SDL2=ON \
+ -DUSE_SYSTEM_GLSLANG=OFF \
+ -DUSE_SYSTEM_INIH=ON \
-DUSE_SYSTEM_JSON=ON \
-DUSE_SYSTEM_LIBUSB=ON \
- -DUSE_SYSTEM_OPENAL=ON \
- -DUSE_SYSTEM_OPENSSL=ON \
- -DUSE_SYSTEM_VULKAN_HEADERS=ON \
+ -DUSE_SYSTEM_LODEPNG=OFF \
+ -DUSE_SYSTEM_OPENAL=OFF \
+ -DUSE_SYSTEM_SDL2=ON \
-DUSE_SYSTEM_SOUNDTOUCH=ON \
- -DUSE_SYSTEM_INIH=ON \
+ -DUSE_SYSTEM_VMA=OFF \
+ -DUSE_SYSTEM_VULKAN_HEADERS=OFF \
+ -DUSE_SYSTEM_XBYAK=OFF \
-DUSE_SYSTEM_ZSTD=ON \
-DCMAKE_C_COMPILER=gcc \
-DCMAKE_CXX_COMPILER=g++ \