summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorEmmanuel Gil Peyrot2016-03-16 00:09:28 +0000
committerEmmanuel Gil Peyrot2016-03-16 00:09:28 +0000
commitc32787e3f87c01615cab45c5dc37dc5df36c597b (patch)
treec662344f16f78ad0628ee4f207bfa24a7a9cabd4 /PKGBUILD
parent96d7d1a4d98970b7b4d58fb05f28ca539ecfd8e4 (diff)
downloadaur-c32787e3f87c01615cab45c5dc37dc5df36c597b.tar.gz
The citra binary now depends on sdl2 instead of glfw, also update the other dependencies.
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD10
1 files changed, 6 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 367ef6317a6e..2db4ec8c597c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,13 +4,13 @@
_pkgbase='citra'
pkgbase="$_pkgbase-git"
pkgname=("$_pkgbase-git" "$_pkgbase-qt-git")
-pkgver=r2957.5fdfd78
+pkgver=r3317.becb758
pkgrel=1
pkgdesc="An experimental open-source Nintendo 3DS emulator/debugger"
arch=('i686' 'x86_64')
url="https://github.com/citra-emu/citra/"
license=('GPL2')
-makedepends=('git' 'cmake' 'glfw' 'qt5-base' 'shared-mime-info' 'desktop-file-utils')
+makedepends=('git' 'cmake' 'sdl2' 'qt5-base' 'shared-mime-info' 'desktop-file-utils')
source=("$_pkgbase::git+https://github.com/citra-emu/citra"
'git+https://github.com/citra-emu/ext-boost'
'git+https://github.com/svn2github/inih'
@@ -41,13 +41,15 @@ build() {
}
package_citra-git() {
- depends=('glfw')
+ depends=('sdl2' 'libpng')
install -Dm755 "$srcdir/$_pkgbase/build/src/citra/citra" "$pkgdir/usr/bin/$_pkgbase"
}
package_citra-qt-git() {
- depends=('qt5-base' 'libxkbcommon-x11' 'shared-mime-info' 'desktop-file-utils')
+ depends=('qt5-base' 'shared-mime-info' 'desktop-file-utils')
+ optdepends=('libxkbcommon-x11: for X11 support'
+ 'qt5-wayland: for Wayland support')
cd "$srcdir/$_pkgbase/build"
make DESTDIR="$pkgdir/" install