summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorKevin MacMartin2015-12-01 20:01:02 -0500
committerKevin MacMartin2015-12-01 20:01:02 -0500
commit65136d4c4a4f815c86662ff363abc8edd5acca30 (patch)
tree43e52583dd5413e7712a83829182092ffdfc8191 /PKGBUILD
parentc4dcdfb0f9fafeadf556cc7deb725fdee95523a3 (diff)
downloadaur-65136d4c4a4f815c86662ff363abc8edd5acca30.tar.gz
Add patch to fix build on i686
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD11
1 files changed, 8 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 3edfd6fd020c..795a5800845b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,7 +6,7 @@
_pkgname=cjdns
pkgname=$_pkgname-git
pkgver=17.1.r72.g68693cc
-pkgrel=1
+pkgrel=2
pkgdesc='A routing engine designed for security, scalability, speed and ease of use'
url='https://github.com/cjdelisle/cjdns'
license=('GPL3')
@@ -20,14 +20,19 @@ optdepends=(
)
provides=("$_pkgname")
conflicts=("$_pkgname")
-source=("git+$url#branch=crashey")
-sha512sums=('SKIP')
+source=("git+$url#branch=crashey" 'seccomp-bind-getsockaddr.patch')
+sha512sums=('SKIP' '547db6c204c029375fa435414dc3a15d4df3cb6d73a65ad7c9476454dc1cc5ded6cf5cfca75ccd580ed98b2ca4508127572eb4bd2d4c7847015c94c014bd18a4')
pkgver() {
cd $_pkgname
git describe --tags | sed 's|^[^-]*-v||;s|-|.r|;s|-|.|g'
}
+prepare() {
+ cd $_pkgname
+ patch -p1 < ../seccomp-bind-getsockaddr.patch
+}
+
build() {
cd $_pkgname
bash 'do'